aboutsummaryrefslogtreecommitdiff
path: root/sysutils/storcli
diff options
context:
space:
mode:
authorAdrian Chadd <adrian@FreeBSD.org>2015-08-31 18:39:32 +0000
committerAdrian Chadd <adrian@FreeBSD.org>2015-08-31 18:39:32 +0000
commit5af250a8756f3821378d0490892ae1fdf43efe3f (patch)
tree34cf6f386e2ad6726e5943eac78d6039c44670aa /sysutils/storcli
parent55551f727bfbce1de84244e095ae8edd46ca8a1c (diff)
downloadports-5af250a8756f3821378d0490892ae1fdf43efe3f.tar.gz
ports-5af250a8756f3821378d0490892ae1fdf43efe3f.zip
Notes
Diffstat (limited to 'sysutils/storcli')
-rw-r--r--sysutils/storcli/Makefile42
-rw-r--r--sysutils/storcli/distinfo2
-rw-r--r--sysutils/storcli/pkg-descr2
3 files changed, 46 insertions, 0 deletions
diff --git a/sysutils/storcli/Makefile b/sysutils/storcli/Makefile
new file mode 100644
index 000000000000..f976855bfcf8
--- /dev/null
+++ b/sysutils/storcli/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= storcli
+PORTVERSION= 1.16.06
+CATEGORIES= sysutils
+MASTER_SITES= http://www.avagotech.com/docs-and-downloads/raid-controllers/raid-controllers-common-files/
+DISTNAME= MR_SAS_StorCLI_${PORTVERSION:S!.!-!g}
+
+MAINTAINER= takefu@airport.fm
+COMMENT= SAS MegaRAID FreeBSD StorCLI
+
+LICENSE= storcli
+LICENSE_NAME= LSI
+LICENSE_TEXT= ${RESTRICTED}
+LICENSE_PERMS= no-dist-mirror no-dist-sell no-pkg-mirror no-pkg-sell auto-accept
+
+RESTRICTED= Source recipient must acknowledge license. Reproduction or redistribution prohibited. See http://www.lsi.com/Pages/user/eula.aspx
+
+USES= zip
+
+ONLY_FOR_ARCHS= i386 amd64
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= sbin/storcli
+PKGMESSAGE= ${WRKDIR}/pkg-message
+BINSRC= ${WRKDIR}/storcli_all_os/FreeBSD
+FETCH_AFTER_ARGS=-v
+
+post-extract:
+ @${TAR} xf ${WRKDIR}/storcli_all_os.zip -C${WRKSRC}
+ @${TAR} xf ${BINSRC}/storcli${ARCH:S/i386//:S/amd64/64/}.tar -C${WRKSRC}
+ @${REINPLACE_CMD} 's#\(StorCli\).*StorCli64#\1#'\
+ ${BINSRC}/FreeBSD_readme.txt
+ @${FMT} 75 79 ${BINSRC}/FreeBSD_readme.txt > ${WRKDIR}/pkg-message
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/storcli${ARCH:S/i386//:S/amd64/64/}\
+ ${STAGEDIR}${PREFIX}/sbin/storcli
+
+.include <bsd.port.mk>
diff --git a/sysutils/storcli/distinfo b/sysutils/storcli/distinfo
new file mode 100644
index 000000000000..7331dead7c76
--- /dev/null
+++ b/sysutils/storcli/distinfo
@@ -0,0 +1,2 @@
+SHA256 (MR_SAS_StorCLI_1-16-06.zip) = 97b059facadaf7ab2bece4513a0048612a425846431620c2bc169f7044477019
+SIZE (MR_SAS_StorCLI_1-16-06.zip) = 36982064
diff --git a/sysutils/storcli/pkg-descr b/sysutils/storcli/pkg-descr
new file mode 100644
index 000000000000..31197e428815
--- /dev/null
+++ b/sysutils/storcli/pkg-descr
@@ -0,0 +1,2 @@
+Command Line Interface for the MegaRAID SAS family of RAID controllers,
+used to configure and manage connected storage devices.