aboutsummaryrefslogtreecommitdiff
path: root/sysutils/symon/Makefile
diff options
context:
space:
mode:
authorUlrich Spörlein <uqs@FreeBSD.org>2013-11-19 11:48:31 +0000
committerUlrich Spörlein <uqs@FreeBSD.org>2013-11-19 11:48:31 +0000
commit4529cf3daf1992c82ce7d323ec0a87a493da1922 (patch)
treedcfb360175d2e94d5e90995c1363464dc80f61cc /sysutils/symon/Makefile
parente1b1102ee811e2467f801036fe7ea1acfbd4fa37 (diff)
downloadports-4529cf3daf1992c82ce7d323ec0a87a493da1922.tar.gz
ports-4529cf3daf1992c82ce7d323ec0a87a493da1922.zip
Notes
Diffstat (limited to 'sysutils/symon/Makefile')
-rw-r--r--sysutils/symon/Makefile22
1 files changed, 8 insertions, 14 deletions
diff --git a/sysutils/symon/Makefile b/sysutils/symon/Makefile
index 219743cfc8c6..588d72b1b6ba 100644
--- a/sysutils/symon/Makefile
+++ b/sysutils/symon/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= symon
-PORTVERSION= 2.85
-PORTREVISION= 1
+PORTVERSION= 2.86
CATEGORIES= sysutils
MASTER_SITES= http://wpd.home.xs4all.nl/symon/philes/ \
${MASTER_SITE_LOCAL}
@@ -18,6 +17,8 @@ USES= perl5
USE_PERL5= build
MAKE_JOBS_UNSAFE= yes
+USERS= _symon
+
# Synonym for WITHOUT_SYMUX
.if defined(WITHOUT_RRD)
WITHOUT_SYMUX= yes
@@ -34,7 +35,6 @@ IGNORE= you have defined both WITHOUT_SYMUX or WITHOUT_RRD *and* WITHOUT_SYMON
SUBDIR= lib
.if !defined(WITHOUT_SYMON)
SUBDIR+= symon
-MAN8+= symon.8
PLIST_SUB+= SYMON=""
USE_RC_SUBR+= symon
.else
@@ -42,7 +42,6 @@ PLIST_SUB+= SYMON="@comment "
.endif
.if !defined(WITHOUT_SYMUX)
SUBDIR+= symux
-MAN8+= symux.8
PLIST_SUB+= SYMUX=""
USE_RC_SUBR+= symux
.else
@@ -50,23 +49,18 @@ PLIST_SUB+= SYMUX="@comment "
.endif
SUBDIR+= client
-MAKE_ARGS+= SUBDIR="${SUBDIR}" RRDDIR="${LOCALBASE}"
+MAKE_ARGS+= SUBDIR="${SUBDIR}" RRDDIR="${LOCALBASE}" \
+ SYSCONFDIR="${PREFIX}/etc" PREFIX="${STAGEDIR}/${PREFIX}"
-NO_STAGE= yes
.include <bsd.port.pre.mk>
post-extract:
@${MV} ${WRKDIR}/${PORTNAME} ${WRKSRC}
-.if ${OSVERSION} < 700000
+# We need to teach symon about mbstat changes/removal in r253351 and r253361.
+.if ${OSVERSION} > 1000000
post-patch:
- @${REINPLACE_CMD} 's/^LIBS+=/LIBS= -pthread /' ${WRKSRC}/symux/Makefile
+ @${RM} ${WRKSRC}/platform/FreeBSD/sm_mbuf.c
.endif
-pre-install:
- @${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
-
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.post.mk>