aboutsummaryrefslogtreecommitdiff
path: root/sysutils/syslog-ng-devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-14 12:46:33 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-11-14 12:46:33 +0000
commit36dc0b3c5ad0e02227cddbf6fa29999e5921368e (patch)
treecc7a26bf4c678695f05b09d1fd7bd655293c1c58 /sysutils/syslog-ng-devel
parent15b7aa1860be31fad68c061658e69249bcaad906 (diff)
downloadports-36dc0b3c5ad0e02227cddbf6fa29999e5921368e.tar.gz
ports-36dc0b3c5ad0e02227cddbf6fa29999e5921368e.zip
Notes
Diffstat (limited to 'sysutils/syslog-ng-devel')
-rw-r--r--sysutils/syslog-ng-devel/Makefile55
-rw-r--r--sysutils/syslog-ng-devel/distinfo3
-rw-r--r--sysutils/syslog-ng-devel/files/patch-configure23
-rw-r--r--sysutils/syslog-ng-devel/files/patch-syslog-names.c20
-rw-r--r--sysutils/syslog-ng-devel/files/patch-syslog-ng.h15
-rw-r--r--sysutils/syslog-ng-devel/files/syslog-ng.conf.sample181
-rw-r--r--sysutils/syslog-ng-devel/files/syslog-ng.sh.in36
-rw-r--r--sysutils/syslog-ng-devel/pkg-descr10
-rw-r--r--sysutils/syslog-ng-devel/pkg-message25
-rw-r--r--sysutils/syslog-ng-devel/pkg-plist11
10 files changed, 379 insertions, 0 deletions
diff --git a/sysutils/syslog-ng-devel/Makefile b/sysutils/syslog-ng-devel/Makefile
new file mode 100644
index 000000000000..3545f18c5888
--- /dev/null
+++ b/sysutils/syslog-ng-devel/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: syslog-ng
+# Date created: 10 november 1006
+# Whom: Ivan Lago <ivan.lago@ifom-ieo-campus.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= syslog-ng
+PORTVERSION= 2.0.0
+CATEGORIES= sysutils
+MASTER_SITES= http://www.balabit.com/downloads/syslog-ng/2.0/src/
+
+MAINTAINER= ivan.lago@ifom-ieo-campus.it
+COMMENT= A powerful syslogd replacement
+
+MAN5= syslog-ng.conf.5
+MAN8= syslog-ng.8
+
+USE_RC_SUBR= syslog-ng.sh
+GNU_CONFIGURE= yes
+USE_GCC= 3.3+
+
+PKGMESSAGE= ${WRKDIR}/MESSAGE
+
+LIB_DEPENDS= glib-2.0:${PORTSDIR}/devel/glib20 \
+ evtlog.0:${PORTSDIR}/sysutils/eventlog
+
+.if defined(WITH_TCP_WRAPPERS)
+CONFIGURE_ARGS+=--enable-tcp-wrapper
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's:__PREFIX__:${PREFIX}:g' ${WRKSRC}/src/syslog-ng.h
+
+post-build:
+ @${SED} -e 's,__PREFIX__,${PREFIX},g' ${PKGDIR}/pkg-message > ${PKGMESSAGE}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} \
+ ${PREFIX}/share/doc/syslog-ng \
+ ${PREFIX}/share/doc/syslog-ng/sgml
+ ${INSTALL_DATA} ${WRKSRC}/AUTHORS ${PREFIX}/share/doc/syslog-ng
+ ${INSTALL_DATA} ${WRKSRC}/COPYING ${PREFIX}/share/doc/syslog-ng
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${PREFIX}/share/doc/syslog-ng
+ ${INSTALL_DATA} ${WRKSRC}/NEWS ${PREFIX}/share/doc/syslog-ng
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/syslog-ng
+.endif
+ @if [ ! -f ${PREFIX}/etc/syslog-ng/syslog-ng.conf.sample ]; then \
+ ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} ${PREFIX}/etc/syslog-ng; \
+ ${INSTALL_DATA} ${FILESDIR}/syslog-ng.conf.sample ${PREFIX}/etc/syslog-ng; \
+ fi
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/sysutils/syslog-ng-devel/distinfo b/sysutils/syslog-ng-devel/distinfo
new file mode 100644
index 000000000000..567cd841aa04
--- /dev/null
+++ b/sysutils/syslog-ng-devel/distinfo
@@ -0,0 +1,3 @@
+MD5 (syslog-ng-2.0.0.tar.gz) = 134db2e3d7b16bb70fd86d749cc2e4fd
+SHA256 (syslog-ng-2.0.0.tar.gz) = 6f1e22554eb7292d9322de0623fd13dbd11bdda8d52d66280c1d4e193a69fac7
+SIZE (syslog-ng-2.0.0.tar.gz) = 337553
diff --git a/sysutils/syslog-ng-devel/files/patch-configure b/sysutils/syslog-ng-devel/files/patch-configure
new file mode 100644
index 000000000000..2de447e76178
--- /dev/null
+++ b/sysutils/syslog-ng-devel/files/patch-configure
@@ -0,0 +1,23 @@
+--- configure.orig Wed Nov 8 15:14:56 2006
++++ configure Wed Nov 8 15:16:36 2006
+@@ -3426,7 +3426,7 @@
+ echo $ECHO_N "checking how to enable static linking for certain libraries... $ECHO_C" >&6
+ ldversion=`ld -V 2>&1 | head -1`
+ ostype=`uname -s`
+-if echo $ldversion | egrep "GNU|Solaris" > /dev/null; then
++if echo $ldversion | egrep "Solaris" > /dev/null; then
+ LD_START_STATIC="-Wl,-Bstatic"
+ LD_END_STATIC="-Wl,-Bdynamic"
+ echo "$as_me:$LINENO: result: GNU or Solaris" >&5
+@@ -3441,6 +3441,11 @@
+ LD_END_STATIC="-Wl,-bdynamic"
+ echo "$as_me:$LINENO: result: AIX" >&5
+ echo "${ECHO_T}AIX" >&6
++elif test "$ostype" = "FreeBSD"; then
++ LD_START_STATIC=""
++ LD_END_STATIC=""
++ echo "$as_me:$LINENO: result: FreeBSD" >&5
++echo "${ECHO_T}FreeBSD" >&6
+ else
+ LD_START_STATIC=""
+ LD_END_STATIC=""
diff --git a/sysutils/syslog-ng-devel/files/patch-syslog-names.c b/sysutils/syslog-ng-devel/files/patch-syslog-names.c
new file mode 100644
index 000000000000..8ae34d897e72
--- /dev/null
+++ b/sysutils/syslog-ng-devel/files/patch-syslog-names.c
@@ -0,0 +1,20 @@
+--- src/syslog-names.c.orig Wed Nov 8 14:43:03 2006
++++ src/syslog-names.c Wed Nov 8 14:50:06 2006
+@@ -45,6 +45,7 @@
+ #ifdef LOG_AUTHPRIV
+ {"authpriv", LOG_AUTHPRIV},
+ #endif
++ {"console", LOG_CONSOLE },
+ #ifdef LOG_CRON
+ {"cron", LOG_CRON},
+ #endif
+@@ -56,7 +57,8 @@
+ {"lpr", LOG_LPR},
+ {"mail", LOG_MAIL},
+ {"news", LOG_NEWS},
+- {"security", LOG_AUTH}, /* DEPRECATED */
++ {"ntp", LOG_NTP },
++ {"security", LOG_SECURITY },
+ {"syslog", LOG_SYSLOG},
+ {"user", LOG_USER},
+ {"uucp", LOG_UUCP},
diff --git a/sysutils/syslog-ng-devel/files/patch-syslog-ng.h b/sysutils/syslog-ng-devel/files/patch-syslog-ng.h
new file mode 100644
index 000000000000..bc4091efacfd
--- /dev/null
+++ b/sysutils/syslog-ng-devel/files/patch-syslog-ng.h
@@ -0,0 +1,15 @@
+--- src/syslog-ng.h.orig Wed Nov 8 14:45:18 2006
++++ src/syslog-ng.h Wed Nov 8 14:45:44 2006
+@@ -38,10 +38,10 @@
+
+ #if ENABLE_DEBUG
+ #define PATH_SYSLOG_NG_CONF "syslog-ng.conf"
+-#define PATH_PIDFILE "syslog-ng.pid"
++#define PATH_PIDFILE "syslog.pid"
+ #else
+ #define PATH_SYSLOG_NG_CONF PATH_SYSCONFDIR "/syslog-ng.conf"
+-#define PATH_PIDFILE "/var/run/syslog-ng.pid"
++#define PATH_PIDFILE "/var/run/syslog.pid"
+ #endif
+
+ #define LOG_PRIORITY_LISTEN 100
diff --git a/sysutils/syslog-ng-devel/files/syslog-ng.conf.sample b/sysutils/syslog-ng-devel/files/syslog-ng.conf.sample
new file mode 100644
index 000000000000..c2059c4165db
--- /dev/null
+++ b/sysutils/syslog-ng-devel/files/syslog-ng.conf.sample
@@ -0,0 +1,181 @@
+#
+# This sample configuration file is essentially equilivent to the stock
+# FreeBSD /etc/syslog.conf file.
+#
+
+#
+# options
+#
+options { long_hostnames(off); sync(0); };
+
+#
+# sources
+#
+source src { unix-dgram("/var/run/log");
+ unix-dgram("/var/run/logpriv" perm(0600));
+ udp(); internal(); file("/dev/klog"); };
+
+#
+# destinations
+#
+destination messages { file("/var/log/messages"); };
+destination security { file("/var/log/security"); };
+destination authlog { file("/var/log/auth.log"); };
+destination maillog { file("/var/log/maillog"); };
+destination lpd-errs { file("/var/log/lpd-errs"); };
+destination xferlog { file("/var/log/xferlog"); };
+destination cron { file("/var/log/cron"); };
+destination debuglog { file("/var/log/debug.log"); };
+destination consolelog { file("/var/log/console.log"); };
+destination all { file("/var/log/all.log"); };
+destination newscrit { file("/var/log/news/news.crit"); };
+destination newserr { file("/var/log/news/news.err"); };
+destination newsnotice { file("/var/log/news/news.notice"); };
+destination slip { file("/var/log/slip.log"); };
+destination ppp { file("/var/log/ppp.log"); };
+destination console { file("/dev/console"); };
+destination allusers { usertty("*"); };
+#destination loghost { udp("loghost" port(514)); };
+
+#
+# log facility filters
+#
+filter f_auth { facility(auth); };
+filter f_authpriv { facility(authpriv); };
+filter f_not_authpriv { not facility(authpriv); };
+filter f_console { facility(console); };
+filter f_cron { facility(cron); };
+filter f_daemon { facility(daemon); };
+filter f_ftp { facility(ftp); };
+filter f_kern { facility(kern); };
+filter f_lpr { facility(lpr); };
+filter f_mail { facility(mail); };
+filter f_news { facility(news); };
+filter f_security { facility(security); };
+filter f_user { facility(user); };
+filter f_uucp { facility(uucp); };
+filter f_local0 { facility(local0); };
+filter f_local1 { facility(local1); };
+filter f_local2 { facility(local2); };
+filter f_local3 { facility(local3); };
+filter f_local4 { facility(local4); };
+filter f_local5 { facility(local5); };
+filter f_local6 { facility(local6); };
+filter f_local7 { facility(local7); };
+
+#
+# log level filters
+#
+filter f_emerg { level(emerg); };
+filter f_alert { level(alert..emerg); };
+filter f_crit { level(crit..emerg); };
+filter f_err { level(err..emerg); };
+filter f_warning { level(warning..emerg); };
+filter f_notice { level(notice..emerg); };
+filter f_info { level(info..emerg); };
+filter f_debug { level(debug..emerg); };
+filter f_is_debug { level(debug); };
+
+#
+# program filters
+#
+filter f_ppp { program("ppp"); };
+filter f_slip { program("startslip"); };
+
+#
+# *.err;kern.warning;auth.notice;mail.crit /dev/console
+#
+log { source(src); filter(f_err); destination(console); };
+log { source(src); filter(f_kern); filter(f_warning); destination(console); };
+log { source(src); filter(f_auth); filter(f_notice); destination(console); };
+log { source(src); filter(f_mail); filter(f_crit); destination(console); };
+
+#
+# *.notice;authpriv.none;kern.debug;lpr.info;mail.crit;news.err /var/log/messages
+#
+log { source(src); filter(f_notice); filter(f_not_authpriv); destination(messages); };
+log { source(src); filter(f_kern); filter(f_debug); destination(messages); };
+log { source(src); filter(f_lpr); filter(f_info); destination(messages); };
+log { source(src); filter(f_mail); filter(f_crit); destination(messages); };
+log { source(src); filter(f_news); filter(f_err); destination(messages); };
+
+#
+# security.* /var/log/security
+#
+log { source(src); filter(f_security); destination(security); };
+
+#
+# auth.info;authpriv.info /var/log/auth.log
+log { source(src); filter(f_auth); filter(f_info); destination(authlog); };
+log { source(src); filter(f_authpriv); filter(f_info); destination(authlog); };
+
+#
+# mail.info /var/log/maillog
+#
+log { source(src); filter(f_mail); filter(f_info); destination(maillog); };
+
+#
+# lpr.info /var/log/lpd-errs
+#
+log { source(src); filter(f_lpr); filter(f_info); destination(lpd-errs); };
+
+#
+# ftp.info /var/log/xferlog
+#
+log { source(src); filter(f_ftp); filter(f_info); destination(xferlog); };
+
+#
+# cron.* /var/log/cron
+#
+log { source(src); filter(f_cron); destination(cron); };
+
+#
+# *.=debug /var/log/debug.log
+#
+log { source(src); filter(f_is_debug); destination(debuglog); };
+
+#
+# *.emerg *
+#
+log { source(src); filter(f_emerg); destination(allusers); };
+
+#
+# uncomment this to log all writes to /dev/console to /var/log/console.log
+# console.info /var/log/console.log
+#
+#log { source(src); filter(f_console); filter(f_info); destination(consolelog); };
+
+#
+# uncomment this to enable logging of all log messages to /var/log/all.log
+# touch /var/log/all.log and chmod it to mode 600 before it will work
+# *.* /var/log/all.log
+#
+#log { source(src); destination(all); };
+
+#
+# uncomment this to enable logging to a remote loghost named loghost
+# *.* @loghost
+#
+#log { source(src); destination(loghost); };
+
+#
+# uncomment these if you're running inn
+# news.crit /var/log/news/news.crit
+# news.err /var/log/news/news.err
+# news.notice /var/log/news/news.notice
+#
+#log { source(src); filter(f_news); filter(f_crit); destination(newscrit); };
+#log { source(src); filter(f_news); filter(f_err); destination(newserr); };
+#log { source(src); filter(f_news); filter(f_notice); destination(newsnotice); };
+
+#
+# !startslip
+# *.* /var/log/slip.log
+#
+log { source(src); filter(f_slip); destination(slip); };
+
+#
+# !ppp
+# *.* /var/log/ppp.log
+#
+log { source(src); filter(f_ppp); destination(ppp); };
diff --git a/sysutils/syslog-ng-devel/files/syslog-ng.sh.in b/sysutils/syslog-ng-devel/files/syslog-ng.sh.in
new file mode 100644
index 000000000000..341143b8a2f3
--- /dev/null
+++ b/sysutils/syslog-ng-devel/files/syslog-ng.sh.in
@@ -0,0 +1,36 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: syslogd
+# REQUIRE: mountcritremote cleanvar
+# BEFORE: SERVERS
+
+#
+# Add the following line to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+#syslog_ng_enable="YES"
+#
+
+. %%RC_SUBR%%
+
+name=syslog_ng
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/sbin/syslog-ng
+required_files=%%PREFIX%%/etc/syslog-ng/syslog-ng.conf
+pidfile=/var/run/syslog.pid
+extra_commands=reload
+stop_postcmd=stop_postcmd
+
+load_rc_config $name
+
+: ${syslog_ng_enable:="NO"}
+
+stop_postcmd() {
+ rm -f $pidfile
+}
+
+run_rc_command "$1"
diff --git a/sysutils/syslog-ng-devel/pkg-descr b/sysutils/syslog-ng-devel/pkg-descr
new file mode 100644
index 000000000000..99d4182ac377
--- /dev/null
+++ b/sysutils/syslog-ng-devel/pkg-descr
@@ -0,0 +1,10 @@
+syslog-ng (Syslog New Generation) is a powerful replacement for the standard
+syslogd. Features include:
+
+ - ability to filter messages based on content using regular expressions
+ - forwarding logs on TCP
+
+WWW: http://www.balabit.com/products/syslog_ng/
+
+-Vince Valenti
+vince@blue-box.net
diff --git a/sysutils/syslog-ng-devel/pkg-message b/sysutils/syslog-ng-devel/pkg-message
new file mode 100644
index 000000000000..223446c811e0
--- /dev/null
+++ b/sysutils/syslog-ng-devel/pkg-message
@@ -0,0 +1,25 @@
+
+syslog-ng is now installed! To replace FreeBSD's standard syslogd
+(/usr/sbin/syslogd), complete these steps:
+
+1. Create a configuration file named __PREFIX__/etc/syslog-ng/syslog-ng.conf
+ (a sample named syslog-ng.conf.sample has been included)
+
+2. Configure syslog-ng to start automatically by adding the following
+ to /etc/rc.conf:
+
+ syslog_ng_enable="YES"
+
+3. Prevent the standard FreeBSD syslogd from starting automatically by
+ adding a line to the end of your /etc/rc.conf file that reads:
+
+ syslogd_enable="NO"
+
+4. Shut down the standard FreeBSD syslogd:
+
+ kill `cat /var/run/syslog.pid`
+
+5. Start syslog-ng:
+
+ __PREFIX__/etc/rc.d/syslog-ng.sh start
+
diff --git a/sysutils/syslog-ng-devel/pkg-plist b/sysutils/syslog-ng-devel/pkg-plist
new file mode 100644
index 000000000000..bcec734c4727
--- /dev/null
+++ b/sysutils/syslog-ng-devel/pkg-plist
@@ -0,0 +1,11 @@
+@unexec %D/etc/rc.d/syslog-ng.sh stop > /dev/null 2>&1 || true
+etc/syslog-ng/syslog-ng.conf.sample
+sbin/syslog-ng
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/sgml
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm etc/syslog-ng