aboutsummaryrefslogtreecommitdiff
path: root/sysutils/syslog-ng3
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2008-11-18 23:21:09 +0000
committerWesley Shields <wxs@FreeBSD.org>2008-11-18 23:21:09 +0000
commit7e7393f75e45e2d157bfae746b25ade77c3179e9 (patch)
tree7c3a938f67299c62f0d25c0bed167709cecb0278 /sysutils/syslog-ng3
parentd8e9ae25b1d25b548fa7b30af75e38973fb5a57c (diff)
downloadports-7e7393f75e45e2d157bfae746b25ade77c3179e9.tar.gz
ports-7e7393f75e45e2d157bfae746b25ade77c3179e9.zip
Notes
Diffstat (limited to 'sysutils/syslog-ng3')
-rw-r--r--sysutils/syslog-ng3/Makefile9
-rw-r--r--sysutils/syslog-ng3/files/patch-src_main.c22
2 files changed, 26 insertions, 5 deletions
diff --git a/sysutils/syslog-ng3/Makefile b/sysutils/syslog-ng3/Makefile
index 9ba5a261535b..d3958e7ae664 100644
--- a/sysutils/syslog-ng3/Makefile
+++ b/sysutils/syslog-ng3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= syslog-ng
PORTVERSION= 2.0.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= http://www.balabit.com/downloads/files/syslog-ng/sources/2.0/src/
PKGNAMESUFFIX= 2
@@ -27,12 +27,11 @@ USE_GNOME= glib20
SUB_FILES= pkg-message
SUB_LIST= RC_SUBR_SUFFIX=${RC_SUBR_SUFFIX}
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
CONFIGURE_ARGS= --sysconfdir=${LOCALBASE}/etc --localstatedir=/var/db \
- --enable-dynamic-linking --mandir=${PREFIX}/man \
- --with-libnet=${LOCALBASE}/bin
-CONFIGURE_ENV= CFLAGS="`${LIBNET_CONFIG} --cflags`" \
+ --enable-dynamic-linking --with-libnet=${LOCALBASE}/bin
+CONFIGURE_ENV= CFLAGS="`${LIBNET_CONFIG} --cflags`" \
LDFLAGS="`${LIBNET_CONFIG} --libs`"
.if defined(WITH_TCP_WRAPPERS)
diff --git a/sysutils/syslog-ng3/files/patch-src_main.c b/sysutils/syslog-ng3/files/patch-src_main.c
new file mode 100644
index 000000000000..e6423ef8fa25
--- /dev/null
+++ b/sysutils/syslog-ng3/files/patch-src_main.c
@@ -0,0 +1,22 @@
+Patch for CVE-2008-5110
+
+Obtained from: http://bugs.debian.org/cgi-bin/bugreport.cgi?msg=14;mbox=yes;bug=505791
+Note: was not able to cleanly apply the original patch, so it was recreated
+ by hand using the original submission contents
+
+--- src/main.c.orig 2008-03-23 23:35:27.000000000 +0300
++++ src/main.c 2008-11-18 14:38:13.000000000 +0300
+@@ -275,6 +275,13 @@
+ {
+ if (chroot_dir)
+ {
++ if (chdir(chroot_dir) < 0)
++ {
++ msg_error("Error during chdir() before chroot()",
++ evt_tag_errno(EVT_TAG_OSERROR, errno),
++ NULL);
++ return 0;
++ }
+ if (chroot(chroot_dir) < 0)
+ {
+ msg_error("Error during chroot()",