aboutsummaryrefslogtreecommitdiff
path: root/sysutils/syslog-ng
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2012-09-11 14:05:31 +0000
committerCy Schubert <cy@FreeBSD.org>2012-09-11 14:05:31 +0000
commit60c6047b8af543903616d7f76f7ef6b6bc434803 (patch)
treec7dc94fa46ad3c8c647e2091ecb186c40b02a8c7 /sysutils/syslog-ng
parente0372106868731ef04fe18a6001698bdcb9cd345 (diff)
Notes
Diffstat (limited to 'sysutils/syslog-ng')
-rw-r--r--sysutils/syslog-ng/Makefile2
-rw-r--r--sysutils/syslog-ng/files/patch-lib-ivykis-lib-include-iv_tls.h11
-rw-r--r--sysutils/syslog-ng/files/patch-lib-ivykis-lib-iv_tls.c11
3 files changed, 23 insertions, 1 deletions
diff --git a/sysutils/syslog-ng/Makefile b/sysutils/syslog-ng/Makefile
index cc2f1e931757..72f1a46d4c03 100644
--- a/sysutils/syslog-ng/Makefile
+++ b/sysutils/syslog-ng/Makefile
@@ -7,7 +7,7 @@
PORTNAME= syslog-ng
PORTVERSION= 3.3.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= http://www.balabit.com/downloads/files/syslog-ng/sources/$(PORTVERSION)/source/
DISTFILES= $(PORTNAME)_$(PORTVERSION).tar.gz
diff --git a/sysutils/syslog-ng/files/patch-lib-ivykis-lib-include-iv_tls.h b/sysutils/syslog-ng/files/patch-lib-ivykis-lib-include-iv_tls.h
new file mode 100644
index 000000000000..bd918cf440d1
--- /dev/null
+++ b/sysutils/syslog-ng/files/patch-lib-ivykis-lib-include-iv_tls.h
@@ -0,0 +1,11 @@
+--- lib/ivykis/lib/include/iv_tls.h.old
++++ lib/ivykis/lib/include/iv_tls.h
+@@ -33,7 +33,7 @@ struct iv_tls_user {
+ void (*deinit_thread)(void *st);
+
+ struct iv_list_head list;
+- off_t state_offset;
++ int state_offset;
+ };
+
+ void iv_tls_user_register(struct iv_tls_user *);
diff --git a/sysutils/syslog-ng/files/patch-lib-ivykis-lib-iv_tls.c b/sysutils/syslog-ng/files/patch-lib-ivykis-lib-iv_tls.c
new file mode 100644
index 000000000000..ce05c2e1a6b8
--- /dev/null
+++ b/sysutils/syslog-ng/files/patch-lib-ivykis-lib-iv_tls.c
@@ -0,0 +1,11 @@
+--- lib/ivykis/lib/iv_tls.c.old
++++ lib/ivykis/lib/iv_tls.c
+@@ -25,7 +25,7 @@
+ #include "iv_private.h"
+
+ static int inited;
+-static off_t last_offset;
++static int last_offset = (sizeof(struct iv_state) + 15) & ~15;
+ static struct iv_list_head iv_tls_users = IV_LIST_HEAD_INIT(iv_tls_users);
+
+ void iv_tls_user_register(struct iv_tls_user *itu)