aboutsummaryrefslogtreecommitdiff
path: root/sysutils/syslog-ng
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-04-25 12:48:06 +0000
committerWill Andrews <will@FreeBSD.org>2000-04-25 12:48:06 +0000
commitd4b671f0a8b585ee1e73578c937ef456dda509bb (patch)
treeb55f9baf63277f45b572a41cad80614b925b5d00 /sysutils/syslog-ng
parent5e04d9a0460d27f9fe620385db244119264224d1 (diff)
downloadports-d4b671f0a8b585ee1e73578c937ef456dda509bb.tar.gz
ports-d4b671f0a8b585ee1e73578c937ef456dda509bb.zip
Notes
Diffstat (limited to 'sysutils/syslog-ng')
-rw-r--r--sysutils/syslog-ng/Makefile60
-rw-r--r--sysutils/syslog-ng/distinfo1
-rw-r--r--sysutils/syslog-ng/files/patch-aa11
-rw-r--r--sysutils/syslog-ng/files/syslog-ng.conf.sample167
-rw-r--r--sysutils/syslog-ng/pkg-comment1
-rw-r--r--sysutils/syslog-ng/pkg-descr10
-rw-r--r--sysutils/syslog-ng/pkg-message17
-rw-r--r--sysutils/syslog-ng/pkg-plist18
8 files changed, 285 insertions, 0 deletions
diff --git a/sysutils/syslog-ng/Makefile b/sysutils/syslog-ng/Makefile
new file mode 100644
index 000000000000..0579e5785ef9
--- /dev/null
+++ b/sysutils/syslog-ng/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: syslog-ng
+# Date created: 22 April 2000
+# Whom: Vince Valenti <vince@blue-box.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= syslog-ng
+PORTVERSION= 1.4.3
+CATEGORIES= sysutils
+MASTER_SITES= http://www.balabit.hu/downloads/syslog-ng/1.4/
+
+MAINTAINER= vince@blue-box.net
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libol.a:${PORTSDIR}/devel/libol
+
+MAN5= syslog-ng.conf.5
+MAN8= syslog-ng.8
+
+GNU_CONFIGURE= yes
+
+PKGMESSAGE= ${WRKDIR}/MESSAGE
+
+post-patch:
+ @${PERL} -pi -e 's:__PREFIX__:${PREFIX}:g' ${WRKSRC}/src/syslog-ng.h
+
+post-build:
+ @${SED} -e 's,__PREFIX__,${PREFIX},g' ${PKGDIR}/MESSAGE > ${PKGMESSAGE}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} \
+ ${PREFIX}/share/doc/syslog-ng \
+ ${PREFIX}/share/doc/syslog-ng/sgml
+ ${INSTALL_DATA} ${WRKSRC}/AUTHORS ${PREFIX}/share/doc/syslog-ng
+ ${INSTALL_DATA} ${WRKSRC}/COPYING ${PREFIX}/share/doc/syslog-ng
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${PREFIX}/share/doc/syslog-ng
+ ${INSTALL_DATA} ${WRKSRC}/INSTALL ${PREFIX}/share/doc/syslog-ng
+ ${INSTALL_DATA} ${WRKSRC}/NEWS ${PREFIX}/share/doc/syslog-ng
+ ${INSTALL_DATA} ${WRKSRC}/PORTS ${PREFIX}/share/doc/syslog-ng
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/syslog-ng
+ ${INSTALL_DATA} ${WRKSRC}/doc/sgml/syslog-ng.dvi ${PREFIX}/share/doc/syslog-ng/sgml
+ ${INSTALL_DATA} ${WRKSRC}/doc/sgml/syslog-ng.html.tar.gz ${PREFIX}/share/doc/syslog-ng/sgml
+ ${INSTALL_DATA} ${WRKSRC}/doc/sgml/syslog-ng.ps ${PREFIX}/share/doc/syslog-ng/sgml
+ ${INSTALL_DATA} ${WRKSRC}/doc/sgml/syslog-ng.sgml ${PREFIX}/share/doc/syslog-ng/sgml
+ ${INSTALL_DATA} ${WRKSRC}/doc/sgml/syslog-ng.txt ${PREFIX}/share/doc/syslog-ng/sgml
+.endif
+ @if [ ! -f ${PREFIX}/etc/syslog-ng/syslog-ng.conf.sample ]; then \
+ ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} ${PREFIX}/etc/syslog-ng; \
+ ${INSTALL_DATA} ${FILESDIR}/syslog-ng.conf.sample ${PREFIX}/etc/syslog-ng; \
+ fi
+ @if [ ! -f ${PREFIX}/etc/rc.d/syslog-ng.sh.sample ]; then \
+ ${ECHO} "Installing ${PREFIX}/etc/rc.d/syslog-ng.sh.sample startup file."; \
+ ${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/syslog-ng.sh.sample; \
+ ${ECHO} "[ -x ${PREFIX}/sbin/syslog-ng ] && ${PREFIX}/sbin/syslog-ng && ${ECHO} -n ' syslog-ng'" >> ${PREFIX}/etc/rc.d/syslog-ng.sh.sample; \
+ ${CHMOD} 755 ${PREFIX}/etc/rc.d/syslog-ng.sh.sample; \
+ fi
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/sysutils/syslog-ng/distinfo b/sysutils/syslog-ng/distinfo
new file mode 100644
index 000000000000..8c018f76ff98
--- /dev/null
+++ b/sysutils/syslog-ng/distinfo
@@ -0,0 +1 @@
+MD5 (syslog-ng-1.4.3.tar.gz) = 8eae4931bd32cd8c2a9b7ef9a8606f9e
diff --git a/sysutils/syslog-ng/files/patch-aa b/sysutils/syslog-ng/files/patch-aa
new file mode 100644
index 000000000000..9ae003c2093b
--- /dev/null
+++ b/sysutils/syslog-ng/files/patch-aa
@@ -0,0 +1,11 @@
+--- src/syslog-ng.h.orig Sat Apr 22 12:19:19 2000
++++ src/syslog-ng.h Sat Apr 22 12:28:52 2000
+@@ -34,7 +34,7 @@
+ #define PATH_SYSLOG_NG_CONF "syslog-ng.conf"
+ #define PATH_PIDFILE "syslog-ng.pid"
+ #else
+-#define PATH_SYSLOG_NG_CONF "/etc/syslog-ng/syslog-ng.conf"
++#define PATH_SYSLOG_NG_CONF "__PREFIX__/etc/syslog-ng/syslog-ng.conf"
+ #define PATH_PIDFILE "/var/run/syslog-ng.pid"
+ #endif
+
diff --git a/sysutils/syslog-ng/files/syslog-ng.conf.sample b/sysutils/syslog-ng/files/syslog-ng.conf.sample
new file mode 100644
index 000000000000..317e4b9a28ef
--- /dev/null
+++ b/sysutils/syslog-ng/files/syslog-ng.conf.sample
@@ -0,0 +1,167 @@
+#
+# This sample configuration file is essentially equilivent to the stock
+# FreeBSD /etc/syslog.conf file.
+#
+
+#
+# options
+#
+options { long_hostnames(off); sync(0); };
+
+#
+# sources
+#
+source src { unix-dgram("/var/run/log"); udp(); internal(); };
+
+#
+# destinations
+#
+destination messages { file("/var/log/messages"); };
+destination security { file("/var/log/security"); };
+destination maillog { file("/var/log/maillog"); };
+destination lpd-errs { file("/var/log/lpd-errs"); };
+destination cron { file("/var/log/cron"); };
+destination all { file("/var/log/all.log"); };
+destination newscrit { file("/var/log/news/news.crit"); };
+destination newserr { file("/var/log/news/news.err"); };
+destination newsnotice { file("/var/log/news/news.notice"); };
+destination slip { file("/var/log/slip.log"); };
+destination ppp { file("/var/log/ppp.log"); };
+destination console { file("/dev/console"); };
+destination root { usertty("root"); };
+destination allusers { usertty("*"); };
+#destination loghost { udp("loghost" port(514)); };
+
+#
+# log facility filters
+#
+filter f_auth { facility(auth); };
+filter f_authpriv { facility(authpriv); };
+filter f_cron { facility(cron); };
+filter f_daemon { facility(daemon); };
+filter f_ftp { facility(ftp); };
+filter f_kern { facility(kern); };
+filter f_lpr { facility(lpr); };
+filter f_mail { facility(mail); };
+filter f_news { facility(news); };
+filter f_security { facility(security); };
+filter f_user { facility(user); };
+filter f_uucp { facility(uucp); };
+filter f_local0 { facility(local0); };
+filter f_local1 { facility(local1); };
+filter f_local2 { facility(local2); };
+filter f_local3 { facility(local3); };
+filter f_local4 { facility(local4); };
+filter f_local5 { facility(local5); };
+filter f_local6 { facility(local6); };
+filter f_local7 { facility(local7); };
+
+#
+# log level filters
+#
+filter f_emerg { level(emerg); };
+filter f_alert { level(alert); };
+filter f_crit { level(crit); };
+filter f_err { level(err); };
+filter f_warning { level(warning); };
+filter f_notice { level(notice); };
+filter f_info { level(info); };
+filter f_debug { level(debug); };
+
+#
+# program filters
+#
+filter f_ppp { program("ppp"); };
+filter f_slip { program("startslip"); };
+
+#
+# *.err;kern.debug;auth.notice;mail.crit /dev/console
+#
+log { source(src); filter(f_err); destination(console); };
+log { source(src); filter(f_kern); filter(f_debug); destination(console); };
+log { source(src); filter(f_auth); filter(f_notice); destination(console); };
+log { source(src); filter(f_mail); filter(f_crit); destination(console); };
+
+#
+# *.notice;kern.debug;lpr.info;mail.crit;news.err /var/log/messages
+#
+log { source(src); filter(f_notice); destination(messages); };
+log { source(src); filter(f_kern); filter(f_debug); destination(messages); };
+log { source(src); filter(f_lpr); filter(f_info); destination(messages); };
+log { source(src); filter(f_mail); filter(f_crit); destination(messages); };
+log { source(src); filter(f_news); filter(f_err); destination(messages); };
+
+#
+# security.* /var/log/security
+#
+log { source(src); filter(f_security); destination(security); };
+
+#
+# mail.info /var/log/maillog
+#
+log { source(src); filter(f_mail); filter(f_info); destination(maillog); };
+
+#
+# lpr.info /var/log/lpd-errs
+#
+log { source(src); filter(f_lpr); filter(f_info); destination(lpd-errs); };
+
+#
+# cron.* /var/log/cron
+#
+log { source(src); filter(f_cron); destination(cron); };
+
+#
+# *.err root
+#
+log { source(src); filter(f_err); destination(root); };
+
+#
+# *.notice;news.err root
+#
+log { source(src); filter(f_notice); destination(root); };
+log { source(src); filter(f_news); filter(f_err); destination(root); };
+
+#
+# *.alert root
+#
+log { source(src); filter(f_alert); destination(root); };
+
+#
+# *.emerg *
+#
+log { source(src); filter(f_emerg); destination(allusers); };
+
+#
+# uncomment this to enable logging of all log messages to /var/log/all.log
+# *.* /var/log/all.log
+#
+#log { source(src); destination(all); };
+
+#
+# uncomment this to enable logging to a remote loghost named loghost
+# *.* @loghost
+#
+#log { source(src); destination(loghost); };
+
+#
+# uncomment these if you're running inn
+# news.crit /var/log/news/news.crit
+# news.err /var/log/news/news.err
+# news.notice /var/log/news/news.notice
+#
+#log { source(src); filter(f_news); filter(f_crit); destination(newscrit); };
+#log { source(src); filter(f_news); filter(f_err); destination(newserr); };
+#log { source(src); filter(f_news); filter(f_notice); destination(newsnotice); };
+
+#
+# !startslip
+# *.* /var/log/slip.log
+#
+log { source(src); filter(f_slip); destination(slip); };
+
+#
+# !ppp
+# *.* /var/log/ppp.log
+#
+log { source(src); filter(f_ppp); destination(ppp); };
diff --git a/sysutils/syslog-ng/pkg-comment b/sysutils/syslog-ng/pkg-comment
new file mode 100644
index 000000000000..90775a767166
--- /dev/null
+++ b/sysutils/syslog-ng/pkg-comment
@@ -0,0 +1 @@
+A powerfull syslogd replacement
diff --git a/sysutils/syslog-ng/pkg-descr b/sysutils/syslog-ng/pkg-descr
new file mode 100644
index 000000000000..95639dd68e5a
--- /dev/null
+++ b/sysutils/syslog-ng/pkg-descr
@@ -0,0 +1,10 @@
+syslog-ng (Syslog New Generation) is a powerful replacement for the standard
+syslogd. Features include:
+
+ - ability to filter messages based on content using regular expressions
+ - forwarding logs on TCP
+
+WWW: http://www.balabit.hu/products/syslog-ng/
+
+-Vince
+vince@blue-box.net
diff --git a/sysutils/syslog-ng/pkg-message b/sysutils/syslog-ng/pkg-message
new file mode 100644
index 000000000000..f69921584cf6
--- /dev/null
+++ b/sysutils/syslog-ng/pkg-message
@@ -0,0 +1,17 @@
+
+syslog-ng is now installed! To replace FreeBSD's standard syslogd
+(/usr/sbin/syslogd), complete these steps:
+
+1. Create a configuration file named __PREFIX__/etc/syslog-ng/syslog-ng.conf
+ (a sample named syslog-ng.conf.sample has been included)
+
+2. Configure syslog-ng to start automatically by creating a startup script
+ in __PREFIX__/etc/rc.d. (a sample named syslog-ng.sh.sample has been
+ included)
+
+3. Prevent the standard FreeBSD syslogd from starting automatically by
+ adding a line to the end of your /etc/rc.conf file that reads:
+
+ syslogd_enable="NO"
+
+4. Reboot.
diff --git a/sysutils/syslog-ng/pkg-plist b/sysutils/syslog-ng/pkg-plist
new file mode 100644
index 000000000000..cd39edbbe966
--- /dev/null
+++ b/sysutils/syslog-ng/pkg-plist
@@ -0,0 +1,18 @@
+etc/rc.d/syslog-ng.sh.sample
+etc/syslog-ng/syslog-ng.conf.sample
+share/doc/syslog-ng/AUTHORS
+share/doc/syslog-ng/COPYING
+share/doc/syslog-ng/ChangeLog
+share/doc/syslog-ng/INSTALL
+share/doc/syslog-ng/NEWS
+share/doc/syslog-ng/PORTS
+share/doc/syslog-ng/README
+share/doc/syslog-ng/sgml/syslog-ng.dvi
+share/doc/syslog-ng/sgml/syslog-ng.html.tar.gz
+share/doc/syslog-ng/sgml/syslog-ng.ps
+share/doc/syslog-ng/sgml/syslog-ng.sgml
+share/doc/syslog-ng/sgml/syslog-ng.txt
+sbin/syslog-ng
+@dirrm etc/syslog-ng
+@dirrm share/doc/syslog-ng/sgml
+@dirrm share/doc/syslog-ng