aboutsummaryrefslogtreecommitdiff
path: root/sysutils/syslog-ng
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2016-03-24 05:55:32 +0000
committerCy Schubert <cy@FreeBSD.org>2016-03-24 05:55:32 +0000
commitc36b7c085b25de15e74c9ea5c1214a59bb81743a (patch)
tree7435a0e3238011a0549b518ac8e518e18e963920 /sysutils/syslog-ng
parentad8bf549b5143e69b1c769ba62f06edbf949306d (diff)
downloadports-c36b7c085b25de15e74c9ea5c1214a59bb81743a.tar.gz
ports-c36b7c085b25de15e74c9ea5c1214a59bb81743a.zip
Notes
Diffstat (limited to 'sysutils/syslog-ng')
-rw-r--r--sysutils/syslog-ng/Makefile146
-rw-r--r--sysutils/syslog-ng/distinfo2
-rw-r--r--sysutils/syslog-ng/files/patch-configure14
-rw-r--r--sysutils/syslog-ng/files/patch-modules__afsocket__afinet-dest.c11
-rw-r--r--sysutils/syslog-ng/files/pkg-message.in29
-rw-r--r--sysutils/syslog-ng/files/syslog-ng.conf.sample185
-rw-r--r--sysutils/syslog-ng/files/syslog-ng.in46
-rw-r--r--sysutils/syslog-ng/pkg-descr17
-rw-r--r--sysutils/syslog-ng/pkg-plist225
9 files changed, 0 insertions, 675 deletions
diff --git a/sysutils/syslog-ng/Makefile b/sysutils/syslog-ng/Makefile
deleted file mode 100644
index 897117255202..000000000000
--- a/sysutils/syslog-ng/Makefile
+++ /dev/null
@@ -1,146 +0,0 @@
-# Created by: Ivan Lago <ivan.lago@ifom-ieo-campus.it>
-# $FreeBSD$
-
-PORTNAME= syslog-ng
-PORTVERSION= 3.6.4
-CATEGORIES= sysutils
-DISTVERSION= $(PORTVERSION:S/a/alpha/:S/b/beta/:S/r/rc/)
-DISTFILES= syslog-ng-${DISTVERSION}.tar.gz
-MASTER_SITES= https://github.com/balabit/${PORTNAME}/releases/download/${PORTNAME}-${DISTVERSION}/ \
- http://www.balabit.com/downloads/files/syslog-ng/open-source-edition/${DISTVERSION}/source/ \
-
-MAINTAINER= cy@FreeBSD.org
-COMMENT= Powerful syslogd replacement
-
-LIB_DEPENDS= libevtlog.so:${PORTSDIR}/sysutils/eventlog \
- libpcre.so:${PORTSDIR}/devel/pcre
-
-CONFLICTS?= syslog-ng-[0-9]* syslog-ng[0-9]-[0-9]* \
- syslog-ng[0-9][0-9]-[0-9]* \
- syslog-ng-devel-[0-9]*
-WRKSRC= $(WRKDIR)/$(PORTNAME)-$(DISTVERSION)
-
-MAKE_JOBS_UNSAFE= yes
-OPTIONS_DEFINE= TCP_WRAPPERS SQL SPOOF IPV6 SMTP JSON GEOIP DOCS REDIS OPENSSL
-OPTIONS_DEFAULT= OPENSSL JSON
-TCP_WRAPPERS_DESC= Build with TCP Wrappers
-SQL_DESC= Build with database (libdbi) support
-SPOOF_DESC= Build with spoof source support
-IPV6_DESC= Build with IPV6 support
-SMTP_DESC= Build with SMTP support
-JSON_DESC= Build with JSON-C support
-GEOIP_DESC= Build with GeoIP support
-REDIS_DESC= Build with Redis support
-
-USES= alias gmake libtool pathfix pkgconfig
-USE_LDCONFIG= yes
-USE_RC_SUBR= syslog-ng
-GNU_CONFIGURE= yes
-USE_GNOME= glib20
-SUB_FILES= pkg-message
-INSTALL_TARGET= install-strip
-
-CONFIGURE_ARGS= --sysconfdir=${LOCALBASE}/etc --localstatedir=/var/db \
- --enable-dynamic-linking --disable-linux-caps \
- --enable-debug --enable-manpages \
- --datadir=${PREFIX}/share/syslog-ng/
-
-BROKEN_sparc64= Does not compile on sparc64: gcc core dump
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MOPENSSL}
-USE_OPENSSL= yes
-WITH_OPENSSL_PORT= yes
-CONFIGURE_ARGS+= --enable-ssl
-CONFIGURE_ENV+= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
- OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl"
-PLIST_FILES+= lib/syslog-ng/libafsocket-tls.so
-.else
-CONFIGURE_ARGS+= --disable-ssl
-.endif
-
-.if ${PORT_OPTIONS:MTCP_WRAPPERS}
-CONFIGURE_ARGS+= --enable-tcp-wrapper
-.else
-CONFIGURE_ARGS+= --disable-tcp-wrapper
-.endif
-
-.if ${PORT_OPTIONS:MSPOOF}
-LIB_DEPENDS+= libnet.so:${PORTSDIR}/net/libnet
-CONFIGURE_ARGS+= --enable-spoof-source
-.else
-CONFIGURE_ARGS+= --disable-spoof-source
-.endif
-
-.if ${PORT_OPTIONS:MIPV6}
-CONFIGURE_ARGS+= --enable-ipv6
-.else
-CONFIGURE_ARGS+= --disable-ipv6
-.endif
-
-.if ${PORT_OPTIONS:MGEOIP}
-CONFIGURE_ARGS+= --enable-geoip
-LIB_DEPENDS+= libGeoIP.so:${PORTSDIR}/net/GeoIP
-CONFIGURE_ENV+= GEOIP_LIBS="-L${LOCALBASE}/lib -lGeoIP"
-PLIST_FILES+= lib/syslog-ng/libtfgeoip.so
-.else
-CONFIGURE_ARGS+= --disable-geoip
-.endif
-
-.if ${PORT_OPTIONS:MREDIS}
-CONFIGURE_ARGS+= --enable-redis --with-libhiredis=${LOCALBASE}/lib
-LIB_DEPENDS+= libhiredis.so:${PORTSDIR}/databases/hiredis
-PLIST_FILES+= lib/syslog-ng/libredis.so
-.else
-CONFIGURE_ARGS+= --disable-redis
-.endif
-
-.if ${PORT_OPTIONS:MSMTP}
-CONFIGURE_ARGS+= --with-libesmtp=/usr/local/
-LIB_DEPENDS+= libesmtp.so:${PORTSDIR}/mail/libesmtp
-PLIST_FILES+= lib/syslog-ng/libafsmtp.so
-.else
-CONFIGURE_ARGS+= --disable-smtp
-.endif
-
-.if ${PORT_OPTIONS:MSQL}
-LIB_DEPENDS+= libdbi.so:${PORTSDIR}/databases/libdbi
-CONFIGURE_ENV+= LIBDBI_LIBS="-ldbi"
-CONFIGURE_ARGS+= --enable-sql
-LDFLAGS+= -L${LOCALBASE}/lib
-PLIST_FILES+= lib/syslog-ng/libafsql.so
-.else
-CONFIGURE_ARGS+= --disable-sql
-.endif
-
-.if ${PORT_OPTIONS:MJSON}
-LIB_DEPENDS+= libjson-c.so:${PORTSDIR}/devel/json-c
-CONFIGURE_ARGS+= --enable-json
-PLIST_FILES+= lib/syslog-ng/libjson-plugin.so
-.else
-CONFIGURE_ARGS+= --disable-json
-.endif
-
-post-patch:
- @${CP} ${WRKSRC}/scl/syslog-ng.conf ${WRKSRC}/scl/syslog-ng.conf.dist
- @${CP} ${WRKSRC}/scl/scl.conf ${WRKSRC}/scl/scl.conf.sample
-
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/AUTHORS ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/COPYING ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/NEWS.md ${STAGEDIR}${DOCSDIR}
-.endif
- ${INSTALL_MAN} ${WRKSRC}/doc/man/*.1 ${STAGEDIR}${PREFIX}/man/man1/
- ${INSTALL_MAN} ${WRKSRC}/doc/man/*.5 ${STAGEDIR}${PREFIX}/man/man5/
- ${INSTALL_MAN} ${WRKSRC}/doc/man/*.8 ${STAGEDIR}${PREFIX}/man/man8/
- ${INSTALL_DATA} ${FILESDIR}/syslog-ng.conf.sample \
- ${STAGEDIR}${PREFIX}/etc
- ${INSTALL_DATA} ${WRKSRC}/scl/syslog-ng.conf.dist \
- ${WRKSRC}/scl/scl.conf.sample ${STAGEDIR}${PREFIX}/etc
- ${INSTALL_DATA} ${WRKSRC}/lib/ivykis/src/include/iv*.h \
- ${STAGEDIR}${PREFIX}/include/syslog-ng/
-
-.include <bsd.port.mk>
diff --git a/sysutils/syslog-ng/distinfo b/sysutils/syslog-ng/distinfo
deleted file mode 100644
index eaa442b75f91..000000000000
--- a/sysutils/syslog-ng/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (syslog-ng-3.6.4.tar.gz) = 7be11df31ac7d716f1f952e22b5ae8e2049edd633a41b223776a853d9106f4e7
-SIZE (syslog-ng-3.6.4.tar.gz) = 3276432
diff --git a/sysutils/syslog-ng/files/patch-configure b/sysutils/syslog-ng/files/patch-configure
deleted file mode 100644
index c3c533b2df4c..000000000000
--- a/sysutils/syslog-ng/files/patch-configure
+++ /dev/null
@@ -1,14 +0,0 @@
---- configure.orig 2016-03-22 04:58:27.000000000 -0700
-+++ configure 2016-03-23 20:51:10.722420000 -0700
-@@ -14996,9 +14996,9 @@
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for LIBNET" >&5
- $as_echo_n "checking for LIBNET... " >&6; }
- if test "x$with_libnet" = "x"; then
-- LIBNET_CONFIG="`which libnet-config`"
-+ LIBNET_CONFIG="`which libnet11-config`"
- else
-- LIBNET_CONFIG="$with_libnet/libnet-config"
-+ LIBNET_CONFIG="$with_libnet/libnet11-config"
- fi
-
- if test -n "$LIBNET_CONFIG" -a -x "$LIBNET_CONFIG"; then
diff --git a/sysutils/syslog-ng/files/patch-modules__afsocket__afinet-dest.c b/sysutils/syslog-ng/files/patch-modules__afsocket__afinet-dest.c
deleted file mode 100644
index 7af83d8fb2c0..000000000000
--- a/sysutils/syslog-ng/files/patch-modules__afsocket__afinet-dest.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- modules/afsocket/afinet-dest.c.orig 2016-03-22 02:39:13.000000000 -0700
-+++ modules/afsocket/afinet-dest.c 2016-03-23 22:07:14.289961000 -0700
-@@ -42,7 +42,7 @@
- #endif
-
- #if ENABLE_SPOOF_SOURCE
--#include <libnet.h>
-+#include <libnet11/libnet.h>
- #endif
-
- #if _GNU_SOURCE_DEFINED
diff --git a/sysutils/syslog-ng/files/pkg-message.in b/sysutils/syslog-ng/files/pkg-message.in
deleted file mode 100644
index 2b5582660897..000000000000
--- a/sysutils/syslog-ng/files/pkg-message.in
+++ /dev/null
@@ -1,29 +0,0 @@
-
-syslog-ng is now installed! To replace FreeBSD's standard syslogd
-(/usr/sbin/syslogd), complete these steps:
-
-1. Create a configuration file named %%PREFIX%%/etc/syslog-ng.conf
- (a sample named syslog-ng.conf.sample has been included in
- %%PREFIX%%/etc). Note that this is a change in 2.0.2
- version, previous ones put the config file in
- %%PREFIX%%/etc/syslog-ng/syslog-ng.conf, so if this is an update
- move that file in the right place
-
-2. Configure syslog-ng to start automatically by adding the following
- to /etc/rc.conf:
-
- syslog_ng_enable="YES"
-
-3. Prevent the standard FreeBSD syslogd from starting automatically by
- adding a line to the end of your /etc/rc.conf file that reads:
-
- syslogd_enable="NO"
-
-4. Shut down the standard FreeBSD syslogd:
-
- kill `cat /var/run/syslog.pid`
-
-5. Start syslog-ng:
-
- %%PREFIX%%/etc/rc.d/syslog-ng start
-
diff --git a/sysutils/syslog-ng/files/syslog-ng.conf.sample b/sysutils/syslog-ng/files/syslog-ng.conf.sample
deleted file mode 100644
index 7fa32733ffd1..000000000000
--- a/sysutils/syslog-ng/files/syslog-ng.conf.sample
+++ /dev/null
@@ -1,185 +0,0 @@
-@version:3.6
-@include "scl.conf"
-
-#
-# This sample configuration file is essentially equilivent to the stock
-# FreeBSD /etc/syslog.conf file.
-#
-# $FreeBSD: head/sysutils/syslog-ng/files/syslog-ng.conf.sample 340872 2014-01-24 00:14:07Z mat $
-#
-
-#
-# options
-#
-options { chain_hostnames(off); flush_lines(0); threaded(yes); };
-
-#
-# sources
-#
-source src { system();
- udp(); internal(); };
-
-#
-# destinations
-#
-destination messages { file("/var/log/messages"); };
-destination security { file("/var/log/security"); };
-destination authlog { file("/var/log/auth.log"); };
-destination maillog { file("/var/log/maillog"); };
-destination lpd-errs { file("/var/log/lpd-errs"); };
-destination xferlog { file("/var/log/xferlog"); };
-destination cron { file("/var/log/cron"); };
-destination debuglog { file("/var/log/debug.log"); };
-destination consolelog { file("/var/log/console.log"); };
-destination all { file("/var/log/all.log"); };
-destination newscrit { file("/var/log/news/news.crit"); };
-destination newserr { file("/var/log/news/news.err"); };
-destination newsnotice { file("/var/log/news/news.notice"); };
-destination slip { file("/var/log/slip.log"); };
-destination ppp { file("/var/log/ppp.log"); };
-destination console { file("/dev/console"); };
-destination allusers { usertty("*"); };
-#destination loghost { udp("loghost" port(514)); };
-
-#
-# log facility filters
-#
-filter f_auth { facility(auth); };
-filter f_authpriv { facility(authpriv); };
-filter f_not_authpriv { not facility(authpriv); };
-#filter f_console { facility(console); };
-filter f_cron { facility(cron); };
-filter f_daemon { facility(daemon); };
-filter f_ftp { facility(ftp); };
-filter f_kern { facility(kern); };
-filter f_lpr { facility(lpr); };
-filter f_mail { facility(mail); };
-filter f_news { facility(news); };
-filter f_security { facility(security); };
-filter f_user { facility(user); };
-filter f_uucp { facility(uucp); };
-filter f_local0 { facility(local0); };
-filter f_local1 { facility(local1); };
-filter f_local2 { facility(local2); };
-filter f_local3 { facility(local3); };
-filter f_local4 { facility(local4); };
-filter f_local5 { facility(local5); };
-filter f_local6 { facility(local6); };
-filter f_local7 { facility(local7); };
-
-#
-# log level filters
-#
-filter f_emerg { level(emerg); };
-filter f_alert { level(alert..emerg); };
-filter f_crit { level(crit..emerg); };
-filter f_err { level(err..emerg); };
-filter f_warning { level(warning..emerg); };
-filter f_notice { level(notice..emerg); };
-filter f_info { level(info..emerg); };
-filter f_debug { level(debug..emerg); };
-filter f_is_debug { level(debug); };
-
-#
-# program filters
-#
-filter f_ppp { program("ppp"); };
-filter f_slip { program("startslip"); };
-
-#
-# *.err;kern.warning;auth.notice;mail.crit /dev/console
-#
-log { source(src); filter(f_err); destination(console); };
-log { source(src); filter(f_kern); filter(f_warning); destination(console); };
-log { source(src); filter(f_auth); filter(f_notice); destination(console); };
-log { source(src); filter(f_mail); filter(f_crit); destination(console); };
-
-#
-# *.notice;authpriv.none;kern.debug;lpr.info;mail.crit;news.err /var/log/messages
-#
-log { source(src); filter(f_notice); filter(f_not_authpriv); destination(messages); };
-log { source(src); filter(f_kern); filter(f_debug); destination(messages); };
-log { source(src); filter(f_lpr); filter(f_info); destination(messages); };
-log { source(src); filter(f_mail); filter(f_crit); destination(messages); };
-log { source(src); filter(f_news); filter(f_err); destination(messages); };
-
-#
-# security.* /var/log/security
-#
-log { source(src); filter(f_security); destination(security); };
-
-#
-# auth.info;authpriv.info /var/log/auth.log
-log { source(src); filter(f_auth); filter(f_info); destination(authlog); };
-log { source(src); filter(f_authpriv); filter(f_info); destination(authlog); };
-
-#
-# mail.info /var/log/maillog
-#
-log { source(src); filter(f_mail); filter(f_info); destination(maillog); };
-
-#
-# lpr.info /var/log/lpd-errs
-#
-log { source(src); filter(f_lpr); filter(f_info); destination(lpd-errs); };
-
-#
-# ftp.info /var/log/xferlog
-#
-log { source(src); filter(f_ftp); filter(f_info); destination(xferlog); };
-
-#
-# cron.* /var/log/cron
-#
-log { source(src); filter(f_cron); destination(cron); };
-
-#
-# *.=debug /var/log/debug.log
-#
-log { source(src); filter(f_is_debug); destination(debuglog); };
-
-#
-# *.emerg *
-#
-log { source(src); filter(f_emerg); destination(allusers); };
-
-#
-# uncomment this to log all writes to /dev/console to /var/log/console.log
-# console.info /var/log/console.log
-#
-#log { source(src); filter(f_console); filter(f_info); destination(consolelog); };
-
-#
-# uncomment this to enable logging of all log messages to /var/log/all.log
-# touch /var/log/all.log and chmod it to mode 600 before it will work
-# *.* /var/log/all.log
-#
-#log { source(src); destination(all); };
-
-#
-# uncomment this to enable logging to a remote loghost named loghost
-# *.* @loghost
-#
-#log { source(src); destination(loghost); };
-
-#
-# uncomment these if you're running inn
-# news.crit /var/log/news/news.crit
-# news.err /var/log/news/news.err
-# news.notice /var/log/news/news.notice
-#
-#log { source(src); filter(f_news); filter(f_crit); destination(newscrit); };
-#log { source(src); filter(f_news); filter(f_err); destination(newserr); };
-#log { source(src); filter(f_news); filter(f_notice); destination(newsnotice); };
-
-#
-# !startslip
-# *.* /var/log/slip.log
-#
-log { source(src); filter(f_slip); destination(slip); };
-
-#
-# !ppp
-# *.* /var/log/ppp.log
-#
-log { source(src); filter(f_ppp); destination(ppp); };
diff --git a/sysutils/syslog-ng/files/syslog-ng.in b/sysutils/syslog-ng/files/syslog-ng.in
deleted file mode 100644
index ae24e4984375..000000000000
--- a/sysutils/syslog-ng/files/syslog-ng.in
+++ /dev/null
@@ -1,46 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD: head/sysutils/syslog-ng/files/syslog-ng.in 340872 2014-01-24 00:14:07Z mat $
-#
-
-# PROVIDE: syslogd
-# REQUIRE: mountcritremote cleanvar ldconfig
-# BEFORE: SERVERS
-
-#
-# Add the following line to /etc/rc.conf.local or /etc/rc.conf
-# to enable this service:
-#
-#syslog_ng_enable="YES"
-#syslog_ng_config="-u daemon"
-#syslog_ng_pid="/var/run/syslog-ng.pid"
-#
-
-syslog_ng_purgeklog=${syslog_ng_purgeklog-"NO"}
-
-. /etc/rc.subr
-
-name=syslog_ng
-rcvar=syslog_ng_enable
-
-command=%%PREFIX%%/sbin/syslog-ng
-required_files=%%PREFIX%%/etc/syslog-ng.conf
-extra_commands=reload
-
-if checkyesno syslog_ng_purgeklog; then
- start_precmd="echo \"Purging klog(9)\" && sysctl -w kern.msgbuf_clear=1 $start_precmd";
-fi
-
-stop_postcmd=stop_postcmd
-
-load_rc_config $name
-
-: ${syslog_ng_enable:="NO"}
-pidfile=${syslog_ng_pid:-"/var/run/syslog.pid"}
-command_args="-p ${pidfile} ${syslog_ng_config}"
-
-stop_postcmd() {
- rm -f $pidfile
-}
-
-run_rc_command "$1"
diff --git a/sysutils/syslog-ng/pkg-descr b/sysutils/syslog-ng/pkg-descr
deleted file mode 100644
index fa72550fde2a..000000000000
--- a/sysutils/syslog-ng/pkg-descr
+++ /dev/null
@@ -1,17 +0,0 @@
-syslog-ng is an enhanced log daemon, supporting a wide range of input and
-output methods: syslog, unstructured text, message queues, databases (SQL
-and NoSQL alike) and more.
-
-Key features:
-
- * receive and send RFC3164 and RFC5424 style syslog messages
- * work with any kind of unstructured data
- * receive and send JSON formatted messages
- * classify and structure logs with builtin parsers (csv-parser(),
- db-parser(), ...)
- * normalize, crunch and process logs as they flow through the system
- * hand on messages for further processing using message queues (like
- AMQP), files or databases (like PostgreSQL or MongoDB).
-
-The official home page of syslog-ng is:
-http://www.balabit.com/network-security/syslog-ng/
diff --git a/sysutils/syslog-ng/pkg-plist b/sysutils/syslog-ng/pkg-plist
deleted file mode 100644
index b89015f05447..000000000000
--- a/sysutils/syslog-ng/pkg-plist
+++ /dev/null
@@ -1,225 +0,0 @@
-@unexec %D/etc/rc.d/syslog-ng.sh stop > /dev/null 2>&1 || true
-@sample etc/scl.conf.sample
-etc/syslog-ng.conf.dist
-@sample etc/syslog-ng.conf.sample
-bin/loggen
-bin/pdbtool
-bin/update-patterndb
-include/syslog-ng/ack_tracker.h
-include/syslog-ng/afinter.h
-include/syslog-ng/alarms.h
-include/syslog-ng/apphook.h
-include/syslog-ng/atomic.h
-include/syslog-ng/block-ref-parser.h
-include/syslog-ng/bookmark.h
-include/syslog-ng/cache.h
-include/syslog-ng/cfg-args.h
-include/syslog-ng/cfg-grammar.h
-include/syslog-ng/cfg-lexer-subst.h
-include/syslog-ng/cfg-lexer.h
-include/syslog-ng/cfg-parser.h
-include/syslog-ng/cfg-tree.h
-include/syslog-ng/cfg.h
-include/syslog-ng/children.h
-include/syslog-ng/compat/compat.h
-include/syslog-ng/compat/getutent.h
-include/syslog-ng/compat/glib.h
-include/syslog-ng/compat/lfs.h
-include/syslog-ng/compat/pio.h
-include/syslog-ng/compat/time.h
-include/syslog-ng/compat/socket.h
-include/syslog-ng/compat/string.h
-include/syslog-ng/control/control-server.h
-include/syslog-ng/control/control.h
-include/syslog-ng/crypto.h
-include/syslog-ng/dnscache.h
-include/syslog-ng/driver.h
-include/syslog-ng/file-perms.h
-include/syslog-ng/filter/filter-call.h
-include/syslog-ng/filter/filter-cmp.h
-include/syslog-ng/filter/filter-expr-parser.h
-include/syslog-ng/filter/filter-expr.h
-include/syslog-ng/filter/filter-in-list.h
-include/syslog-ng/filter/filter-netmask.h
-include/syslog-ng/filter/filter-op.h
-include/syslog-ng/filter/filter-pipe.h
-include/syslog-ng/filter/filter-pri.h
-include/syslog-ng/filter/filter-re.h
-include/syslog-ng/filter/filter-tags.h
-include/syslog-ng/gprocess.h
-include/syslog-ng/gsockaddr.h
-include/syslog-ng/gsocket.h
-include/syslog-ng/host-resolve.h
-include/syslog-ng/hostname.h
-include/syslog-ng/iv.h
-include/syslog-ng/iv_avl.h
-include/syslog-ng/iv_event.h
-include/syslog-ng/iv_event_raw.h
-include/syslog-ng/iv_fd_pump.h
-include/syslog-ng/iv_inotify.h
-include/syslog-ng/iv_list.h
-include/syslog-ng/iv_popen.h
-include/syslog-ng/iv_signal.h
-include/syslog-ng/iv_thread.h
-include/syslog-ng/iv_tls.h
-include/syslog-ng/iv_wait.h
-include/syslog-ng/iv_work.h
-include/syslog-ng/ivykis/iv.h
-include/syslog-ng/ivykis/iv_avl.h
-include/syslog-ng/ivykis/iv_event.h
-include/syslog-ng/ivykis/iv_event_raw.h
-include/syslog-ng/ivykis/iv_fd_pump.h
-include/syslog-ng/ivykis/iv_list.h
-include/syslog-ng/ivykis/iv_popen.h
-include/syslog-ng/ivykis/iv_signal.h
-include/syslog-ng/ivykis/iv_thread.h
-include/syslog-ng/ivykis/iv_tls.h
-include/syslog-ng/ivykis/iv_wait.h
-include/syslog-ng/ivykis/iv_work.h
-include/syslog-ng/libtest/mock-transport.h
-include/syslog-ng/libtest/msg_parse_lib.h
-include/syslog-ng/libtest/persist_lib.h
-include/syslog-ng/libtest/proto_lib.h
-include/syslog-ng/libtest/template_lib.h
-include/syslog-ng/libtest/testutils.h
-include/syslog-ng/logmatcher.h
-include/syslog-ng/logmpx.h
-include/syslog-ng/logmsg.h
-include/syslog-ng/logpipe.h
-include/syslog-ng/logproto/logproto-buffered-server.h
-include/syslog-ng/logproto/logproto-builtins.h
-include/syslog-ng/logproto/logproto-client.h
-include/syslog-ng/logproto/logproto-dgram-server.h
-include/syslog-ng/logproto/logproto-framed-client.h
-include/syslog-ng/logproto/logproto-framed-server.h
-include/syslog-ng/logproto/logproto-indented-multiline-server.h
-include/syslog-ng/logproto/logproto-record-server.h
-include/syslog-ng/logproto/logproto-regexp-multiline-server.h
-include/syslog-ng/logproto/logproto-server.h
-include/syslog-ng/logproto/logproto-text-client.h
-include/syslog-ng/logproto/logproto-text-server.h
-include/syslog-ng/logproto/logproto.h
-include/syslog-ng/logqueue-fifo.h
-include/syslog-ng/logqueue.h
-include/syslog-ng/logreader.h
-include/syslog-ng/logsource.h
-include/syslog-ng/logstamp.h
-include/syslog-ng/logthrdestdrv.h
-include/syslog-ng/logwriter.h
-include/syslog-ng/mainloop-call.h
-include/syslog-ng/mainloop-io-worker.h
-include/syslog-ng/mainloop-worker.h
-include/syslog-ng/mainloop.h
-include/syslog-ng/memtrace.h
-include/syslog-ng/messages.h
-include/syslog-ng/misc.h
-include/syslog-ng/ml-batched-timer.h
-include/syslog-ng/msg-format.h
-include/syslog-ng/nvtable.h
-include/syslog-ng/parse-number.h
-include/syslog-ng/parser/parser-expr-parser.h
-include/syslog-ng/parser/parser-expr.h
-include/syslog-ng/pathutils.h
-include/syslog-ng/persist-state.h
-include/syslog-ng/persistable-state-header.h
-include/syslog-ng/persistable-state-presenter.h
-include/syslog-ng/plugin-types.h
-include/syslog-ng/plugin.h
-include/syslog-ng/poll-events.h
-include/syslog-ng/poll-fd-events.h
-include/syslog-ng/pragma-parser.h
-include/syslog-ng/presented-persistable-state.h
-include/syslog-ng/rcptid.h
-include/syslog-ng/reloc.h
-include/syslog-ng/rewrite/rewrite-expr-parser.h
-include/syslog-ng/rewrite/rewrite-expr.h
-include/syslog-ng/rewrite/rewrite-groupset.h
-include/syslog-ng/rewrite/rewrite-set-tag.h
-include/syslog-ng/rewrite/rewrite-set.h
-include/syslog-ng/rewrite/rewrite-subst.h
-include/syslog-ng/ringbuffer.h
-include/syslog-ng/run-id.h
-include/syslog-ng/scratch-buffers.h
-include/syslog-ng/serialize.h
-include/syslog-ng/service-management.h
-include/syslog-ng/stats/stats-cluster.h
-include/syslog-ng/stats/stats-counter.h
-include/syslog-ng/stats/stats-csv.h
-include/syslog-ng/stats/stats-log.h
-include/syslog-ng/stats/stats-registry.h
-include/syslog-ng/stats/stats-syslog.h
-include/syslog-ng/stats/stats.h
-include/syslog-ng/str-format.h
-include/syslog-ng/syslog-names.h
-include/syslog-ng/syslog-ng.h
-include/syslog-ng/tags.h
-include/syslog-ng/template/templates.h
-include/syslog-ng/thread-utils.h
-include/syslog-ng/timeutils.h
-include/syslog-ng/tls-support.h
-include/syslog-ng/tlscontext.h
-include/syslog-ng/transport/logtransport.h
-include/syslog-ng/transport/transport-aux-data.h
-include/syslog-ng/transport/transport-device.h
-include/syslog-ng/transport/transport-file.h
-include/syslog-ng/transport/transport-pipe.h
-include/syslog-ng/transport/transport-socket.h
-include/syslog-ng/transport/transport-tls.h
-include/syslog-ng/type-hinting.h
-include/syslog-ng/uuid.h
-include/syslog-ng/value-pairs.h
-include/syslog-ng/versioning.h
-include/syslog-ng/vptransform.h
-lib/libsyslog-ng-3.6.so.0.0.0
-lib/libsyslog-ng.so
-lib/libsyslog-ng-3.6.so.0
-lib/syslog-ng/libafamqp.so
-lib/syslog-ng/libaffile.so
-lib/syslog-ng/libafmongodb.so
-lib/syslog-ng/libafprog.so
-lib/syslog-ng/libafsocket-notls.so
-lib/syslog-ng/libafsocket.so
-lib/syslog-ng/libafstomp.so
-lib/syslog-ng/libafuser.so
-lib/syslog-ng/libbasicfuncs.so
-lib/syslog-ng/libconfgen.so
-lib/syslog-ng/libcryptofuncs.so
-lib/syslog-ng/libcsvparser.so
-lib/syslog-ng/libdbparser.so
-lib/syslog-ng/libgraphite.so
-lib/syslog-ng/liblinux-kmsg-format.so
-lib/syslog-ng/libpseudofile.so
-lib/syslog-ng/libsyslog-ng-crypto.so
-lib/syslog-ng/libsyslogformat.so
-lib/syslog-ng/libsystem-source.so
-lib/syslog-ng/libtest/libsyslog-ng-test.a
-libdata/pkgconfig/syslog-ng.pc
-libdata/pkgconfig/syslog-ng-test.pc
-man/man1/loggen.1.gz
-man/man1/pdbtool.1.gz
-man/man1/syslog-ng-ctl.1.gz
-man/man5/syslog-ng.conf.5.gz
-man/man8/syslog-ng.8.gz
-sbin/syslog-ng
-sbin/syslog-ng-ctl
-share/syslog-ng/include/scl/graphite/plugin.conf
-share/syslog-ng/include/scl/graphite/README
-share/syslog-ng/include/scl/nodejs/plugin.conf
-share/syslog-ng/include/scl/pacct/plugin.conf
-share/syslog-ng/include/scl/syslogconf/README
-share/syslog-ng/include/scl/syslogconf/convert-syslogconf.awk
-share/syslog-ng/include/scl/syslogconf/plugin.conf
-share/syslog-ng/include/scl/system/plugin.conf
-share/syslog-ng/include/scl/rewrite/cc-mask.conf
-share/syslog-ng/tools/cfg-grammar.y
-share/syslog-ng/tools/lex-rules.am
-share/syslog-ng/tools/merge-grammar.pl
-share/syslog-ng/tools/system-expand
-share/syslog-ng/xsd/patterndb-1.xsd
-share/syslog-ng/xsd/patterndb-2.xsd
-share/syslog-ng/xsd/patterndb-3.xsd
-share/syslog-ng/xsd/patterndb-4.xsd
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/NEWS.md
-@dir etc/patterndb.d