aboutsummaryrefslogtreecommitdiff
path: root/sysutils/system-tools-backends
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
commit190418a078b1eb7ea3c5d38a08bdab3cbd422086 (patch)
treebb336ccecde7052d26d3d8d8c97238744a373aad /sysutils/system-tools-backends
parent6b0c40606cac591d75b88d05c7276bd16c369035 (diff)
downloadports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.tar.gz
ports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.zip
Notes
Diffstat (limited to 'sysutils/system-tools-backends')
-rw-r--r--sysutils/system-tools-backends/Makefile45
-rw-r--r--sysutils/system-tools-backends/distinfo2
-rw-r--r--sysutils/system-tools-backends/files/patch-replace.pl.in29
-rw-r--r--sysutils/system-tools-backends/files/patch-service-list.pl.in10
-rw-r--r--sysutils/system-tools-backends/pkg-descr4
-rw-r--r--sysutils/system-tools-backends/pkg-plist96
6 files changed, 186 insertions, 0 deletions
diff --git a/sysutils/system-tools-backends/Makefile b/sysutils/system-tools-backends/Makefile
new file mode 100644
index 000000000000..d4133bcff47f
--- /dev/null
+++ b/sysutils/system-tools-backends/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: system-tools-backends
+# Date created: 11 February 2005
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= system-tools-backends
+PORTVERSION= 1.2.0
+CATEGORIES= sysutils gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.2
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Backend system admin scripts for gnome-system-tools
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_PERL5= yes
+PREFIX?= ${X11BASE}
+USE_GNOME= gnomehack gnometarget intlhack
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3
+MTREE_FILE= /etc/mtree/BSD.x11.dist
+.else
+MTREE_FILE= /etc/mtree/BSD.x11-4.dist
+.endif
+
+.if ${PERL_LEVEL} <= 500800
+RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+.endif
+
+.if ${PERL_LEVEL} < 500600
+post-configure:
+ @${FIND} ${WRKSRC} \( -name "*.pl" -or -name "*-conf" \) | \
+ ${XARGS} ${REINPLACE_CMD} -e 's|@scriptsdir|[@]scriptsdir|g'
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/system-tools-backends/distinfo b/sysutils/system-tools-backends/distinfo
new file mode 100644
index 000000000000..1fd288819b40
--- /dev/null
+++ b/sysutils/system-tools-backends/distinfo
@@ -0,0 +1,2 @@
+MD5 (gnome2/system-tools-backends-1.2.0.tar.bz2) = 96b00eb0f800c1b5346be2f71d4dc3b2
+SIZE (gnome2/system-tools-backends-1.2.0.tar.bz2) = 532611
diff --git a/sysutils/system-tools-backends/files/patch-replace.pl.in b/sysutils/system-tools-backends/files/patch-replace.pl.in
new file mode 100644
index 000000000000..9487b290dd52
--- /dev/null
+++ b/sysutils/system-tools-backends/files/patch-replace.pl.in
@@ -0,0 +1,29 @@
+--- replace.pl.in.orig Tue Dec 21 11:17:14 2004
++++ replace.pl.in Thu Dec 23 13:14:41 2004
+@@ -1128,7 +1128,7 @@
+
+ while ($line_no < $line_end)
+ {
+- delete $$buff[$line_no];
++ splice @{$buff},$line_no,1;
+ $line_no++;
+ }
+
+@@ -1140,7 +1140,7 @@
+
+ while ($line_no < $line_end)
+ {
+- delete $$buff[$line_no];
++ splice @{$buff},$line_no,1;
+ $line_no++;
+ }
+ }
+@@ -1680,7 +1680,7 @@
+ }
+ else
+ {
+- delete $$buff[$i];
++ splice @{$buff},$i,1;
+ }
+ }
+ }
diff --git a/sysutils/system-tools-backends/files/patch-service-list.pl.in b/sysutils/system-tools-backends/files/patch-service-list.pl.in
new file mode 100644
index 000000000000..8020a0e52c1e
--- /dev/null
+++ b/sysutils/system-tools-backends/files/patch-service-list.pl.in
@@ -0,0 +1,10 @@
+--- service-list.pl.in.orig Sun Sep 19 13:20:02 2004
++++ service-list.pl.in Sun Sep 19 13:20:10 2004
+@@ -225,6 +225,7 @@
+ "atm3\.sh",
+ "ccd",
+ "cleanvar",
++ "cleartmp",
+ "devdb",
+ "devfs",
+ "dhclient",
diff --git a/sysutils/system-tools-backends/pkg-descr b/sysutils/system-tools-backends/pkg-descr
new file mode 100644
index 000000000000..c92b12768beb
--- /dev/null
+++ b/sysutils/system-tools-backends/pkg-descr
@@ -0,0 +1,4 @@
+System-tools-backends is a collection of scripts (mostly Perl) used by
+gnome-sytem-tools to perform system administration tasks.
+
+WWW: http://www.gnome.org/projects/gst/
diff --git a/sysutils/system-tools-backends/pkg-plist b/sysutils/system-tools-backends/pkg-plist
new file mode 100644
index 000000000000..da943e8f93fd
--- /dev/null
+++ b/sysutils/system-tools-backends/pkg-plist
@@ -0,0 +1,96 @@
+libdata/pkgconfig/system-tools-backends.pc
+share/aclocal/system-tools-backends.m4
+share/locale/ar/LC_MESSAGES/setup-tools-backends.mo
+share/locale/az/LC_MESSAGES/setup-tools-backends.mo
+share/locale/bg/LC_MESSAGES/setup-tools-backends.mo
+share/locale/bn/LC_MESSAGES/setup-tools-backends.mo
+share/locale/bs/LC_MESSAGES/setup-tools-backends.mo
+share/locale/ca/LC_MESSAGES/setup-tools-backends.mo
+share/locale/cs/LC_MESSAGES/setup-tools-backends.mo
+share/locale/da/LC_MESSAGES/setup-tools-backends.mo
+share/locale/de/LC_MESSAGES/setup-tools-backends.mo
+share/locale/el/LC_MESSAGES/setup-tools-backends.mo
+share/locale/en_CA/LC_MESSAGES/setup-tools-backends.mo
+share/locale/en_GB/LC_MESSAGES/setup-tools-backends.mo
+share/locale/es/LC_MESSAGES/setup-tools-backends.mo
+share/locale/eu/LC_MESSAGES/setup-tools-backends.mo
+share/locale/fi/LC_MESSAGES/setup-tools-backends.mo
+share/locale/fr/LC_MESSAGES/setup-tools-backends.mo
+share/locale/gu/LC_MESSAGES/setup-tools-backends.mo
+share/locale/hi/LC_MESSAGES/setup-tools-backends.mo
+share/locale/hr/LC_MESSAGES/setup-tools-backends.mo
+share/locale/hu/LC_MESSAGES/setup-tools-backends.mo
+share/locale/id/LC_MESSAGES/setup-tools-backends.mo
+share/locale/it/LC_MESSAGES/setup-tools-backends.mo
+share/locale/ja/LC_MESSAGES/setup-tools-backends.mo
+share/locale/ko/LC_MESSAGES/setup-tools-backends.mo
+share/locale/lt/LC_MESSAGES/setup-tools-backends.mo
+share/locale/ms/LC_MESSAGES/setup-tools-backends.mo
+share/locale/nb/LC_MESSAGES/setup-tools-backends.mo
+share/locale/nl/LC_MESSAGES/setup-tools-backends.mo
+share/locale/no/LC_MESSAGES/setup-tools-backends.mo
+share/locale/pa/LC_MESSAGES/setup-tools-backends.mo
+share/locale/pl/LC_MESSAGES/setup-tools-backends.mo
+share/locale/pt/LC_MESSAGES/setup-tools-backends.mo
+share/locale/pt_BR/LC_MESSAGES/setup-tools-backends.mo
+share/locale/ro/LC_MESSAGES/setup-tools-backends.mo
+share/locale/sk/LC_MESSAGES/setup-tools-backends.mo
+share/locale/sq/LC_MESSAGES/setup-tools-backends.mo
+share/locale/sr/LC_MESSAGES/setup-tools-backends.mo
+share/locale/sr@Latn/LC_MESSAGES/setup-tools-backends.mo
+share/locale/sv/LC_MESSAGES/setup-tools-backends.mo
+share/locale/ta/LC_MESSAGES/setup-tools-backends.mo
+share/locale/th/LC_MESSAGES/setup-tools-backends.mo
+share/locale/tr/LC_MESSAGES/setup-tools-backends.mo
+share/locale/uk/LC_MESSAGES/setup-tools-backends.mo
+share/locale/vi/LC_MESSAGES/setup-tools-backends.mo
+share/locale/zh_CN/LC_MESSAGES/setup-tools-backends.mo
+share/locale/zh_TW/LC_MESSAGES/setup-tools-backends.mo
+share/setup-tool-backends/files/general_isdn_ppp_options
+share/setup-tool-backends/scripts/boot-conf
+share/setup-tool-backends/scripts/boot-grub.pl
+share/setup-tool-backends/scripts/boot-lilo.pl
+share/setup-tool-backends/scripts/boot-yaboot.pl
+share/setup-tool-backends/scripts/boot.pl
+share/setup-tool-backends/scripts/debug.pl
+share/setup-tool-backends/scripts/dhcpd-conf
+share/setup-tool-backends/scripts/dhcpd.pl
+share/setup-tool-backends/scripts/disks-conf
+share/setup-tool-backends/scripts/display-conf
+share/setup-tool-backends/scripts/file.pl
+share/setup-tool-backends/scripts/filesys.pl
+share/setup-tool-backends/scripts/font-conf
+share/setup-tool-backends/scripts/font.pl
+share/setup-tool-backends/scripts/general.pl
+share/setup-tool-backends/scripts/guess_system.sh
+share/setup-tool-backends/scripts/internetsharing-conf
+share/setup-tool-backends/scripts/ishare.pl
+share/setup-tool-backends/scripts/media.pl
+share/setup-tool-backends/scripts/memory-conf
+share/setup-tool-backends/scripts/mouse-conf
+share/setup-tool-backends/scripts/network-conf
+share/setup-tool-backends/scripts/network.pl
+share/setup-tool-backends/scripts/package-conf
+share/setup-tool-backends/scripts/parse.pl
+share/setup-tool-backends/scripts/partition.pl
+share/setup-tool-backends/scripts/platform.pl
+share/setup-tool-backends/scripts/print-conf
+share/setup-tool-backends/scripts/print.pl
+share/setup-tool-backends/scripts/process.pl
+share/setup-tool-backends/scripts/replace.pl
+share/setup-tool-backends/scripts/report.pl
+share/setup-tool-backends/scripts/service-list.pl
+share/setup-tool-backends/scripts/service.pl
+share/setup-tool-backends/scripts/services-conf
+share/setup-tool-backends/scripts/share.pl
+share/setup-tool-backends/scripts/shares-conf
+share/setup-tool-backends/scripts/time-conf
+share/setup-tool-backends/scripts/tokenizer.pl
+share/setup-tool-backends/scripts/type1inst
+share/setup-tool-backends/scripts/users-conf
+share/setup-tool-backends/scripts/util.pl
+share/setup-tool-backends/scripts/x.pl
+share/setup-tool-backends/scripts/xml.pl
+@dirrm share/setup-tool-backends/scripts
+@dirrm share/setup-tool-backends/files
+@dirrm share/setup-tool-backends