aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tarsnap
diff options
context:
space:
mode:
authorColin Percival <cperciva@FreeBSD.org>2009-07-05 09:36:28 +0000
committerColin Percival <cperciva@FreeBSD.org>2009-07-05 09:36:28 +0000
commit81b5dde2e9677554f32256f679cb63b01d2ed98c (patch)
tree446aa5a60e752b63c59a37a58d0129517bdfb7ce /sysutils/tarsnap
parentd075a884a9197f049c1ce77f887b46be54fe8eef (diff)
downloadports-81b5dde2e9677554f32256f679cb63b01d2ed98c.tar.gz
ports-81b5dde2e9677554f32256f679cb63b01d2ed98c.zip
Notes
Diffstat (limited to 'sysutils/tarsnap')
-rw-r--r--sysutils/tarsnap/Makefile42
-rw-r--r--sysutils/tarsnap/distinfo3
-rw-r--r--sysutils/tarsnap/pkg-descr12
-rw-r--r--sysutils/tarsnap/pkg-message14
-rw-r--r--sysutils/tarsnap/pkg-plist6
5 files changed, 77 insertions, 0 deletions
diff --git a/sysutils/tarsnap/Makefile b/sysutils/tarsnap/Makefile
new file mode 100644
index 000000000000..cb07f01062be
--- /dev/null
+++ b/sysutils/tarsnap/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: Tarsnap backup client
+# Date created: 2009-07-04
+# Whom: Colin Percival
+#
+# $FreeBSD$
+#
+
+PORTNAME= tarsnap
+PORTVERSION= 1.0.24
+CATEGORIES= sysutils
+MASTER_SITES= https://beta.tarsnap.com/download/
+DISTNAME= ${PORTNAME}-autoconf-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= cperciva@tarsnap.com
+COMMENT= Online encrypted backup service (client)
+
+RESTRICTED= license restricts redistribution of source and binaries
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+MAN1= tarsnap.1 tarsnap-keygen.1 tarsnap-keymgmt.1
+MAN5= tarsnap.conf.5
+
+OPTIONS= SSE2 "Use SSE2-optimized code" Off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_SSE2)
+CONFIGURE_ARGS+= --enable-sse2
+.else
+CONFIGURE_ARGS+= --disable-sse2
+.endif
+
+post-install:
+ @if [ ! -f ${PREFIX}/etc/tarsnap.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/tarsnap.conf.sample ${PREFIX}/etc/tarsnap.conf ; \
+ fi
+ @${CAT} ${PKGDIR}/pkg-message
+
+.include <bsd.port.mk>
diff --git a/sysutils/tarsnap/distinfo b/sysutils/tarsnap/distinfo
new file mode 100644
index 000000000000..c32a8365f9d8
--- /dev/null
+++ b/sysutils/tarsnap/distinfo
@@ -0,0 +1,3 @@
+MD5 (tarsnap-autoconf-1.0.24.tgz) = cd27c6aeb624f2dead1c11c4fd322e64
+SHA256 (tarsnap-autoconf-1.0.24.tgz) = 55db2cfa222d60eee8e084a6325b558220813f07a28d0ae1be1d257d012510ae
+SIZE (tarsnap-autoconf-1.0.24.tgz) = 589225
diff --git a/sysutils/tarsnap/pkg-descr b/sysutils/tarsnap/pkg-descr
new file mode 100644
index 000000000000..694358fe1f9b
--- /dev/null
+++ b/sysutils/tarsnap/pkg-descr
@@ -0,0 +1,12 @@
+Tarsnap is an online encrypted backup service. It presents a tar-like
+command-line interface, but stores data online rather than locally;
+using ideas taken from the author's FreeBSD Update and Portsnap
+utilities, it maximizes performance by recognizing duplicate data and
+only storing it once, and cryptographically encrypts and signs archives
+using locally-held keys in order to guarantee that nobody without access
+to the key file (including the author) can read or modify archives.
+
+WWW: http://www.tarsnap.com/
+
+- Colin Percival
+cperciva@tarsnap.com
diff --git a/sysutils/tarsnap/pkg-message b/sysutils/tarsnap/pkg-message
new file mode 100644
index 000000000000..b430904d370d
--- /dev/null
+++ b/sysutils/tarsnap/pkg-message
@@ -0,0 +1,14 @@
+================================================================================
+
+If you have never used tarsnap before, you will need to create an account
+with the tarsnap service and deposit money into the account before you
+can start using tarsnap; see
+ https://beta.tarsnap.com/gettingstarted.html
+for details.
+
+Once you have a tarsnap account you will need to create a key file using
+the tarsnap-keygen utility before you start storing archives; this key
+file MUST BE KEPT IN A SAFE LOCATION since you will not be able to read
+your backups without it.
+
+================================================================================
diff --git a/sysutils/tarsnap/pkg-plist b/sysutils/tarsnap/pkg-plist
new file mode 100644
index 000000000000..b6488af3bb1b
--- /dev/null
+++ b/sysutils/tarsnap/pkg-plist
@@ -0,0 +1,6 @@
+bin/tarsnap
+bin/tarsnap-keygen
+bin/tarsnap-keymgmt
+@unexec if cmp -s %D/etc/tarsnap.conf.sample %D/etc/tarsnap.conf; then rm -f %D/etc/tarsnap.conf; fi
+etc/tarsnap.conf.sample
+@exec if [ ! -f %D/etc/tarsnap.conf ] ; then cp -p %D/%F %B/tarsnap.conf; fi