aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tclsyslog/Makefile
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2008-04-17 14:20:23 +0000
committerWesley Shields <wxs@FreeBSD.org>2008-04-17 14:20:23 +0000
commit4bcb0f29b8b4c5c0e020856ba39fe70884e34950 (patch)
treede96fe91f973777ead3462917e864de3c001796c /sysutils/tclsyslog/Makefile
parent752349aa2b4927d2e8b5a7cff5dd3210c0379dfd (diff)
Notes
Diffstat (limited to 'sysutils/tclsyslog/Makefile')
-rw-r--r--sysutils/tclsyslog/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/sysutils/tclsyslog/Makefile b/sysutils/tclsyslog/Makefile
new file mode 100644
index 000000000000..5fc6251aa154
--- /dev/null
+++ b/sysutils/tclsyslog/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: tclsyslog
+# Date created: 31 March 2008
+# Whom: Frank Fenor <frank@fenor.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tclsyslog
+PORTVERSION= 2.1
+CATEGORIES= sysutils tcl
+MASTER_SITES= http://ftp.wagner.pp.ru/pub/tcl/tclsyslog/
+
+MAINTAINER= frank@fenor.de
+COMMENT= Tcl Interface to Syslog
+
+USE_TCL= 82+
+MANN= syslog.n
+MANCOMPRESSED= no
+
+WRKSRC= ${WRKDIR}/tclsyslog
+
+PLIST_FILES= lib/syslog/libsyslog.so.2.1 \
+ lib/syslog/pkgIndex.tcl
+PLIST_DIRS= lib/syslog
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's|CC=gcc|CC=${CC}|' \
+ -e 's| gcc| $${CC} $${CFLAGS}|' \
+ -e 's|CFLAGS=|CFLAGS=${CFLAGS}|' \
+ -e 's|LDFLAGS=-shared -L/usr/local/lib|LDFLAGS=-shared -L${PREFIX}/lib|' \
+ -e 's|PREFIX=/usr/local|PREFIX=${PREFIX}|' \
+ -e 's|INCLUDES=-I/usr/local/include|INCLUDES=-I${TCL_INCLUDEDIR}|' \
+ -e 's|LOADLIBES=-ltclstub8.2|LOADLIBES=-ltclstub${TCL_VER:S/.//}|' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>