aboutsummaryrefslogtreecommitdiff
path: root/sysutils/testdisk
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-04-18 19:42:57 +0000
committerClement Laforet <clement@FreeBSD.org>2004-04-18 19:42:57 +0000
commit0459402774ffe659ac2e8d942e4b4ab022660366 (patch)
tree4a4c6d3169ca88687f51b0b9cb0c193be7317b56 /sysutils/testdisk
parente30e9b20be1fd2e89493a448bf44e32c37595079 (diff)
downloadports-0459402774ffe659ac2e8d942e4b4ab022660366.tar.gz
ports-0459402774ffe659ac2e8d942e4b4ab022660366.zip
Notes
Diffstat (limited to 'sysutils/testdisk')
-rw-r--r--sysutils/testdisk/Makefile54
-rw-r--r--sysutils/testdisk/distinfo2
-rw-r--r--sysutils/testdisk/pkg-descr18
3 files changed, 74 insertions, 0 deletions
diff --git a/sysutils/testdisk/Makefile b/sysutils/testdisk/Makefile
new file mode 100644
index 000000000000..a2dd41a0c8ee
--- /dev/null
+++ b/sysutils/testdisk/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: testdisk
+# Date created: Feb 28 2004
+# Whom: Florent Thoumie <flz@xbsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= testdisk
+PORTVERSION= 5.1
+CATEGORIES= sysutils
+MASTER_SITES= http://www.cgsecurity.org/
+
+MAINTAINER= flz@xbsd.org
+COMMENT= Tool to check and undelete partitions
+
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
+USE_REINPLACE= yes
+PLIST_FILES= bin/testdisk
+
+.if defined(WITH_E2FSPROGS)
+BUILD_DEPENDS+= ext2fs.2:${PORTSDIR}/sysutils/e2fsprogs
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500040
+IGNORE= "Requires FreeBSD 5.x, some defines are missing in sys/disk.h before __FreeBSD_version 500040"
+.endif
+
+.if !defined(WITH_E2FSPROGS)
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You can define the following for additional features:"
+ @${ECHO_MSG} ""
+.if !defined(WITH_E2FSPROGS)
+ @${ECHO_MSG} "WITH_E2FSPROGS - Use ext2fs extensions.
+.endif
+ @${ECHO_MSG} ""
+.endif
+
+post-patch:
+.if defined(WITH_E2FSPROGS)
+ @${REINPLACE_CMD} -e 's|-DHAVE_PROGSREISERFS31.*||' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|^\(LIBS=\).*|\1${PREFIX}/lib/libext2fs.a|' ${WRKSRC}/Makefile
+.else
+ @${REINPLACE_CMD} -e 's|-DHAVE_E2FSPROGS.*||' ${WRKSRC}/Makefile
+.endif
+ @${REINPLACE_CMD} -e 's|^bsd:|all:|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|^\(LIBSA=\).*|\1|' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/testdisk ${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/testdisk/distinfo b/sysutils/testdisk/distinfo
new file mode 100644
index 000000000000..1c8f78fa7712
--- /dev/null
+++ b/sysutils/testdisk/distinfo
@@ -0,0 +1,2 @@
+MD5 (testdisk-5.1.tar.gz) = c86eb08730a52a113ae572de75ff9c9e
+SIZE (testdisk-5.1.tar.gz) = 618498
diff --git a/sysutils/testdisk/pkg-descr b/sysutils/testdisk/pkg-descr
new file mode 100644
index 000000000000..80b545c09958
--- /dev/null
+++ b/sysutils/testdisk/pkg-descr
@@ -0,0 +1,18 @@
+Tool to check and undelete partition
+Works with the following partitions:
+- FAT12 FAT16 FAT32
+- Linux EXT2/EXT3
+- Linux SWAP (version 1 and 2)
+- NTFS (Windows NT/W2K/XP)
+- BeFS (BeOS)
+- UFS (BSD)
+- Netware
+- ReiserFS
+
+TestDisk is under GNU Public License.
+You can compile it under Dos with DJGPP or under Linux or BSD with gcc.
+
+WWW: http://www.cgsecurity.org/
+
+- Florent Thoumie
+flz@xbsd.org