aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tm
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-12-18 15:44:11 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-12-18 15:44:11 +0000
commitb94d3337c09a1cf07ec9acabeb6ae05758817f9d (patch)
tree4b162414f60a33fdbcd04513dad56480b4f6e0d5 /sysutils/tm
parent38e579be6db5c808f2275494f53ba0ea867d1d1b (diff)
Notes
Diffstat (limited to 'sysutils/tm')
-rw-r--r--sysutils/tm/Makefile36
-rw-r--r--sysutils/tm/distinfo3
-rw-r--r--sysutils/tm/pkg-descr16
3 files changed, 55 insertions, 0 deletions
diff --git a/sysutils/tm/Makefile b/sysutils/tm/Makefile
new file mode 100644
index 000000000000..181d27f4d681
--- /dev/null
+++ b/sysutils/tm/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: tm
+# Date created: 18 December 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tm
+PORTVERSION= 0.4
+CATEGORIES= sysutils
+MASTER_SITES= http://vicerveza.homeunix.net/~viric/soft/tm/ CENKES
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Terminal mixer
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= ChangeLog DOCS index.html
+MAKE_ENV= LINUX_LIBS=-lutil
+
+post-extract:
+ @${MV} ${WRKSRC}/web/index.html ${WRKSRC}/
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$^|$${.ALLSRC}|;/^GLIBCFLAGS/d;/^CFLAGS/d;\
+ /^CC/d;/^ifeq/,/^endif/d' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|pty.h|libutil.h|' ${WRKSRC}/app_term.c
+ @${ECHO_CMD} '#include <string.h>' >> ${WRKSRC}/main.h
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}/
+ @cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/tm/distinfo b/sysutils/tm/distinfo
new file mode 100644
index 000000000000..aad31703325f
--- /dev/null
+++ b/sysutils/tm/distinfo
@@ -0,0 +1,3 @@
+MD5 (tm-0.4.tar.gz) = ce4f105d8c450e2bdbda035941dee534
+SHA256 (tm-0.4.tar.gz) = ff3a59cb1f61804fed0a631235443f531048e0c78898cecb462b1d716e1b1630
+SIZE (tm-0.4.tar.gz) = 28606
diff --git a/sysutils/tm/pkg-descr b/sysutils/tm/pkg-descr
new file mode 100644
index 000000000000..ed65dc22b01b
--- /dev/null
+++ b/sysutils/tm/pkg-descr
@@ -0,0 +1,16 @@
+Terminal mixer can start processes inside a pseudo-terminal, which can
+be accessed through a Unix socket, TCP or even raw ethernet (not yet
+ported to FreeBSD). The programs can be linked to the current
+terminal, or they can be unlinked like in nohup. But even in this
+latter case you can connect to them using the mentioned protocols.
+
+tm can also start programs as if they communicate through pipes
+instead of terminals, and this can be quite useful for
+remote-controlling applications.
+
+More than one client can connect to the served pseudo-terminal, either
+using tm as a client or telnet for TCP. You can choose if they are
+only allowed to read, or they can also contribute on input.
+
+WWW: http://vicerveza.homeunix.net/~viric/soft/tm/
+Author: Lluis Batlle i Rossell <viric_at_vicerveza_dot_homeunix_dot_net>