aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tmate-slave
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2016-05-27 19:58:42 +0000
committerSteve Wills <swills@FreeBSD.org>2016-05-27 19:58:42 +0000
commit61965a9e6b94225398eb76ecb2330c838c7be5f9 (patch)
treed392f50be77fbde3848d891672fb62f3244a03b9 /sysutils/tmate-slave
parent8946e732cecc52099c01320f90b976f83688f8c0 (diff)
Notes
Diffstat (limited to 'sysutils/tmate-slave')
-rw-r--r--sysutils/tmate-slave/Makefile31
-rw-r--r--sysutils/tmate-slave/distinfo3
-rw-r--r--sysutils/tmate-slave/files/patch-tmate-proxy.c10
-rw-r--r--sysutils/tmate-slave/files/patch-tmate-ssh-server.c11
-rw-r--r--sysutils/tmate-slave/pkg-descr3
5 files changed, 58 insertions, 0 deletions
diff --git a/sysutils/tmate-slave/Makefile b/sysutils/tmate-slave/Makefile
new file mode 100644
index 000000000000..96711f34eebf
--- /dev/null
+++ b/sysutils/tmate-slave/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= tmate-slave
+PORTVERSION= 0.0.0.2016051901
+CATEGORIES= sysutils
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Instant terminal sharing server
+
+LIB_DEPENDS= libevent.so:devel/libevent2 \
+ libmsgpackc.so:devel/msgpack \
+ libssh_threads.so:security/libssh
+
+USES= autoreconf pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= tmate-io
+GH_TAGNAME= b3c85fa
+
+GNU_CONFIGURE= yes
+INSTALL_ARGET= install-strip
+USE_LDCONFIG= yes
+LDFLAGS+= -lexecinfo
+
+PLIST_FILES= bin/tmate-slave
+
+BROKEN_FreeBSD_9= Does not build
+
+pre-configure:
+ @cd $(wrksrc} && ./autogen.sh
+
+.include <bsd.port.mk>
diff --git a/sysutils/tmate-slave/distinfo b/sysutils/tmate-slave/distinfo
new file mode 100644
index 000000000000..0d3e97a4479a
--- /dev/null
+++ b/sysutils/tmate-slave/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1463705525
+SHA256 (tmate-io-tmate-slave-0.0.0.2016051901-b3c85fa_GH0.tar.gz) = cc8a078a4fc44662b83b8e10e43b320eb3820d697f6357cb2bb439b156e2d6df
+SIZE (tmate-io-tmate-slave-0.0.0.2016051901-b3c85fa_GH0.tar.gz) = 618445
diff --git a/sysutils/tmate-slave/files/patch-tmate-proxy.c b/sysutils/tmate-slave/files/patch-tmate-proxy.c
new file mode 100644
index 000000000000..7d8db950b486
--- /dev/null
+++ b/sysutils/tmate-slave/files/patch-tmate-proxy.c
@@ -0,0 +1,10 @@
+--- tmate-proxy.c.orig 2016-04-26 08:05:24 UTC
++++ tmate-proxy.c
+@@ -2,6 +2,7 @@
+ #include <netinet/tcp.h>
+ #include <fcntl.h>
+ #include <errno.h>
++#include <netinet/in.h>
+
+ #include "tmate.h"
+ #include "tmate-protocol.h"
diff --git a/sysutils/tmate-slave/files/patch-tmate-ssh-server.c b/sysutils/tmate-slave/files/patch-tmate-ssh-server.c
new file mode 100644
index 000000000000..bafe72cf2168
--- /dev/null
+++ b/sysutils/tmate-slave/files/patch-tmate-ssh-server.c
@@ -0,0 +1,11 @@
+--- tmate-ssh-server.c.orig 2016-04-26 08:05:24 UTC
++++ tmate-ssh-server.c
+@@ -7,6 +7,8 @@
+ #include <stdio.h>
+ #include <event.h>
+ #include <arpa/inet.h>
++#include <netinet/in.h>
++#include <sys/signal.h>
+
+ #include "tmate.h"
+
diff --git a/sysutils/tmate-slave/pkg-descr b/sysutils/tmate-slave/pkg-descr
new file mode 100644
index 000000000000..75b18f7975d1
--- /dev/null
+++ b/sysutils/tmate-slave/pkg-descr
@@ -0,0 +1,3 @@
+Instant terminal sharing - server
+
+WWW: https://tmate.io/