aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tmux
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-12-22 01:38:53 +0000
committerWen Heping <wen@FreeBSD.org>2010-12-22 01:38:53 +0000
commit78f352b18ea886fea2d0d6f3f3be0e1ca9f712a8 (patch)
tree0a4b423feb26e89283d2cf73455176ee18b82642 /sysutils/tmux
parent215977f6ef4a066bc70147fe1dae0204d3ff4f79 (diff)
downloadports-78f352b18ea886fea2d0d6f3f3be0e1ca9f712a8.tar.gz
ports-78f352b18ea886fea2d0d6f3f3be0e1ca9f712a8.zip
Notes
Diffstat (limited to 'sysutils/tmux')
-rw-r--r--sysutils/tmux/Makefile1
-rw-r--r--sysutils/tmux/distinfo1
-rw-r--r--sysutils/tmux/files/patch-configure10
-rw-r--r--sysutils/tmux/files/patch_server-window.c13
4 files changed, 24 insertions, 1 deletions
diff --git a/sysutils/tmux/Makefile b/sysutils/tmux/Makefile
index 43946d21a1b8..24c73593466e 100644
--- a/sysutils/tmux/Makefile
+++ b/sysutils/tmux/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tmux
PORTVERSION= 1.3
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
diff --git a/sysutils/tmux/distinfo b/sysutils/tmux/distinfo
index 46890ada7844..ed441f8be068 100644
--- a/sysutils/tmux/distinfo
+++ b/sysutils/tmux/distinfo
@@ -1,3 +1,2 @@
-MD5 (tmux-1.3.tar.gz) = 96e60cb206de2db0610b9fb6a64c2251
SHA256 (tmux-1.3.tar.gz) = 72c2d6f1c30fb4ccbd29b530a7d8a08e67c9c2d87ac8d67e3806561670fc0362
SIZE (tmux-1.3.tar.gz) = 251999
diff --git a/sysutils/tmux/files/patch-configure b/sysutils/tmux/files/patch-configure
new file mode 100644
index 000000000000..977d6fbcaa79
--- /dev/null
+++ b/sysutils/tmux/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig 2010-12-22 09:03:15.000000000 +0800
++++ configure 2010-12-22 09:03:49.000000000 +0800
+@@ -208,7 +208,6 @@
+ FreeBSD|DragonFly)
+ cat <<EOF >>$CONFIG_H
+ #define HAVE_ASPRINTF
+-#define HAVE_BROKEN_KQUEUE
+ #define HAVE_BZERO
+ #define HAVE_DAEMON
+ #define HAVE_FGETLN
diff --git a/sysutils/tmux/files/patch_server-window.c b/sysutils/tmux/files/patch_server-window.c
new file mode 100644
index 000000000000..cdda2949ccb3
--- /dev/null
+++ b/sysutils/tmux/files/patch_server-window.c
@@ -0,0 +1,13 @@
+@@ -109,10 +109,8 @@
+
+ if (!(w->flags & WINDOW_BELL) || wl->flags & WINLINK_BELL)
+ return (0);
+- if (s->curw == wl)
+- return (0);
+-
+- wl->flags |= WINLINK_BELL;
++ if (s->curw != wl)
++ wl->flags |= WINLINK_BELL;
+
+ action = options_get_number(&s->options, "bell-action");
+ switch (action) {