aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tmux
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-05-25 00:29:33 +0000
committerWen Heping <wen@FreeBSD.org>2011-05-25 00:29:33 +0000
commit7e66cdfd322650e45aa4114d5314a0b91aa061f0 (patch)
tree6735113c49f6141aaf8ed363f4fb89d9c56a8a52 /sysutils/tmux
parentc979e32c0a9681735afd56088edc9561569243b1 (diff)
downloadports-7e66cdfd322650e45aa4114d5314a0b91aa061f0.tar.gz
ports-7e66cdfd322650e45aa4114d5314a0b91aa061f0.zip
Notes
Diffstat (limited to 'sysutils/tmux')
-rw-r--r--sysutils/tmux/Makefile50
-rw-r--r--sysutils/tmux/files/extra-patch-tty-keys.c (renamed from sysutils/tmux/files/patch-tty-keys.c)0
2 files changed, 38 insertions, 12 deletions
diff --git a/sysutils/tmux/Makefile b/sysutils/tmux/Makefile
index b1554bf9d320..30059b8639f2 100644
--- a/sysutils/tmux/Makefile
+++ b/sysutils/tmux/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tmux
PORTVERSION= 1.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -23,12 +23,10 @@ PLIST_FILES= bin/tmux
PORTDOCS= CHANGES FAQ NOTES
PORTEXAMPLES= *
-CFLAGS+= -I${LOCALBASE}/include
-#LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
-
-OPTIONS= KQUEUE "Build without define HAVE_BROKEN_KQUEUE " On \
- LIBEVENT_STATIC "Build with static libevent" Off
+OPTIONS= KQUEUE "Build without define HAVE_BROKEN_KQUEUE " On \
+ LIBEVENT2 "Use libevent version 2" Off \
+ LIBEVENT_STATIC "Build with static libevent" Off \
+ BACKSPACE "Build with tty/keys patch" Off
# Now I set tmux build without #define HAVE_BROKEN_KQUEUE as default and an option,
# If it still hang the system or other run error, try as upstream suggest:
@@ -36,10 +34,32 @@ OPTIONS= KQUEUE "Build without define HAVE_BROKEN_KQUEUE " On \
.include <bsd.port.pre.mk>
+.if defined(WITH_LIBEVENT2)
+CFLAGS+= -I${LOCALBASE}/include/event2/compat -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib/event2
+.else
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+.endif
+
+MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+
.if defined(WITH_LIBEVENT_STATIC)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent
+. if defined(WITH_LIBEVENT2)
+_LEVENT_LIB= ${LOCALBASE}/lib/event2/libevent.a
+BUILD_DEPENDS+= ${_LEVENT_LIB}:${PORTSDIR}/devel/libevent2
+. else
+_LEVENT_LIB= ${LOCALBASE}/lib/libevent.a
+BUILD_DEPENDS+= ${_LEVENT_LIB}:${PORTSDIR}/devel/libevent
+. endif
.else
+. if defined(WITH_LIBEVENT2)
+_LEVENT_LIB= -levent-2.0
+LIB_DEPENDS= event-2.0:${PORTSDIR}/devel/libevent2
+. else
+_LEVENT_LIB= -levent-1.4
LIB_DEPENDS= event-1.4:${PORTSDIR}/devel/libevent
+. endif
.endif
.if !defined(WITHOUT_KQUEUE)
@@ -52,13 +72,19 @@ EXTRA_PATCHES= ${PATCHDIR}/extra-patch-kqueue
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-fb7
.endif
+.if defined(WITH_BACKSPACE)
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-tty-keys.c
+.endif
+
post-patch:
- @${REINPLACE_CMD} -e 's#/usr/local#${LOCALBASE}#g' \
+ @${REINPLACE_CMD} -e 's|/etc/tmux.conf|${PREFIX}/etc/tmux.conf|g' \
+ ${WRKSRC}/tmux.1 ${WRKSRC}/tmux.h
+ @${REINPLACE_CMD} -e 's|-I/usr/local/include||g' \
+ -e 's|/usr/local|${LOCALBASE}|g' \
+ -e 's|LDFLAGS+=|#LDFLAGS+=|g' \
${WRKSRC}/Makefile
-.if defined(WITH_LIBEVENT_STATIC)
- @${REINPLACE_CMD} -e 's|-levent|${LOCALBASE}/lib/libevent.a|g' \
+ @${REINPLACE_CMD} -e 's|-levent|${_LEVENT_LIB}|g' \
${WRKSRC}/configure
-.endif
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/tmux ${PREFIX}/bin
diff --git a/sysutils/tmux/files/patch-tty-keys.c b/sysutils/tmux/files/extra-patch-tty-keys.c
index 6a8bf625c9cc..6a8bf625c9cc 100644
--- a/sysutils/tmux/files/patch-tty-keys.c
+++ b/sysutils/tmux/files/extra-patch-tty-keys.c