aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tmux
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-05-04 08:23:47 +0000
committerMathieu Arnold <mat@FreeBSD.org>2020-05-04 08:23:47 +0000
commit12abc12774aa901b45e7fee03cd049fc7228dfab (patch)
treeb090788c13089e774527ea5afbfca9c5792a7d35 /sysutils/tmux
parent29d2ca2029e35686384be675e4169f697e50ca42 (diff)
Notes
Diffstat (limited to 'sysutils/tmux')
-rw-r--r--sysutils/tmux/Makefile1
-rw-r--r--sysutils/tmux/files/patch-6a33a12798b2afeee6fb7bba74d86d628137921e18
2 files changed, 19 insertions, 0 deletions
diff --git a/sysutils/tmux/Makefile b/sysutils/tmux/Makefile
index 416545e0078d..eb015dc96e5d 100644
--- a/sysutils/tmux/Makefile
+++ b/sysutils/tmux/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tmux
PORTVERSION= 3.1a
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= https://github.com/tmux/tmux/releases/download/${PORTVERSION}/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
diff --git a/sysutils/tmux/files/patch-6a33a12798b2afeee6fb7bba74d86d628137921e b/sysutils/tmux/files/patch-6a33a12798b2afeee6fb7bba74d86d628137921e
new file mode 100644
index 000000000000..bc1202ad1cd0
--- /dev/null
+++ b/sysutils/tmux/files/patch-6a33a12798b2afeee6fb7bba74d86d628137921e
@@ -0,0 +1,18 @@
+From 6a33a12798b2afeee6fb7bba74d86d628137921e Mon Sep 17 00:00:00 2001
+From: Nicholas Marriott <nicholas.marriott@gmail.com>
+Date: Thu, 30 Apr 2020 15:20:08 +0100
+Subject: [PATCH] Do not remove the automatic-rename option from the global
+ set, only from the window (it must stay in the global set or tmux will
+ crash). GitHub issue 2188.
+
+--- input.c.orig 2020-04-29 20:01:18 UTC
++++ input.c
+@@ -2304,7 +2304,7 @@ input_exit_rename(struct input_ctx *ictx)
+ return;
+
+ if (ictx->input_len == 0) {
+- oe = options_get(wp->window->options, "automatic-rename");
++ oe = options_get_only(wp->window->options, "automatic-rename");
+ if (oe != NULL)
+ options_remove(oe);
+ return;