aboutsummaryrefslogtreecommitdiff
path: root/sysutils/torsmo
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-01-12 04:34:45 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-01-12 04:34:45 +0000
commite2be50057ad6c0918dfff897c7b74e3b6cc3f688 (patch)
tree6bf83cc97e8a883ccc19a413ca4ed02fab82871b /sysutils/torsmo
parent1729b094e7cbe6c7e5f213ce95f895182a0e7fe0 (diff)
downloadports-e2be50057ad6c0918dfff897c7b74e3b6cc3f688.tar.gz
ports-e2be50057ad6c0918dfff897c7b74e3b6cc3f688.zip
Notes
Diffstat (limited to 'sysutils/torsmo')
-rw-r--r--sysutils/torsmo/Makefile1
-rw-r--r--sysutils/torsmo/files/patch-freebsd.c11
2 files changed, 11 insertions, 1 deletions
diff --git a/sysutils/torsmo/Makefile b/sysutils/torsmo/Makefile
index 3a0582226579..30732b3f9ada 100644
--- a/sysutils/torsmo/Makefile
+++ b/sysutils/torsmo/Makefile
@@ -7,6 +7,7 @@
PORTNAME= torsmo
PORTVERSION= 0.18
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/sysutils/torsmo/files/patch-freebsd.c b/sysutils/torsmo/files/patch-freebsd.c
index 91b2eca45358..109d6bfb13c2 100644
--- a/sysutils/torsmo/files/patch-freebsd.c
+++ b/sysutils/torsmo/files/patch-freebsd.c
@@ -1,5 +1,5 @@
--- freebsd.c.orig Wed Aug 25 20:24:24 2004
-+++ freebsd.c Wed Dec 29 22:11:31 2004
++++ freebsd.c Sun Jan 2 08:49:26 2005
@@ -4,14 +4,12 @@
#include <stdio.h>
#include <stdlib.h>
@@ -77,6 +77,15 @@
if((sysctl(mib, 2, &boottime, &size, NULL, 0) != -1) && (boottime.tv_sec != 0)) {
time(&now);
+@@ -292,7 +329,7 @@
+ }
+
+ double get_acpi_temperature(int fd) {
+- double temp;
++ int temp;
+
+ if (GETSYSCTL("hw.acpi.thermal.tz0.temperature", temp)) {
+ (void)fprintf(stderr, "Cannot read sysctl \"hw.acpi.thermal.tz0.temperature\"\n");
@@ -344,4 +381,38 @@
char* get_acpi_fan() {