aboutsummaryrefslogtreecommitdiff
path: root/sysutils/toshctl
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-04 00:37:43 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-04 00:37:43 +0000
commit85ce16562ba7f3359a4d51d85106eb6607d123de (patch)
tree5aa26319d564b5a184b13bb460d0a662310aa44e /sysutils/toshctl
parent1891fd41b9c68300478bece05f50d583a543f69d (diff)
downloadports-85ce16562ba7f3359a4d51d85106eb6607d123de.tar.gz
ports-85ce16562ba7f3359a4d51d85106eb6607d123de.zip
Notes
Diffstat (limited to 'sysutils/toshctl')
-rw-r--r--sysutils/toshctl/Makefile19
-rw-r--r--sysutils/toshctl/distinfo1
-rw-r--r--sysutils/toshctl/files/patch-Makefile11
-rw-r--r--sysutils/toshctl/files/patch-tosh_bios.cpp11
-rw-r--r--sysutils/toshctl/files/patch-tosh_hci.cpp20
-rw-r--r--sysutils/toshctl/files/patch-tosh_hci.h14
-rw-r--r--sysutils/toshctl/pkg-descr8
-rw-r--r--sysutils/toshctl/pkg-plist1
8 files changed, 85 insertions, 0 deletions
diff --git a/sysutils/toshctl/Makefile b/sysutils/toshctl/Makefile
new file mode 100644
index 000000000000..d3172990e546
--- /dev/null
+++ b/sysutils/toshctl/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: toshctl
+# Date created: 22 September 2003
+# Whom: XXX
+#
+# $FreeBSD$
+#
+
+PORTNAME= toshctl
+PORTVERSION= 0.0.0p2
+CATEGORIES= sysutils
+MASTER_SITES= http://freebie.miraclenet.co.th/notebook/toshctl/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= carl@servicefactory.se
+COMMENT= A command-line tool to access parts of the Toshiba hardware interface
+
+WRKSRC= ${WRKDIR}/toshctl
+
+.include <bsd.port.mk>
diff --git a/sysutils/toshctl/distinfo b/sysutils/toshctl/distinfo
new file mode 100644
index 000000000000..e3dbdac96f58
--- /dev/null
+++ b/sysutils/toshctl/distinfo
@@ -0,0 +1 @@
+MD5 (toshctl-0.0.0p2.tgz) = 619f3c42160ee7a4cbd01126c710cbd4
diff --git a/sysutils/toshctl/files/patch-Makefile b/sysutils/toshctl/files/patch-Makefile
new file mode 100644
index 000000000000..a19075bfdc12
--- /dev/null
+++ b/sysutils/toshctl/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig Thu Mar 20 02:19:07 2003
++++ Makefile Fri Aug 22 16:11:21 2003
+@@ -34,5 +34,8 @@
+ $(PROGRAM):$(OBJS)
+ $(CC) -o $(PROGRAM) $(LDFLAGS) $(OBJS)
+
++install:
++ ${INSTALL} ${PROGRAM} ${LOCALBASE}/bin
++
+ clean:
+ rm -f *.o *.bak $(PROGRAM)
diff --git a/sysutils/toshctl/files/patch-tosh_bios.cpp b/sysutils/toshctl/files/patch-tosh_bios.cpp
new file mode 100644
index 000000000000..05de81b20f3d
--- /dev/null
+++ b/sysutils/toshctl/files/patch-tosh_bios.cpp
@@ -0,0 +1,11 @@
+--- tosh_bios.cpp.orig Fri Aug 22 16:03:37 2003
++++ tosh_bios.cpp Fri Aug 22 16:03:50 2003
+@@ -130,7 +130,7 @@
+ bios_time.tm_mday = str2int(&mem[0xFFFF8],2);
+ time_t t = mktime(&bios_time);
+
+- snprintf(buf,32,"%ld",t);
++ snprintf(buf,32,"%d",t);
+ s = "20";s += mem[0xFFFFB];s += mem[0xFFFFC];s += '-';
+ s += mem[0xFFFF5]; s+= mem[0xFFFF6];s+= '-';
+ s += mem[0xFFFF8]; s+= mem[0xFFFF9];
diff --git a/sysutils/toshctl/files/patch-tosh_hci.cpp b/sysutils/toshctl/files/patch-tosh_hci.cpp
new file mode 100644
index 000000000000..5ad72bf70e92
--- /dev/null
+++ b/sysutils/toshctl/files/patch-tosh_hci.cpp
@@ -0,0 +1,20 @@
+--- tosh_hci.cpp.orig Wed Apr 23 17:16:42 2003
++++ tosh_hci.cpp Fri Oct 3 17:35:48 2003
+@@ -132,7 +132,7 @@
+
+ unsigned
+ CToshHCIVar::hci_read(HCI_FUNCTION fn,unsigned ecx,unsigned edx)
+- throw (runtime_error)
++ throw (std::runtime_error)
+ {
+ unsigned result;
+
+@@ -144,7 +144,7 @@
+
+ void
+ CToshHCIVar::hci_write(HCI_FUNCTION fn,unsigned ecx,unsigned edx)
+- throw (runtime_error)
++ throw (std::runtime_error)
+ {
+ unsigned result;
+
diff --git a/sysutils/toshctl/files/patch-tosh_hci.h b/sysutils/toshctl/files/patch-tosh_hci.h
new file mode 100644
index 000000000000..1a0020e5deba
--- /dev/null
+++ b/sysutils/toshctl/files/patch-tosh_hci.h
@@ -0,0 +1,14 @@
+--- tosh_hci.h.orig Wed Mar 19 16:53:24 2003
++++ tosh_hci.h Fri Oct 3 17:34:15 2003
+@@ -80,9 +80,9 @@
+ unsigned ecx,unsigned edx) throw();
+
+ static unsigned hci_read(HCI_FUNCTION fn,unsigned ecx,unsigned edx)
+- throw(runtime_error);
++ throw(std::runtime_error);
+ static void hci_write(HCI_FUNCTION fn,unsigned ecx,unsigned edx)
+- throw(runtime_error);
++ throw(std::runtime_error);
+ protected:
+ typedef std::pair<unsigned,std::string> VAR_INFO;
+
diff --git a/sysutils/toshctl/pkg-descr b/sysutils/toshctl/pkg-descr
new file mode 100644
index 000000000000..19e44b07cddc
--- /dev/null
+++ b/sysutils/toshctl/pkg-descr
@@ -0,0 +1,8 @@
+Toshctl is a command-line tool to allow access to much of the
+Toshiba hardware interface developed by Jonathan Buzzard and
+Linux toshset by Charles D. Schwieters.
+
+It can do things linke set the LCD brightness, set CPU speed and set
+fan speed.
+
+WWW: http://freebie.miraclenet.co.th/notebook/toshctl/
diff --git a/sysutils/toshctl/pkg-plist b/sysutils/toshctl/pkg-plist
new file mode 100644
index 000000000000..ffaa69bf7797
--- /dev/null
+++ b/sysutils/toshctl/pkg-plist
@@ -0,0 +1 @@
+bin/toshctl