aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tracker/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2018-09-30 11:58:29 +0000
committerKoop Mast <kwm@FreeBSD.org>2018-09-30 11:58:29 +0000
commit951c1f5d1c7354f058f5919d858dbb0c174dc73e (patch)
tree6146e775343aaf339921799078894a48fef9aa15 /sysutils/tracker/Makefile
parentc9b47f0427d70ba42c2d53271f8b64b8e8096825 (diff)
downloadports-951c1f5d1c7354f058f5919d858dbb0c174dc73e.tar.gz
ports-951c1f5d1c7354f058f5919d858dbb0c174dc73e.zip
Notes
Diffstat (limited to 'sysutils/tracker/Makefile')
-rw-r--r--sysutils/tracker/Makefile103
1 files changed, 20 insertions, 83 deletions
diff --git a/sysutils/tracker/Makefile b/sysutils/tracker/Makefile
index b41739908eb7..d9971788cbc5 100644
--- a/sysutils/tracker/Makefile
+++ b/sysutils/tracker/Makefile
@@ -2,109 +2,46 @@
# $FreeBSD$
PORTNAME= tracker
-PORTVERSION= 1.6.1
-PORTREVISION= 14
+PORTVERSION= 2.0.4
CATEGORIES= sysutils gnome
MASTER_SITES= GNOME
MAINTAINER= gnome@FreeBSD.org
COMMENT= Object database, tag/metadata database, search tool and indexer
-LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
- libgmime-2.6.so:mail/gmime26 \
- libhal.so:sysutils/hal \
- libraptor.so:textproc/raptor \
- libuuid.so:misc/e2fsprogs-libuuid \
- libicutu.so:devel/icu \
- libmediaart-2.0.so:multimedia/libmediaart \
- librest-0.7.so:devel/librest
-RUN_DEPENDS= xdg-desktop-icon:devel/xdg-utils \
- o3totxt:converters/o3read \
- pdftotext:graphics/poppler-utils \
- w3m:www/w3m
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING.LGPL
+
+BUILD_DEPENDS= valac:lang/vala
+LIB_DEPENDS= libuuid.so:misc/e2fsprogs-libuuid \
+ libsoup-2.4.so:devel/libsoup \
+ libjson-glib-1.0.so:devel/json-glib \
+ libicutu.so:devel/icu
PORTSCOUT= limitw:1,even
-USES= compiler:c++11-lib desktop-file-utils gettext gmake gnome \
- libarchive libtool pathfix pkgconfig python:run shebangfix \
- sqlite tar:xz
-USE_GNOME= gtk30 intltool introspection:build libxslt:build
+USES= compiler:c++11-lib gettext gmake gnome libtool localbase \
+ pathfix pkgconfig python:3.4+,build shebangfix sqlite tar:xz
+USE_GNOME= glib20 intltool introspection:build libxml2
USE_LDCONFIG= yes
-USE_GSTREAMER1= yes
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --with-session-bus-services-dir=${LOCALBASE}/share/dbus-1/services \
- --disable-libiptcdata --enable-miner-fs \
- --disable-meegotouch \
- --enable-icu-charset-detection \
+CONFIGURE_ARGS= --disable-static \
--disable-network-manager \
- --disable-enca \
- --enable-tracker-preferences \
- --disable-libosinfo \
- --enable-generic-media-extractor=gstreamer
-# disable evolution miner until tracker fixes the dep
-CONFIGURE_ARGS+= --disable-miner-evolution
-CONFIGURE_ENV+= enable_miner_evolution=no \
- DATADIRNAME=share
+ --with-bash-completion-dir=no
INSTALL_TARGET= install-strip
GLIB_SCHEMAS= org.freedesktop.Tracker.DB.gschema.xml \
- org.freedesktop.Tracker.Extract.gschema.xml \
org.freedesktop.Tracker.FTS.gschema.xml \
- org.freedesktop.Tracker.Miner.Files.gschema.xml \
- org.freedesktop.Tracker.Needle.gschema.xml \
org.freedesktop.Tracker.Store.gschema.xml \
- org.freedesktop.Tracker.Writeback.gschema.xml \
org.freedesktop.Tracker.enums.xml \
org.freedesktop.Tracker.gschema.xml
-SHEBANG_FILES= tests/tracker-writeback/01-writeback.py
-
-PLIST_SUB= TRACKER_VER="1.0" LIBVER=601
-
-OPTIONS_DEFINE= AUDIO_MINERS DOCUMENT_MINERS GRAPHIC_MINERS \
- WEB_MINERS
-OPTIONS_DEFAULT= AUDIO_MINERS DOCUMENT_MINERS GRAPHIC_MINERS
-OPTIONS_SUB=yes
-WEB_MINERS_DESC= Support for Firefox, Thunderbird
-# and Evolution
-AUDIO_MINERS_DESC= Support for audio formats
-DOCUMENT_MINERS_DESC= Support for some sort of documents (pdf, ps, xps, office)
-GRAPHIC_MINERS_DESC= Support for some graphic formats (gif, png, tiff)
-NAUTILUS_DESC= Support for nautilus tagging
-
-WEB_MINERS_CONFIGURE_ENABLE= miner-firefox miner-thunderbird
-# miner-evolution
-WEB_MINERS_BUILD_DEPENDS= firefox>=0:www/firefox \
- thunderbird>=0:mail/thunderbird
-WEB_MINERS_RUN_DEPENDS= firefox>=0:www/firefox \
- thunderbird>=0:mail/thunderbird
-
-AUDIO_MINERS_CONFIGURE_ENABLE= libvorbis libflac taglib mp3 libcue playlist
-AUDIO_MINERS_LIB_DEPENDS= libtotem-plparser.so:multimedia/totem-pl-parser \
- libFLAC.so:audio/flac \
- libvorbis.so:audio/libvorbis \
- libcue.so:textproc/libcue \
- libogg.so:audio/libogg \
- libtag.so:audio/taglib
-
-DOCUMENT_MINERS_CONFIGURE_ENABLE= libgxps poppler libxml2 libgsf \
- abiword dvi ps exempi text
-DOCUMENT_MINERS_LIB_DEPENDS= libpoppler-glib.so:graphics/poppler-glib \
- libgxps.so:graphics/libgxps \
- libgsf-1.so:devel/libgsf \
- libexempi.so:textproc/exempi \
- libwv.so:textproc/wv
+SHEBANG_FILES= utils/g-ir-merge/g-ir-merge
-GRAPHIC_MINERS_CONFIGURE_ENABLE= libexif libgif libjpeg libtiff icon libpng
-GRAPHIC_MINERS_LIB_DEPENDS= libexif.so:graphics/libexif \
- libgif.so:graphics/giflib \
- libpng.so:graphics/png \
- libtiff.so:graphics/tiff
+PLIST_SUB= LIBVER=0.4.0
-# cirular dependancy tracker -> nautilus -> tracker
-CONFIGURE_ARGS= --disable-nautilus-extension
-#NAUTILUS_CONFIGURE_ENABLE= nautilus-extension
-#NAUTILUS_USE= GNOME=nautilus3
+# force regen of this file, so the correct tracker version is embedded
+# https://bugzilla.gnome.org/show_bug.cgi?id=792691
+post-patch:
+ @${RM} ${WRKSRC}/src/libtracker-sparql/tracker-sparql.vapi
.include <bsd.port.mk>