aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tree
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2008-09-26 15:44:01 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2008-09-26 15:44:01 +0000
commit8181033ff53c0ce42ab56386b0b62adaafcfbd48 (patch)
tree329461ebf39c68b2f057f80eceebde0026ff4e85 /sysutils/tree
parent779625ae836eb349f5cab0ea74f0142876ff8d17 (diff)
downloadports-8181033ff53c0ce42ab56386b0b62adaafcfbd48.tar.gz
ports-8181033ff53c0ce42ab56386b0b62adaafcfbd48.zip
Notes
Diffstat (limited to 'sysutils/tree')
-rw-r--r--sysutils/tree/Makefile14
-rw-r--r--sysutils/tree/distinfo6
-rw-r--r--sysutils/tree/files/patch-Makefile48
-rw-r--r--sysutils/tree/files/patch-tree.c65
4 files changed, 60 insertions, 73 deletions
diff --git a/sysutils/tree/Makefile b/sysutils/tree/Makefile
index 42c0628dc4a2..a2cc1a67ce40 100644
--- a/sysutils/tree/Makefile
+++ b/sysutils/tree/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= tree
-PORTVERSION= 1.5.1.1
-PORTREVISION= 1
+PORTVERSION= 1.5.2.1
CATEGORIES= sysutils
-MASTER_SITES= ftp://mama.indstate.edu/linux/tree/ CENKES
+MASTER_SITES= ftp://mama.indstate.edu/linux/tree/ \
+ CENKES
EXTRACT_SUFX= .tgz
MAINTAINER= gb@isis.u-strasbg.fr
@@ -20,4 +20,12 @@ MAKE_ENV+= MKDIR="${MKDIR}"
MAN1= tree.1
PLIST_FILES= bin/tree
+PORTDOCS= CHANGES LICENSE README
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>
diff --git a/sysutils/tree/distinfo b/sysutils/tree/distinfo
index c79a75200ae6..4424bc669a41 100644
--- a/sysutils/tree/distinfo
+++ b/sysutils/tree/distinfo
@@ -1,3 +1,3 @@
-MD5 (tree-1.5.1.1.tgz) = f8fc70a9260b50bf8b4613e9d5f5e589
-SHA256 (tree-1.5.1.1.tgz) = de16db952531f76f4e83f10e5eeb3f810b4bf984d4b11aa3378e71dfa1d13aec
-SIZE (tree-1.5.1.1.tgz) = 30792
+MD5 (tree-1.5.2.1.tgz) = 73d5fa220dfef1ee9c1876c3966f1c18
+SHA256 (tree-1.5.2.1.tgz) = 9189a74ee6f740e48884e3eedf9b55013a8f4a46c1f448ce79bdf39ed9a708f4
+SIZE (tree-1.5.2.1.tgz) = 33584
diff --git a/sysutils/tree/files/patch-Makefile b/sysutils/tree/files/patch-Makefile
index 7d119890d267..b0b7f8cc227a 100644
--- a/sysutils/tree/files/patch-Makefile
+++ b/sysutils/tree/files/patch-Makefile
@@ -1,37 +1,41 @@
---- Makefile.orig Mon Jun 11 09:22:47 2007
-+++ Makefile Tue Jul 31 21:41:14 2007
-@@ -6,14 +6,9 @@
+--- Makefile.orig 2008-09-22 15:51:25.000000000 +0800
++++ Makefile 2008-09-22 15:56:58.000000000 +0800
+@@ -6,27 +6,27 @@
# warranties, including, without limitation, the implied warranties
# of merchant-ability and fitness for a particular purpose.
--CC=gcc
--#CFLAGS=-ggdb -Wall -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
--CFLAGS=-O2 -Wall -fomit-frame-pointer -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
--LDFLAGS=-s
--
- # Uncomment for FreeBSD:
- #CC=gcc
--#CFLAGS=-O2 -Wall -fomit-frame-pointer
-+CFLAGS=-O2 -Wall -fomit-frame-pointer
- #LDFLAGS=-s
-
- # Uncomment for Cygwin:
-@@ -38,12 +33,12 @@
- #CFLAGS=-02 -Wall -fomit-frame-pointer -Zomf -Zsmall-conv
- #LDFLAGS=-s -Zomf -Zsmall-conv
-
-prefix = /usr
+prefix = ${PREFIX}
- VERSION=1.5.1.1
+ CC=gcc
+
+ VERSION=1.5.2.1
TREE_DEST=tree
BINDIR=${prefix}/bin
-MAN=tree.1
+MAN=man/tree.1
MANDIR=${prefix}/man/man1
- all: tree
-@@ -58,13 +53,11 @@
+ # Uncomment options below for your particular OS:
+
+ # Linux defaults:
+ #CFLAGS=-ggdb -Wall -DLINUX -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+-CFLAGS=-O2 -Wall -fomit-frame-pointer -DLINUX -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+-LDFLAGS=-s
++#CFLAGS=-O2 -Wall -fomit-frame-pointer -DLINUX -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
++#LDFLAGS=-s
+
+ # Uncomment for FreeBSD:
+-#CFLAGS=-O2 -Wall -fomit-frame-pointer
+-#LDFLAGS=-s
+-#XOBJS=strverscmp.o
++CFLAGS?=-O2 -Wall -fomit-frame-pointer
++LDFLAGS?=-s
++XOBJS=strverscmp.o
+
+ # Uncomment for Cygwin:
+ #CFLAGS=-O2 -Wall -fomit-frame-pointer -DCYGWIN
+@@ -68,13 +68,11 @@
if [ -f tree.o ]; then rm *.o; fi
rm -f *~
diff --git a/sysutils/tree/files/patch-tree.c b/sysutils/tree/files/patch-tree.c
index e25dd2537642..5a8681f4b78e 100644
--- a/sysutils/tree/files/patch-tree.c
+++ b/sysutils/tree/files/patch-tree.c
@@ -1,62 +1,37 @@
---- tree.c.orig Tue Jan 9 23:07:16 2007
-+++ tree.c Thu Jan 25 18:58:28 2007
-@@ -17,7 +17,6 @@
- * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
- */
-
--#include <features.h>
- #include <stdlib.h>
- #include <stdio.h>
- #include <time.h>
-@@ -148,7 +147,7 @@
- int findino(ino_t, dev_t);
- void *xmalloc(size_t), *xrealloc(void *, size_t);
- void listdir(char *, int *, int *, u_long, dev_t), usage(int);
--void parse_dir_colors(), printit(unsigned char *), free_dir(struct _info **), indent();
-+void parse_dir_colors(), printit(char *), free_dir(struct _info **), indent();
- void saveino(ino_t, dev_t);
- char **split(char *, char *, int *);
- char *gidtoname(int), *uidtoname(int), *do_date(time_t);
-@@ -178,12 +177,6 @@
- char *sLevel, *curdir, *outfilename = NULL;
- FILE *outfile;
- int *dirs, maxdirs;
--
--#ifdef CYGWIN
--extern int MB_CUR_MAX;
--#else
--extern size_t MB_CUR_MAX;
--#endif
-
- int main(int argc, char **argv)
- {
-@@ -622,7 +615,7 @@
+--- tree.c.orig 2008-08-28 03:05:43.000000000 +0800
++++ tree.c 2008-09-22 21:37:05.000000000 +0800
+@@ -663,7 +663,7 @@
#ifdef __USE_FILE_OFFSET64
if (inodeflag) sprintf(path," %7lld",(*dir)->inode);
#else
- if (inodeflag) sprintf(path," %7ld",(*dir)->inode);
-+ if (inodeflag) sprintf(path," %7i",(*dir)->inode);
++ if (inodeflag) sprintf(path," %7u",(*dir)->inode);
#endif
if (devflag) sprintf(path+strlen(path), " %3d", (int)(*dir)->dev);
#ifdef __EMX__
-@@ -1041,8 +1034,10 @@
+@@ -1087,8 +1087,10 @@
} else {
if (Hflag) fprintf(outfile,"<br>\t\t\t\t ");
for(i=0;dirs[i];i++) {
+ if( dirs[i] <= 0 )
-+ break;
++ break;
fprintf(outfile,"%s ",
- dirs[i+1] ? (dirs[i]==1 ? linedraw->vert : (Hflag? "&nbsp;&nbsp;&nbsp;" : " ") )
-+ dirs[i+1] > 0 ? (dirs[i]==1 ? linedraw->vert : (Hflag? "&nbsp;&nbsp;&nbsp;" : " ") )
++ dirs[i+1] > 0 ? (dirs[i]==1 ? linedraw->vert : (Hflag? "&nbsp;&nbsp;&nbsp;" : " ") )
: (dirs[i]==1 ? linedraw->vert_left:linedraw->corner));
}
}
-@@ -1180,7 +1175,7 @@
- return t->name;
- }
-
--void printit(unsigned char *s)
-+void printit(char *s)
- {
- int c;
+@@ -1276,7 +1276,12 @@
+ char *unit="BKMGTPEZY";
+ int idx;
+- if (!hflag) sprintf(buf, sizeof(off_t) == sizeof(long long)? " %11lld" : " %9ld", size);
++ if (!hflag) {
++ if (sizeof(off_t) == sizeof(__int64_t))
++ sprintf(buf, sizeof(long) == sizeof(long long) ? " %11ld" : " %11lld", size);
++ else
++ sprintf(buf, sizeof(long) == sizeof(long long) ? " %9ld" : " %9lld", size);
++ }
+ else {
+ for (idx=size<1024?0:1; size >= (1024*1024); idx++,size>>=10);
+ if (!idx) sprintf(buf, " %4d", (int)size);