aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tree
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-09 15:17:56 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-09 15:17:56 +0000
commit9c53b08e81e75610edd9b70b5740d6251bfca331 (patch)
tree856f5ca2f6e179f285d088b13d4f3e597de9eb62 /sysutils/tree
parentc5135cdd3e4cd5b9937bd8f0c9af175ec706d70b (diff)
downloadports-9c53b08e81e75610edd9b70b5740d6251bfca331.tar.gz
ports-9c53b08e81e75610edd9b70b5740d6251bfca331.zip
Notes
Diffstat (limited to 'sysutils/tree')
-rw-r--r--sysutils/tree/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/sysutils/tree/Makefile b/sysutils/tree/Makefile
index 12db64609e82..1ad4488d6a65 100644
--- a/sysutils/tree/Makefile
+++ b/sysutils/tree/Makefile
@@ -14,20 +14,18 @@ COMMENT= Display a tree-view of directories with optional color or HTML output
LICENSE= GPLv2
MAKE_ENV+= MKDIR="${MKDIR}"
-USE_GMAKE= yes
+USES= gmake
-MAN1= tree.1
-PLIST_FILES= bin/tree
+PLIST_FILES= bin/tree \
+ man/man1/tree.1.gz
PORTDOCS= CHANGES README
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tree ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/*.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
-.endif
.include <bsd.port.mk>