aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ts/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-04-03 12:03:25 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-04-03 12:03:25 +0000
commit4f5dc96cd278f8124d0181695a1e7e5431be75a2 (patch)
treeb7c98fec1fdb6e113407deb1b51c94d9f4779cd2 /sysutils/ts/Makefile
parent2d22371adc2a7e226eb2654ce382bd5d02f6ce53 (diff)
Notes
Diffstat (limited to 'sysutils/ts/Makefile')
-rw-r--r--sysutils/ts/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/sysutils/ts/Makefile b/sysutils/ts/Makefile
new file mode 100644
index 000000000000..ea0987ee86bb
--- /dev/null
+++ b/sysutils/ts/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ts
+# Date created: 3 April 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ts
+PORTVERSION= 0.3
+CATEGORIES= sysutils
+MASTER_SITES= http://vicerveza.homeunix.net/~viric/soft/ts/ CENKES
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Serial task spooler
+
+WRKSRC= ${WRKDIR}/ts
+ALL_TARGET= ts
+PLIST_BIN= bin/${PORTNAME}
+PORTDOCS= OBJECTIVES PROTOCOL README TODO TRICKS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$^|$${.ALLSRC}|' ${WRKSRC}/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}/
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>