aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ts
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-04-03 12:03:25 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-04-03 12:03:25 +0000
commit4f5dc96cd278f8124d0181695a1e7e5431be75a2 (patch)
treeb7c98fec1fdb6e113407deb1b51c94d9f4779cd2 /sysutils/ts
parent2d22371adc2a7e226eb2654ce382bd5d02f6ce53 (diff)
Notes
Diffstat (limited to 'sysutils/ts')
-rw-r--r--sysutils/ts/Makefile31
-rw-r--r--sysutils/ts/distinfo3
-rw-r--r--sysutils/ts/files/patch-execute.c26
-rw-r--r--sysutils/ts/pkg-descr10
4 files changed, 70 insertions, 0 deletions
diff --git a/sysutils/ts/Makefile b/sysutils/ts/Makefile
new file mode 100644
index 000000000000..ea0987ee86bb
--- /dev/null
+++ b/sysutils/ts/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ts
+# Date created: 3 April 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ts
+PORTVERSION= 0.3
+CATEGORIES= sysutils
+MASTER_SITES= http://vicerveza.homeunix.net/~viric/soft/ts/ CENKES
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Serial task spooler
+
+WRKSRC= ${WRKDIR}/ts
+ALL_TARGET= ts
+PLIST_BIN= bin/${PORTNAME}
+PORTDOCS= OBJECTIVES PROTOCOL README TODO TRICKS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$^|$${.ALLSRC}|' ${WRKSRC}/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}/
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/ts/distinfo b/sysutils/ts/distinfo
new file mode 100644
index 000000000000..0eb95069c5c6
--- /dev/null
+++ b/sysutils/ts/distinfo
@@ -0,0 +1,3 @@
+MD5 (ts-0.3.tar.gz) = fc7d79bf36ed06ff2046aecfcfd9de0b
+SHA256 (ts-0.3.tar.gz) = 852b0a9cbacddd7ac0ed7ba7c1f3d7a44b6eb8775d59256ba88c42e8bd20006d
+SIZE (ts-0.3.tar.gz) = 31545
diff --git a/sysutils/ts/files/patch-execute.c b/sysutils/ts/files/patch-execute.c
new file mode 100644
index 000000000000..29920e427340
--- /dev/null
+++ b/sysutils/ts/files/patch-execute.c
@@ -0,0 +1,26 @@
+--- ./execute.c.orig Tue Apr 3 15:07:38 2007
++++ ./execute.c Tue Apr 3 15:07:48 2007
+@@ -16,7 +16,6 @@
+ #include "msg.h"
+ #include "main.h"
+
+-static void program_signal();
+
+ /* Returns errorlevel */
+ static int run_parent(int fd_read_filename, int pid)
+@@ -204,15 +203,3 @@
+ {
+ }
+
+-static void program_signal()
+-{
+- struct sigaction act;
+-
+- act.sa_handler = sigchld_handler;
+- /* Reset the mask */
+- memset(&act.sa_mask,0,sizeof(act.sa_mask));
+- act.sa_flags = SA_NOCLDSTOP;
+- act.sa_restorer = NULL;
+-
+- sigaction(SIGCHLD, &act, NULL);
+-}
diff --git a/sysutils/ts/pkg-descr b/sysutils/ts/pkg-descr
new file mode 100644
index 000000000000..862345918b33
--- /dev/null
+++ b/sysutils/ts/pkg-descr
@@ -0,0 +1,10 @@
+task spooler is a Unix batch system where the tasks spooled run one
+after the other. Each user in each system has his own job queue. The
+tasks are run in the correct context (that of enqueue) from any
+shell/process, and its output/results can be easily watched. It is
+very useful when you know that your commands depend on a lot of RAM,
+a lot of disk use, give a lot of output, or for whatever reason it's
+better not to run them at the same time.
+
+WWW: http://vicerveza.homeunix.net/~viric/soft/ts/
+Author: Lluis Batlle i Rossell <viric_at_vicerveza_dot_homeunix_dot_net>