aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ttyload
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2011-04-05 16:53:15 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2011-04-05 16:53:15 +0000
commit42c02308dd2cb45419b5f316a816b005309f6e06 (patch)
tree10566176577f5473a07b81e43f2024207f659970 /sysutils/ttyload
parent3d2029c2779c1878b130f6b696e98897316fb526 (diff)
downloadports-42c02308dd2cb45419b5f316a816b005309f6e06.tar.gz
ports-42c02308dd2cb45419b5f316a816b005309f6e06.zip
Notes
Diffstat (limited to 'sysutils/ttyload')
-rw-r--r--sysutils/ttyload/Makefile3
-rw-r--r--sysutils/ttyload/distinfo4
-rw-r--r--sysutils/ttyload/files/patch-Makefile11
3 files changed, 10 insertions, 8 deletions
diff --git a/sysutils/ttyload/Makefile b/sysutils/ttyload/Makefile
index 1c53a9c9d1c5..e4d0a2cca11f 100644
--- a/sysutils/ttyload/Makefile
+++ b/sysutils/ttyload/Makefile
@@ -6,7 +6,7 @@
# $FreeBSD$
PORTNAME= ttyload
-PORTVERSION= 0.5
+PORTVERSION= 0.5.2
CATEGORIES= sysutils
MASTER_SITES= http://www.daveltd.com/src/util/ttyload/ \
http://mirror.mcx2.org/
@@ -16,6 +16,7 @@ COMMENT= Give a color-coded graph of load averages over time
ALL_TARGET= default
+USE_BZIP2= yes
PLIST_FILES= bin/ttyload
PORTDOCS= *
diff --git a/sysutils/ttyload/distinfo b/sysutils/ttyload/distinfo
index a7d050f7f8d7..c9b8b5091f4a 100644
--- a/sysutils/ttyload/distinfo
+++ b/sysutils/ttyload/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ttyload-0.5.tar.gz) = d068b61155b81e6982f6886a67f51bd4357eed84853afc5367e43887cc7f5f53
-SIZE (ttyload-0.5.tar.gz) = 14681
+SHA256 (ttyload-0.5.2.tar.bz2) = 4783f6f44a59e554b0f31ab7940b9112123e8eef71b85d2cbad5d4275ba8dd44
+SIZE (ttyload-0.5.2.tar.bz2) = 14649
diff --git a/sysutils/ttyload/files/patch-Makefile b/sysutils/ttyload/files/patch-Makefile
index 95c0d6fb0ab0..896ec3a8833c 100644
--- a/sysutils/ttyload/files/patch-Makefile
+++ b/sysutils/ttyload/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2005-09-09 23:52:11.000000000 +0400
-+++ Makefile 2008-10-11 18:04:07.000000000 +0400
+--- ./Makefile.orig 2011-02-14 08:49:25.000000000 +0100
++++ ./Makefile 2011-04-05 18:39:35.000000000 +0200
@@ -4,21 +4,18 @@
# change this if you want to use 'make install' and have it go
@@ -18,7 +18,7 @@
${NULL}
-# this is what I use most places...
--CC=gcc -pedantic -Wall
+-CC=gcc -pedantic -Wall -Werror
-
# for the things in the sub-directory:
INCLUDES = -I$${PWD:-.} \
@@ -32,7 +32,7 @@
VERSION = -DVERSION='"'`cat Version`'"'
-CFLAGS = $(INCLUDES) $(OTHER_FLAGS) $(DEBUG) $(VERSION)
-+CFLAGS+= $(INCLUDES) $(OTHER_FLAGS) $(DEBUG) $(VERSION) -pedantic -Wall
++CFLAGS = $(INCLUDES) $(OTHER_FLAGS) $(DEBUG) $(VERSION) -pedantic -Wall
# most people won't want loader, so don't bother building it:
# PROGRAMS = archbuild loader
@@ -51,7 +51,7 @@
ttyload.c: ttyload.h Version
touch ttyload.c
-@@ -82,7 +79,10 @@
+@@ -82,7 +79,11 @@
# install, gently. not much to it:
install: $(PROGRAMS)
@@ -60,6 +60,7 @@
+
+deinstall:
+ rm -f ${PREFIX}/bin/ttyload
++
# because different systems' make have different behaviors on how they
# deal with building stuff in subdirectories, and because I don't feel