aboutsummaryrefslogtreecommitdiff
path: root/sysutils/u-boot-wandboard
diff options
context:
space:
mode:
authorIan Lepore <ian@FreeBSD.org>2015-01-02 02:11:32 +0000
committerIan Lepore <ian@FreeBSD.org>2015-01-02 02:11:32 +0000
commit2a4c23d70ff31cfff144f10124044fea6f732e79 (patch)
tree9c8201a68a942d5a7264da430f3f8a822040cb4c /sysutils/u-boot-wandboard
parentdc5aac57c2b79cb7a6c1127b4677a63e2b1f65fd (diff)
downloadports-2a4c23d70ff31cfff144f10124044fea6f732e79.tar.gz
ports-2a4c23d70ff31cfff144f10124044fea6f732e79.zip
Notes
Diffstat (limited to 'sysutils/u-boot-wandboard')
-rw-r--r--sysutils/u-boot-wandboard/Makefile3
-rw-r--r--sysutils/u-boot-wandboard/files/patch-board_technexion_edm__cf__imx6_edm__cf__imx6.c4
-rw-r--r--sysutils/u-boot-wandboard/files/patch-common_cmd__elf.c31
-rw-r--r--sysutils/u-boot-wandboard/files/patch-include_configs_edm__cf__imx6.h46
4 files changed, 57 insertions, 27 deletions
diff --git a/sysutils/u-boot-wandboard/Makefile b/sysutils/u-boot-wandboard/Makefile
index 787f5fca2b88..e34b7157da05 100644
--- a/sysutils/u-boot-wandboard/Makefile
+++ b/sysutils/u-boot-wandboard/Makefile
@@ -2,6 +2,7 @@
PORTNAME= u-boot
PORTVERSION= 2013.10
+PORTREVISION= 1
CATEGORIES= sysutils
PKGNAMESUFFIX= -wandboard
DISTNAME= u-boot-${PORTVERSION}-technexion-edm
@@ -30,7 +31,7 @@ PLIST_FILES= ${U_BOOT_DIR}/u-boot.imx \
MAKE_ARGS+= ARCH=arm \
CROSS_COMPILE=arm-none-eabi- \
- HOSTCC=clang
+ HOSTCC=cc
do-configure:
cd ${WRKSRC}; ${GMAKE} ${MAKE_ARGS} edm_cf_imx6_config
diff --git a/sysutils/u-boot-wandboard/files/patch-board_technexion_edm__cf__imx6_edm__cf__imx6.c b/sysutils/u-boot-wandboard/files/patch-board_technexion_edm__cf__imx6_edm__cf__imx6.c
index e1521d7c0eb7..7c813a1a9661 100644
--- a/sysutils/u-boot-wandboard/files/patch-board_technexion_edm__cf__imx6_edm__cf__imx6.c
+++ b/sysutils/u-boot-wandboard/files/patch-board_technexion_edm__cf__imx6_edm__cf__imx6.c
@@ -1,4 +1,4 @@
---- board/technexion/edm_cf_imx6/edm_cf_imx6.c.orig 2014-08-14 14:51:10 UTC
+--- board/technexion/edm_cf_imx6/edm_cf_imx6.c.orig 2014-06-12 07:50:48 UTC
+++ board/technexion/edm_cf_imx6/edm_cf_imx6.c
@@ -63,10 +63,16 @@ enum boot_device get_boot_device(void);
@@ -43,7 +43,7 @@
+ imxname = "imx6dl";
+ break;
+ }
-+ setenv("imxname", imxname);
++ setenv("soc", imxname);
+
#ifdef CONFIG_CMD_BMODE
add_board_boot_modes(board_boot_modes);
diff --git a/sysutils/u-boot-wandboard/files/patch-common_cmd__elf.c b/sysutils/u-boot-wandboard/files/patch-common_cmd__elf.c
index 4225e5f06374..3bef075d4701 100644
--- a/sysutils/u-boot-wandboard/files/patch-common_cmd__elf.c
+++ b/sysutils/u-boot-wandboard/files/patch-common_cmd__elf.c
@@ -1,10 +1,29 @@
---- common/cmd_elf.c.orig 2014-08-14 14:51:10 UTC
+--- common/cmd_elf.c.orig 2014-06-12 07:50:48 UTC
+++ common/cmd_elf.c
-@@ -46,6 +46,7 @@ unsigned long do_bootelf_exec(ulong (*en
- * pass address parameter as argv[0] (aka command name),
- * and all remaining args
+@@ -35,22 +35,12 @@ unsigned long do_bootelf_exec(ulong (*en
+ unsigned long ret;
+
+ /*
+- * QNX images require the data cache is disabled.
+- * Data cache is already flushed, so just turn it off.
+- */
+- int dcache = dcache_status();
+- if (dcache)
+- dcache_disable();
+-
+- /*
+- * pass address parameter as argv[0] (aka command name),
+- * and all remaining args
++ * FreeBSD wants the caches enabled while ubldr runs, and as of r276397
++ * the kernel can tolerate being entered with internal (but not external
++ * PL310) caches enabled on armv6/7 systems. So don't disable caches
++ * here, just launch the program directly.
*/
-+ cleanup_before_linux();
ret = entry(argc, argv);
+-
+- if (dcache)
+- dcache_enable();
+-
+ return ret;
+ }
- if (dcache)
diff --git a/sysutils/u-boot-wandboard/files/patch-include_configs_edm__cf__imx6.h b/sysutils/u-boot-wandboard/files/patch-include_configs_edm__cf__imx6.h
index 0f1f4bcdc75f..2434fc8ccdc0 100644
--- a/sysutils/u-boot-wandboard/files/patch-include_configs_edm__cf__imx6.h
+++ b/sysutils/u-boot-wandboard/files/patch-include_configs_edm__cf__imx6.h
@@ -1,6 +1,6 @@
---- include/configs/edm_cf_imx6.h.orig 2014-08-14 14:51:10 UTC
+--- include/configs/edm_cf_imx6.h.orig 2014-06-12 07:50:48 UTC
+++ include/configs/edm_cf_imx6.h
-@@ -338,4 +338,54 @@
+@@ -338,4 +338,64 @@
#define CONFIG_CMD_CACHE
#endif
@@ -26,32 +26,42 @@
+/* Create a small(ish) boot environment for FreeBSD. */
+#undef CONFIG_EXTRA_ENV_SETTINGS
+#define CONFIG_EXTRA_ENV_SETTINGS \
-+ "boardname=wandboard\0" \
-+ "bootfile=ubldr\0" \
-+ "fatdev=mmc 0:1\0" \
-+ "loaderdev=disk\0" \
-+ "uenv_file=uEnv.txt\0" \
++ "board=wandboard\0" \
++ "loadaddr=0x11000000\0" \
+ \
-+ "fatboot=" \
-+ "env exists user_fatboot && run user_fatboot; " \
++ "Fatboot=" \
++ "env exists loaderdev || env set loaderdev ${fatdev}; " \
++ "env exists UserFatboot && run UserFatboot; " \
++ "echo Booting from: ${fatdev} ${bootfile}; " \
+ "fatload ${fatdev} ${loadaddr} ${bootfile} && bootelf; " \
+ "\0" \
-+ "netboot=" \
-+ "env exists user_netboot && run user_netboot; " \
++ "Netboot=" \
++ "env exists loaderdev || env set loaderdev net; " \
++ "env exists UserNetboot && run UserNetboot; " \
+ "dhcp ${loadaddr} ${bootfile} && bootelf; " \
+ "\0" \
-+ "preboot=" \
-+ "env exists setfdt && run setfdt; " \
-+ "env exists uenv_import && run uenv_import; " \
-+ "env exists user_preboot && run user_preboot; " \
++ "Preboot=" \
++ "env exists bootfile || bootfile=ubldr; " \
++ "env exists uenv_file || uenv_file=uEnv.txt; " \
++ "env exists SetupFdtfile && run SetupFdtfile; " \
++ "env exists SetupFatdev && run SetupFatdev; " \
++ "env exists SetupUenv && run SetupUenv; " \
++ "env exists UserPreboot && run UserPreboot; " \
+ "\0" \
-+ "setfdt=env set fdt_file ${imxname}-${boardname}.dtb\0" \
-+ "uenv_import=" \
++ "SetupFdtfile=" \
++ "env set fdt_file ${soc}-${board}.dtb" \
++ "\0" \
++ "SetupFatdev=" \
++ "env exists fatdev || fatdev='mmc 0'; " \
++ "\0" \
++ "SetupUenv=" \
+ "fatload ${fatdev} ${loadaddr} ${uenv_file} && " \
+ "env import -t ${loadaddr} ${filesize}; " \
+ "\0"
+
+#undef CONFIG_BOOTCOMMAND
-+#define CONFIG_BOOTCOMMAND "run fatboot"
++#define CONFIG_BOOTCOMMAND "run Fatboot"
++#undef CONFIG_PREBOOT
++#define CONFIG_PREBOOT "run Preboot"
+
#endif /* __CONFIG_H * */