aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ucspi-ipc
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2014-04-17 06:00:54 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2014-04-17 06:00:54 +0000
commit2f1a1d2ed40a43f71e9701066feee44cfeec54d2 (patch)
treeefa1d3d22ec25503b54da3aa822626b5276dfb1c /sysutils/ucspi-ipc
parent6a2cd8e3d111f8006363bc2b290442641ac2081d (diff)
Notes
Diffstat (limited to 'sysutils/ucspi-ipc')
-rw-r--r--sysutils/ucspi-ipc/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/sysutils/ucspi-ipc/Makefile b/sysutils/ucspi-ipc/Makefile
index 62eafe5dc68c..bd76218bded7 100644
--- a/sysutils/ucspi-ipc/Makefile
+++ b/sysutils/ucspi-ipc/Makefile
@@ -17,24 +17,26 @@ DOCS= CHANGES
WRKSRC= ${WRKDIR}/host/superscript.com/net/${DISTNAME}
-NO_STAGE= yes
+.include <bsd.port.options.mk>
+
do-configure:
${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/src/conf-cc
+ ${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/src/conf-ld
do-build:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} package/compile
do-install:
.for x in ipccat ipcconnect ipcdo ipcrun
- ${INSTALL_SCRIPT} ${WRKSRC}/command/${x} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/command/${x} ${STAGEDIR}${PREFIX}/bin
.endfor
.for x in ipcclient ipccommand ipcconnect-io ipcexec ipcexec-config \
ipcexecrules ipcexecrulescheck ipcperl ipcrules ipcrulescheck ipcserver
- ${INSTALL_PROGRAM} ${WRKSRC}/command/${x} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/command/${x} ${STAGEDIR}${PREFIX}/bin
.endfor
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC}/src && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/src && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>