aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ucspi-tcp
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-02-11 17:40:59 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-02-11 17:40:59 +0000
commit325bee28d71e93bbcccff0ee3a2ccd1dc30d31ae (patch)
tree933b0779df343d14205f5342faf09b84d6250ecd /sysutils/ucspi-tcp
parent132e07d309c7ffe4e3c7881312436880266130b1 (diff)
downloadports-325bee28d71e93bbcccff0ee3a2ccd1dc30d31ae.tar.gz
ports-325bee28d71e93bbcccff0ee3a2ccd1dc30d31ae.zip
Notes
Diffstat (limited to 'sysutils/ucspi-tcp')
-rw-r--r--sysutils/ucspi-tcp/Makefile15
-rw-r--r--sysutils/ucspi-tcp/files/patch-ucspi-rss.diff64
2 files changed, 72 insertions, 7 deletions
diff --git a/sysutils/ucspi-tcp/Makefile b/sysutils/ucspi-tcp/Makefile
index 56c8b3244f64..5224a4e18380 100644
--- a/sysutils/ucspi-tcp/Makefile
+++ b/sysutils/ucspi-tcp/Makefile
@@ -7,10 +7,14 @@
PORTNAME= ucspi-tcp
PORTVERSION= 0.88
+PORTREVISION= 1
CATEGORIES= sysutils net
MASTER_SITES= http://cr.yp.to/ucspi-tcp/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
+MAINTAINER= dom@happygiraffe.net
+COMMENT= Command-line tools for building TCP client-server applications
+
.if !defined(WITHOUT_MAN)
MASTER_SITES+= http://smarden.org/pape/djb/manpages/:1
DISTFILES+= ${DISTNAME}-man.tar.gz:1
@@ -20,9 +24,6 @@ MAN1= addcr.1 argv0.1 date@.1 delcr.1 finger@.1 fixcrio.1 \
tcpclient.1 tcprules.1 tcprulescheck.1 tcpserver.1 who@.1
.endif
-MAINTAINER= dom@happygiraffe.net
-COMMENT= Command-line tools for building TCP client-server applications
-
NO_PACKAGE= "Unsure of djb\'s license"
ALL_TARGET= prog install instcheck
@@ -36,11 +37,11 @@ post-configure:
@${ECHO_CMD} ${CC} -s > ${WRKSRC}/conf-ld
do-install:
-.for file in addcr argv0 delcr fixcrio mconnect-io rblsmtpd recordio tcpclient tcprules tcprulescheck tcpserver
- @${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin
+.for file_name in addcr argv0 delcr fixcrio mconnect-io rblsmtpd recordio tcpclient tcprules tcprulescheck tcpserver
+ @${INSTALL_PROGRAM} ${WRKSRC}/${file_name} ${PREFIX}/bin
.endfor
-.for file in date@ finger@ http@ mconnect who@ tcpcat
- @${INSTALL_SCRIPT} ${WRKSRC}/${file} ${PREFIX}/bin
+.for file_name in date@ finger@ http@ mconnect who@ tcpcat
+ @${INSTALL_SCRIPT} ${WRKSRC}/${file_name} ${PREFIX}/bin
.endfor
.if !defined(WITHOUT_MAN)
@cd ${WRKSRC}-man; ${INSTALL_MAN} ${MAN1} ${PREFIX}/man/man1/
diff --git a/sysutils/ucspi-tcp/files/patch-ucspi-rss.diff b/sysutils/ucspi-tcp/files/patch-ucspi-rss.diff
new file mode 100644
index 000000000000..80e1632b6dc0
--- /dev/null
+++ b/sysutils/ucspi-tcp/files/patch-ucspi-rss.diff
@@ -0,0 +1,64 @@
+diff -ruN --exclude conf-* ucspi-tcp-0.88/rblsmtpd.c ucspi-tcp-0.88.fix/rblsmtpd.c
+--- rblsmtpd.c.orig Sat Mar 18 10:18:42 2000
++++ rblsmtpd.c Wed Aug 9 16:42:33 2000
+@@ -60,16 +60,54 @@
+
+ void rbl(char *base)
+ {
++ int i;
++ char *altreply = 0;
+ if (decision) return;
+ if (!stralloc_copy(&tmp,&ip_reverse)) nomem();
++ i = str_chr(base, ':');
++ if (base[i]) {
++ base[i] = 0;
++ altreply = base+i+1;
++ }
+ if (!stralloc_cats(&tmp,base)) nomem();
+- if (dns_txt(&text,&tmp) == -1) {
+- flagmustnotbounce = 1;
+- if (flagfailclosed) {
+- if (!stralloc_copys(&text,"temporary RBL lookup error")) nomem();
+- decision = 2;
++ if (altreply) {
++ if (dns_ip4(&text,&tmp) == -1) {
++ flagmustnotbounce = 1;
++ if (flagfailclosed) {
++ if (!stralloc_copys(&text,"temporary RBL lookup error")) nomem();
++ decision = 2;
++ }
++ return;
++ }
++ if (text.len) {
++ if(!stralloc_copys(&text, "")) nomem();
++ while(*altreply) {
++ char *x;
++ i = str_chr(altreply, '%');
++ if(!stralloc_catb(&text, altreply, i)) nomem();
++ if(altreply[i] &&
++ altreply[i+1]=='I' &&
++ altreply[i+2]=='P' &&
++ altreply[i+3]=='%') {
++ if(!stralloc_catb(&text, ip_env, str_len(ip_env))) nomem();
++ altreply+=i+4;
++ } else if(altreply[i]) {
++ if(!stralloc_cats(&text, "%")) nomem();
++ altreply+=i+1;
++ } else {
++ altreply+=i;
++ }
++ }
++ }
++ } else {
++ if (dns_txt(&text,&tmp) == -1) {
++ flagmustnotbounce = 1;
++ if (flagfailclosed) {
++ if (!stralloc_copys(&text,"temporary RBL lookup error")) nomem();
++ decision = 2;
++ }
++ return;
+ }
+- return;
+ }
+ if (text.len)
+ if (flagrblbounce)