aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ucspi-unix/Makefile
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2003-10-13 14:54:44 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2003-10-13 14:54:44 +0000
commit54bd8459036dbb6b25da31158872b14668273970 (patch)
tree1a787a4cfccae0944aab91e77e822415cfaf3580 /sysutils/ucspi-unix/Makefile
parentda2d2b3bcbd105d57bf8a533e2103e4114fc9cd8 (diff)
Notes
Diffstat (limited to 'sysutils/ucspi-unix/Makefile')
-rw-r--r--sysutils/ucspi-unix/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/sysutils/ucspi-unix/Makefile b/sysutils/ucspi-unix/Makefile
new file mode 100644
index 000000000000..52b9ab65f309
--- /dev/null
+++ b/sysutils/ucspi-unix/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: ucspi-unix
+# Date created: 23.Sep.2003
+# Whom: patrick@rinke-bochum.de
+#
+# $FreeBSD$
+#
+
+PORTNAME= ucspi-unix
+PORTVERSION= 0.36
+CATEGORIES= sysutils
+MASTER_SITES= http://untroubled.org/ucspi-unix/
+
+MAINTAINER= patrick@rinke-bochum.de
+COMMENT= UNIX-domain socket client-server command-line tools
+
+BUILD_DEPENDS= bglibs.1:${PORTSDIR}/devel/bglibs
+
+USE_REINPLACE=yes
+
+pre-build:
+ ${ECHO_CMD} ${PREFIX} > ${WRKSRC}/conf-home
+ ${ECHO_CMD} ${CC} ${CFLAGS} > ${WRKSRC}/conf-cc
+
+do-install:
+ cd ${WRKSRC} && ./installer
+
+.include <bsd.port.mk>