aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ucspi-unix
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-19 15:16:31 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-19 15:16:31 +0000
commit7ca4fab46553c2ca8ffc13be5fe9ad91d81dd15e (patch)
tree55df6e792f10377645a33bbd555ced384f21b814 /sysutils/ucspi-unix
parent9dac3b8f761564835eac0768ee5b74bcb43d38cb (diff)
downloadports-7ca4fab46553c2ca8ffc13be5fe9ad91d81dd15e.tar.gz
ports-7ca4fab46553c2ca8ffc13be5fe9ad91d81dd15e.zip
Notes
Diffstat (limited to 'sysutils/ucspi-unix')
-rw-r--r--sysutils/ucspi-unix/Makefile22
-rw-r--r--sysutils/ucspi-unix/files/patch-Makefile56
-rw-r--r--sysutils/ucspi-unix/pkg-descr4
3 files changed, 69 insertions, 13 deletions
diff --git a/sysutils/ucspi-unix/Makefile b/sysutils/ucspi-unix/Makefile
index be2ebf4bee3a..d2a8e432d478 100644
--- a/sysutils/ucspi-unix/Makefile
+++ b/sysutils/ucspi-unix/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ucspi-unix
-# Date created: 23.Sep.2003
-# Whom: patrick@rinke-bochum.de
-#
+# Created by: Patrick Rinke <patrick@rinke-bochum.de>
# $FreeBSD$
-#
PORTNAME= ucspi-unix
PORTVERSION= 0.36
@@ -12,7 +8,9 @@ CATEGORIES= sysutils
MASTER_SITES= http://untroubled.org/${PORTNAME}/
MAINTAINER= ports@FreeBSD.org
-COMMENT= UNIX-domain socket client-server command-line tools
+COMMENT= Unix-domain socket client-server command-line tools
+
+LICENSE= GPLv2
BUILD_DEPENDS= ${BGLIBS_LIB}/libbg.a:${PORTSDIR}/devel/bglibs
@@ -25,7 +23,11 @@ PLIST_FILES= bin/unixcat bin/unixclient bin/unixserver
MAN1= unixclient.1 unixserver.1
PORTDOCS= NEWS PROTOCOL README TODO
-post-patch:
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+post-patch: .SILENT
${ECHO_CMD} "${PREFIX}" > ${WRKSRC}/conf-home
${ECHO_CMD} "${PREFIX}/bin" > ${WRKSRC}/conf-bin
${ECHO_CMD} "${MANPREFIX}/man" > ${WRKSRC}/conf-man
@@ -36,11 +38,9 @@ post-patch:
do-install:
cd ${WRKSRC} && ./installer
-
-.if !defined(NOPORTDOCS)
-post-install:
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/sysutils/ucspi-unix/files/patch-Makefile b/sysutils/ucspi-unix/files/patch-Makefile
new file mode 100644
index 000000000000..1c121fd9e8f9
--- /dev/null
+++ b/sysutils/ucspi-unix/files/patch-Makefile
@@ -0,0 +1,56 @@
+--- Makefile.orig 2002-06-11 05:12:06.000000000 +0800
++++ Makefile 2013-07-19 22:55:35.000000000 +0800
+@@ -19,8 +19,7 @@
+ echo 'source=$$1; shift'; \
+ echo 'base=`echo "$$source" | sed -e s:\\\\.c$$::`'; \
+ echo exec `head -1 conf-cc` '-I. -o $${base}.o -c $$source $${1+"$$@"}'; \
+- ) >compile
+- chmod 755 compile
++ ) >compile && chmod 755 compile
+
+ conf_bin.c: conf-bin
+ head -1 conf-bin | \
+@@ -38,37 +37,31 @@
+ ./compile env.c
+
+ installer: load insthier.o
+- ./load insthier -linstaller
+- mv insthier installer
++ ./load insthier -linstaller && mv insthier installer
+
+ instcheck: load insthier.o
+- ./load insthier -linstcheck
+- mv insthier instcheck
++ ./load insthier -linstcheck && mv insthier instcheck
+
+ insthier.o: compile insthier.c conf_bin.c conf_man.c
+ ./compile insthier.c
+
+ instshow: load insthier.o
+- ./load insthier -linstshow
+- mv insthier instshow
++ ./load insthier -linstshow && mv insthier instshow
+
+ load: conf-ld
+ ( echo '#!/bin/sh';\
+ echo 'main="$$1"; shift';\
+ echo exec `head -1 conf-ld` '-o "$$main" "$$main.o" $${1+"$$@"}' -lsysdeps;\
+- ) >load
+- chmod 755 load
++ ) >load && chmod 755 load
+
+ programs: unixclient unixserver unixcat
+
+ socket.lib: compile load trylib.c
+ ( ( ./compile trylib.c && ./load trylib -lsocket -lnsl ) >/dev/null 2>&1 \
+- && echo -lsocket -lnsl || exit 0 ) >socket.lib
+- rm -f trylib.o trylib
++ && echo -lsocket -lnsl || exit 0 ) >socket.lib && rm -f trylib.o trylib
+
+ unixcat: warn-auto.sh unixcat.sh
+- cat warn-auto.sh unixcat.sh >unixcat
+- chmod 755 unixcat
++ cat warn-auto.sh unixcat.sh >unixcat && chmod 755 unixcat
+
+ unixclient: load unixclient.o env.o utoa.o socket.lib
+ ./load unixclient env.o utoa.o `cat socket.lib`
diff --git a/sysutils/ucspi-unix/pkg-descr b/sysutils/ucspi-unix/pkg-descr
index 0a92e48f5132..e1d35a0dcdad 100644
--- a/sysutils/ucspi-unix/pkg-descr
+++ b/sysutils/ucspi-unix/pkg-descr
@@ -1,4 +1,4 @@
-UNIX domain socket client and server programs that conform to UCSPI,
-the UNIX Client-Server Program Interface.
+Unix domain socket client and server programs that conform to UCSPI, the
+Unix Client-Server Program Interface.
WWW: http://untroubled.org/ucspi-unix/