aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ucspi-unix
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2003-10-13 14:54:44 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2003-10-13 14:54:44 +0000
commit54bd8459036dbb6b25da31158872b14668273970 (patch)
tree1a787a4cfccae0944aab91e77e822415cfaf3580 /sysutils/ucspi-unix
parentda2d2b3bcbd105d57bf8a533e2103e4114fc9cd8 (diff)
downloadports-54bd8459036dbb6b25da31158872b14668273970.tar.gz
ports-54bd8459036dbb6b25da31158872b14668273970.zip
UNIX domain socket client and server programs that conform to UCSPI,
the UNIX Client-Server Program Interface. Submitted by: Patrick Rinke <patrick@rinke-bochum.de>
Notes
Notes: svn path=/head/; revision=91055
Diffstat (limited to 'sysutils/ucspi-unix')
-rw-r--r--sysutils/ucspi-unix/Makefile27
-rw-r--r--sysutils/ucspi-unix/distinfo1
-rw-r--r--sysutils/ucspi-unix/files/patch-Makefile11
-rw-r--r--sysutils/ucspi-unix/files/patch-conf-ld7
-rw-r--r--sysutils/ucspi-unix/files/patch-env.c11
-rw-r--r--sysutils/ucspi-unix/files/patch-insthier.c22
-rw-r--r--sysutils/ucspi-unix/files/patch-unixserver.c11
-rw-r--r--sysutils/ucspi-unix/pkg-descr4
-rw-r--r--sysutils/ucspi-unix/pkg-plist3
9 files changed, 97 insertions, 0 deletions
diff --git a/sysutils/ucspi-unix/Makefile b/sysutils/ucspi-unix/Makefile
new file mode 100644
index 000000000000..52b9ab65f309
--- /dev/null
+++ b/sysutils/ucspi-unix/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: ucspi-unix
+# Date created: 23.Sep.2003
+# Whom: patrick@rinke-bochum.de
+#
+# $FreeBSD$
+#
+
+PORTNAME= ucspi-unix
+PORTVERSION= 0.36
+CATEGORIES= sysutils
+MASTER_SITES= http://untroubled.org/ucspi-unix/
+
+MAINTAINER= patrick@rinke-bochum.de
+COMMENT= UNIX-domain socket client-server command-line tools
+
+BUILD_DEPENDS= bglibs.1:${PORTSDIR}/devel/bglibs
+
+USE_REINPLACE=yes
+
+pre-build:
+ ${ECHO_CMD} ${PREFIX} > ${WRKSRC}/conf-home
+ ${ECHO_CMD} ${CC} ${CFLAGS} > ${WRKSRC}/conf-cc
+
+do-install:
+ cd ${WRKSRC} && ./installer
+
+.include <bsd.port.mk>
diff --git a/sysutils/ucspi-unix/distinfo b/sysutils/ucspi-unix/distinfo
new file mode 100644
index 000000000000..56315df69c9a
--- /dev/null
+++ b/sysutils/ucspi-unix/distinfo
@@ -0,0 +1 @@
+MD5 (ucspi-unix-0.36.tar.gz) = 759407949912ccb860808ae2205e8a1a
diff --git a/sysutils/ucspi-unix/files/patch-Makefile b/sysutils/ucspi-unix/files/patch-Makefile
new file mode 100644
index 000000000000..356f28f8bbab
--- /dev/null
+++ b/sysutils/ucspi-unix/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig Tue Sep 23 16:31:18 2003
++++ Makefile Tue Sep 23 16:31:37 2003
+@@ -55,7 +55,7 @@
+ load: conf-ld
+ ( echo '#!/bin/sh';\
+ echo 'main="$$1"; shift';\
+- echo exec `head -1 conf-ld` '-o "$$main" "$$main.o" $${1+"$$@"}' -lsysdeps;\
++ echo exec `head -1 conf-ld` '-L/usr/local/lib -o "$$main" "$$main.o" $${1+"$$@"}' -lsysdeps;\
+ ) >load
+ chmod 755 load
+
diff --git a/sysutils/ucspi-unix/files/patch-conf-ld b/sysutils/ucspi-unix/files/patch-conf-ld
new file mode 100644
index 000000000000..20083382926d
--- /dev/null
+++ b/sysutils/ucspi-unix/files/patch-conf-ld
@@ -0,0 +1,7 @@
+--- conf-ld.orig Mon Sep 29 09:52:59 2003
++++ conf-ld Mon Sep 29 09:53:12 2003
+@@ -1,3 +1,3 @@
+-gcc -s -L/usr/local/bglibs/lib
++gcc -s -L/usr/local/include/bglibs
+
+ This will be used to link .o and .a files into an executable.
diff --git a/sysutils/ucspi-unix/files/patch-env.c b/sysutils/ucspi-unix/files/patch-env.c
new file mode 100644
index 000000000000..abb41bc30686
--- /dev/null
+++ b/sysutils/ucspi-unix/files/patch-env.c
@@ -0,0 +1,11 @@
+--- env.c.orig Tue Sep 23 15:57:55 2003
++++ env.c Tue Sep 23 15:59:52 2003
+@@ -1,7 +1,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <unistd.h>
+-#include <sysdeps.h>
++#include </usr/local/include/bglibs/sysdeps.h>
+
+ extern const char* utoa(unsigned long);
+
diff --git a/sysutils/ucspi-unix/files/patch-insthier.c b/sysutils/ucspi-unix/files/patch-insthier.c
new file mode 100644
index 000000000000..ef4e95d48294
--- /dev/null
+++ b/sysutils/ucspi-unix/files/patch-insthier.c
@@ -0,0 +1,22 @@
+--- insthier.c.orig Mon Jun 10 21:12:06 2002
++++ insthier.c Mon Sep 29 09:33:34 2003
+@@ -1,18 +1,11 @@
+-#include <installer.h>
++#include </usr/local/include/bglibs/installer.h>
+ #include "conf_bin.c"
+-#include "conf_man.c"
+
+ void insthier(void)
+ {
+ int bin = opendir(conf_bin);
+- int man = opendir(conf_man);
+- int man1;
+
+ c(bin, "unixcat", -1, -1, 0755);
+ c(bin, "unixclient", -1, -1, 0755);
+ c(bin, "unixserver", -1, -1, 0755);
+-
+- man1 = d(man, "man1", -1, -1, 0755);
+- c(man1, "unixclient.1", -1, -1, 0644);
+- c(man1, "unixserver.1", -1, -1, 0644);
+ }
diff --git a/sysutils/ucspi-unix/files/patch-unixserver.c b/sysutils/ucspi-unix/files/patch-unixserver.c
new file mode 100644
index 000000000000..448bc87a3d9f
--- /dev/null
+++ b/sysutils/ucspi-unix/files/patch-unixserver.c
@@ -0,0 +1,11 @@
+--- unixserver.c.orig Tue Sep 23 16:32:51 2003
++++ unixserver.c Tue Sep 23 16:33:34 2003
+@@ -7,7 +7,7 @@
+ #include <sys/un.h>
+ #include <sys/wait.h>
+ #include <unistd.h>
+-#include <sysdeps.h>
++#include </usr/local/include/bglibs/sysdeps.h>
+
+ extern void setup_env(int, const char*);
+
diff --git a/sysutils/ucspi-unix/pkg-descr b/sysutils/ucspi-unix/pkg-descr
new file mode 100644
index 000000000000..22de7cab4c5b
--- /dev/null
+++ b/sysutils/ucspi-unix/pkg-descr
@@ -0,0 +1,4 @@
+This package contains UNIX domain socket client and server programs that
+conform to UCSPI, the UNIX Client-Server Program Interface.
+
+WWW: http://untroubled.org/ucspi-unix/
diff --git a/sysutils/ucspi-unix/pkg-plist b/sysutils/ucspi-unix/pkg-plist
new file mode 100644
index 000000000000..8e9bdc0678aa
--- /dev/null
+++ b/sysutils/ucspi-unix/pkg-plist
@@ -0,0 +1,3 @@
+bin/unixserver
+bin/unixclient
+bin/unixcat