aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ufs_copy
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2005-07-03 13:58:06 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2005-07-03 13:58:06 +0000
commitaeae7f4dc75440e795f521fdabeb7b5eb21a55d1 (patch)
tree5fd6f0da9b3094d9283bb4dded1181192601a87e /sysutils/ufs_copy
parent3cc9578f16f73cdbcb7a1f304bcf74a8a0936ad6 (diff)
downloadports-aeae7f4dc75440e795f521fdabeb7b5eb21a55d1.tar.gz
ports-aeae7f4dc75440e795f521fdabeb7b5eb21a55d1.zip
Notes
Diffstat (limited to 'sysutils/ufs_copy')
-rw-r--r--sysutils/ufs_copy/Makefile32
-rw-r--r--sysutils/ufs_copy/distinfo2
-rw-r--r--sysutils/ufs_copy/files/patch-Makefile11
-rw-r--r--sysutils/ufs_copy/pkg-descr5
-rw-r--r--sysutils/ufs_copy/pkg-plist3
5 files changed, 53 insertions, 0 deletions
diff --git a/sysutils/ufs_copy/Makefile b/sysutils/ufs_copy/Makefile
new file mode 100644
index 000000000000..706870393ec1
--- /dev/null
+++ b/sysutils/ufs_copy/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: ufs_copy
+# Date created: 3 July 2005
+# Whom: MANTANI Nobutaka <nobutaka@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ufs_copy
+PORTVERSION= 20041015
+CATEGORIES= sysutils
+MASTER_SITES= http://people.freebsd.org/~simokawa/ufs/
+DISTNAME= ufs-${PORTVERSION}
+
+MAINTAINER= nobutaka@freebsd.org
+COMMENT= Fast copy utility for UFS filesystem
+
+WRKSRC= ${WRKDIR}/ufs
+MAKE_ARGS= BINDIR=${PREFIX}/sbin
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= FreeBSD 4.x does not have libufs
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/ufs_copy/distinfo b/sysutils/ufs_copy/distinfo
new file mode 100644
index 000000000000..2c69b47608d0
--- /dev/null
+++ b/sysutils/ufs_copy/distinfo
@@ -0,0 +1,2 @@
+MD5 (ufs-20041015.tar.gz) = ed3c249acecb80a9b9c5438fc823a514
+SIZE (ufs-20041015.tar.gz) = 8112
diff --git a/sysutils/ufs_copy/files/patch-Makefile b/sysutils/ufs_copy/files/patch-Makefile
new file mode 100644
index 000000000000..310e9dca487c
--- /dev/null
+++ b/sysutils/ufs_copy/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig Sun Jul 3 00:10:17 2005
++++ Makefile Sun Jul 3 00:10:38 2005
+@@ -4,7 +4,7 @@
+ PROG= ufs_copy
+ WARNS= 0
+ MAN=
+-NOSHARED?= YES
++NO_SHARED?= YES
+ LDADD= -lufs
+ CFLAGS+= -Wall -Wformat
+ BINDIR?= /sbin
diff --git a/sysutils/ufs_copy/pkg-descr b/sysutils/ufs_copy/pkg-descr
new file mode 100644
index 000000000000..7f2cf9226c1b
--- /dev/null
+++ b/sysutils/ufs_copy/pkg-descr
@@ -0,0 +1,5 @@
+The ufs_copy copies a UFS filesystem image like dd(1).
+It doesn't copy free blocks for speed and it generates a sparse destination
+file for saving space.
+
+WWW: http://people.freebsd.org/~simokawa/ufs/
diff --git a/sysutils/ufs_copy/pkg-plist b/sysutils/ufs_copy/pkg-plist
new file mode 100644
index 000000000000..eaf69d33f6a2
--- /dev/null
+++ b/sysutils/ufs_copy/pkg-plist
@@ -0,0 +1,3 @@
+sbin/ufs_copy
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%