aboutsummaryrefslogtreecommitdiff
path: root/sysutils/uif2iso/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-09-21 10:41:00 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-09-21 10:41:00 +0000
commitf7236404bcb593bacdbb2fda86c7fd80fd1e3a2b (patch)
treefb7bf3d786b1625e2e4fc53671c29c038affda55 /sysutils/uif2iso/Makefile
parent23008feac486eacdb25f253618ab7ff52099c8f8 (diff)
Notes
Diffstat (limited to 'sysutils/uif2iso/Makefile')
-rw-r--r--sysutils/uif2iso/Makefile32
1 files changed, 11 insertions, 21 deletions
diff --git a/sysutils/uif2iso/Makefile b/sysutils/uif2iso/Makefile
index 4b4f20ad1461..6cc9a342ea04 100644
--- a/sysutils/uif2iso/Makefile
+++ b/sysutils/uif2iso/Makefile
@@ -6,15 +6,20 @@
#
PORTNAME= uif2iso
-PORTVERSION= 0.1.7a
+PORTVERSION= 0.1.7c
CATEGORIES= sysutils
-MASTER_SITES= http://www.xs4all.nl/distfiles/
+MASTER_SITES= http://aluigi.altervista.org/mytoolz/
+DISTNAME= ${PORTNAME}
MAINTAINER= scjamorim@bsd.com.br
COMMENT= Convert MagicISO UIF files to ISO9660
+USE_ZIP= yes
+
+WRKSRC= ${WRKDIR}/src
+
PLIST_FILES= bin/uif2iso
-PORTDOCS= uif2iso.txt
+PORTDOCS= README uif2iso.txt
post-patch:
@${REINPLACE_CMD} 's|exit(1)|exit(0)|' ${WRKSRC}/uif2iso.c
@@ -23,24 +28,9 @@ post-patch:
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/uif2iso.txt ${DOCSDIR}
-.endif
-
-# Original files from author contain no version number and are not in
-# a separate directory.
-.if defined(MAINTAINER)
-distfile:
- rm -fr /tmp/${PORTNAME}-${PORTVERSION}
- mkdir /tmp/${PORTNAME}-${PORTVERSION}
- cd /tmp/${PORTNAME}-${PORTVERSION} && \
- fetch http://aluigi.altervista.org/mytoolz/${PORTNAME}.zip && \
- tar xf ${PORTNAME}.zip && \
- mv src/* . && \
- rm -rf ${PORTNAME}.zip *.exe src && \
- chmod 664 *
- cd /tmp && \
- tar cf ${PORTNAME}-${PORTVERSION}.tar.gz ${PORTNAME}-${PORTVERSION}
- rm -fr /tmp/${PORTNAME}-${PORTVERSION}
+.for docs in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKDIR}/${docs} ${DOCSDIR}
+.endfor
.endif
.include <bsd.port.mk>