aboutsummaryrefslogtreecommitdiff
path: root/sysutils/uif2iso/Makefile
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2008-03-31 07:30:00 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2008-03-31 07:30:00 +0000
commitf220848f981196175ca2072783ebf0953e2306c4 (patch)
treec85ae8cf401649aea7898af2221c73a8f43e9330 /sysutils/uif2iso/Makefile
parent97b023d23c8d54c1418e60e097443e0fc02d4fd3 (diff)
downloadports-f220848f981196175ca2072783ebf0953e2306c4.tar.gz
ports-f220848f981196175ca2072783ebf0953e2306c4.zip
Notes
Diffstat (limited to 'sysutils/uif2iso/Makefile')
-rw-r--r--sysutils/uif2iso/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/sysutils/uif2iso/Makefile b/sysutils/uif2iso/Makefile
index 733cba5bdedb..5bd2c67d78be 100644
--- a/sysutils/uif2iso/Makefile
+++ b/sysutils/uif2iso/Makefile
@@ -2,28 +2,31 @@
# Date created: 27 Jan 2008
# Whom: Martin Tournoij <carpetsmoker@xs4all.nl>
#
-# $Carpetsmoker: ports/sysutils/uif2iso/Makefile,v 1.2 2008/02/27 01:21:20 carpetsmoker Exp $
+# $Carpetsmoker: ports/sysutils/uif2iso/Makefile,v 1.3 2008/03/27 14:43:04 carpetsmoker Exp $
# $FreeBSD$
#
PORTNAME= uif2iso
-PORTVERSION= 0.1.2
+PORTVERSION= 0.1.3
CATEGORIES= sysutils
-MASTER_SITES= http://aluigi.altervista.org/mytoolz/ \
- http://www.carpetsmoker.net/distfiles/ \
- http://www.xs4all.nl/distfiles/
+MASTER_SITES= http://www.carpetsmoker.net/distfiles/ \
+ http://www.xs4all.nl/distfiles/ \
+ http://www.rwxrwxrwx.net/distfiles/
MAINTAINER= carpetsmoker@xs4all.nl
COMMENT= Convert MagicISO UIF files to ISO9660
-NO_WRKSUBDIR= yes
-EXTRACT_SUFX= .tgz
PLIST_FILES= bin/uif2iso
+PORTDOCS= uif2iso.txt
do-build:
- ${CC} -o ${WRKSRC}/${PORTNAME} ${CFLAGS} -lz ${WRKSRC}/uif2iso.c
+ ${CC} -o ${WRKSRC}/${PORTNAME} ${CFLAGS} -lz -lssl ${WRKSRC}/uif2iso.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/uif2iso ${PREFIX}/bin/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/uif2iso.txt ${DOCSDIR}
+.endif
.include <bsd.port.mk>