aboutsummaryrefslogtreecommitdiff
path: root/sysutils/unieject/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-07-23 14:19:52 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-07-23 14:19:52 +0000
commit899cf40ca3bd85f494ce387585b90dbb5fd1c64f (patch)
tree9202da193f9326be485d9c8e7042cd9244661294 /sysutils/unieject/Makefile
parentd5274e71936bdf429db360383abf7c9a2fb6e6df (diff)
Notes
Diffstat (limited to 'sysutils/unieject/Makefile')
-rw-r--r--sysutils/unieject/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/sysutils/unieject/Makefile b/sysutils/unieject/Makefile
new file mode 100644
index 000000000000..e730a909b366
--- /dev/null
+++ b/sysutils/unieject/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: unieject
+# Date created: 23 July 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= unieject
+DISTVERSION= 5.3.2
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ ${MASTER_SITE_BERLIOS}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Eject(1) replacement
+
+LIB_DEPENDS= cdio.7:${PORTSDIR}/sysutils/libcdio \
+ confuse.0:${PORTSDIR}/devel/libconfuse \
+ popt.0:${PORTSDIR}/devel/popt
+
+USE_GNOME= pkgconfig
+USE_LDCONFIG= yes
+USE_BZIP2= yes
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+MAN1= unieject.1
+MAN5= unieject.conf.5
+
+CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE} \
+ --with-libpopt-prefix=${LOCALBASE} --mandir=${MANPREFIX}/man
+
+post-patch:
+ ${REINPLACE_CMD} -e 's#if.*<<<$$DOXYFORMATS#if false#' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's#$$(libdir)/pkgconfig#${PREFIX}/libdata/pkgconfig#' ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -Ee 's#install-htmlDATA (install-man)#\1#' ${WRKSRC}/manpages/Makefile.in
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/unieject.conf.sample ${PREFIX}/etc/
+
+.include <bsd.port.mk>