aboutsummaryrefslogtreecommitdiff
path: root/sysutils/uniutils
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2015-10-24 16:48:48 +0000
committerThierry Thomas <thierry@FreeBSD.org>2015-10-24 16:48:48 +0000
commit477b01214244d01fead2905b9f5aeec0d16b139a (patch)
tree0ba9685d216ebed526310516efb31f036707715e /sysutils/uniutils
parent5870a701dea873fd6c9b2f605fbb28c5cfd96253 (diff)
downloadports-477b01214244d01fead2905b9f5aeec0d16b139a.tar.gz
ports-477b01214244d01fead2905b9f5aeec0d16b139a.zip
- Fix hard-coded endian assumption;
- Change /usr/local replacement from LOCALBASE -> PREFIX. PR: ports/203706 Submitted by: John Hein <z7dr6ut7gs (at) snkmail.com>
Notes
Notes: svn path=/head/; revision=400131
Diffstat (limited to 'sysutils/uniutils')
-rw-r--r--sysutils/uniutils/Makefile4
-rw-r--r--sysutils/uniutils/files/patch-utf8lookup11
2 files changed, 9 insertions, 6 deletions
diff --git a/sysutils/uniutils/Makefile b/sysutils/uniutils/Makefile
index aa0588366ff0..522819020f1d 100644
--- a/sysutils/uniutils/Makefile
+++ b/sysutils/uniutils/Makefile
@@ -3,7 +3,7 @@
PORTNAME= uniutils
PORTVERSION= 2.27
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils textproc
MASTER_SITES= http://billposer.org/Software/Downloads/
@@ -26,7 +26,7 @@ PORTDOCS= AUTHORS NEWS README
OPTIONS_DEFINE= DOCS EXAMPLES
pre-configure:
- ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' ${WRKSRC}/Makefile.in
${REINPLACE_CMD} -e 's|TestData|${EXAMPLESDIR}|' ${WRKSRC}/README
regression-test:
diff --git a/sysutils/uniutils/files/patch-utf8lookup b/sysutils/uniutils/files/patch-utf8lookup
index 556a3cb5dadc..12bf96dc0d1e 100644
--- a/sysutils/uniutils/files/patch-utf8lookup
+++ b/sysutils/uniutils/files/patch-utf8lookup
@@ -1,11 +1,14 @@
---- utf8lookup.orig Sun Jan 29 21:43:23 2006
-+++ utf8lookup Tue Jan 31 00:11:48 2006
-@@ -10,7 +10,7 @@
+--- utf8lookup.orig 2007-06-30 05:31:37 UTC
++++ utf8lookup
+@@ -8,9 +8,10 @@
+ # UTF-32 name
+ # 000543 ARMENIAN CAPITAL LETTER CHEH
#
++[ $(( $(printf '\1' | od -dAn) )) -eq 1 ] && end=le || end=be
echo 0x$1 | # feed command-line argument to ascii2binary's stdin
ascii2binary -t ui | # convert text to unsigned integer
-iconv -f utf32 -t utf8 | # convert utf-32 to utf-8 encoding
-+iconv -f ucs-4le -t utf-8 | # convert utf-32 to utf-8 encoding
++iconv -f ucs-4$end -t utf-8 | # convert utf-32 to utf-8 encoding
uniname -b -c -e -g # feed to uniname, suppressing byte and character offsets,
# UTF-8 encoding, and glyph