aboutsummaryrefslogtreecommitdiff
path: root/sysutils/uniutils
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2013-09-05 08:06:33 +0000
committerThierry Thomas <thierry@FreeBSD.org>2013-09-05 08:06:33 +0000
commit5fbc39252a595c1cad67289e4a471bba7cb9c35e (patch)
tree9db7f86a00644ca77488c38971a02304e7c756ff /sysutils/uniutils
parent23fc3a60cc288847da6aa0ee039393ad6095cb16 (diff)
downloadports-5fbc39252a595c1cad67289e4a471bba7cb9c35e.tar.gz
ports-5fbc39252a595c1cad67289e4a471bba7cb9c35e.zip
Fix with clang.
Since I'm there, define the license. Reported by: pkg-fallout
Notes
Notes: svn path=/head/; revision=326365
Diffstat (limited to 'sysutils/uniutils')
-rw-r--r--sysutils/uniutils/Makefile8
-rw-r--r--sysutils/uniutils/files/patch-unifuzz.c11
2 files changed, 14 insertions, 5 deletions
diff --git a/sysutils/uniutils/Makefile b/sysutils/uniutils/Makefile
index faf13831d054..4686ec34fec7 100644
--- a/sysutils/uniutils/Makefile
+++ b/sysutils/uniutils/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: unidesc
-# Date created: Sun 15 May 2005
-# Whom: thierry@pompo.net
-#
+# Created by: thierry@pompo.net
# $FreeBSD$
-#
PORTNAME= uniutils
PORTVERSION= 2.27
@@ -14,6 +10,8 @@ MASTER_SITES= http://billposer.org/Software/Downloads/
MAINTAINER= thierry@FreeBSD.org
COMMENT= Unicode Description Utilities
+LICENSE= GPLv3
+
RUN_DEPENDS= ascii2binary:${PORTSDIR}/converters/ascii2binary
GNU_CONFIGURE= yes
diff --git a/sysutils/uniutils/files/patch-unifuzz.c b/sysutils/uniutils/files/patch-unifuzz.c
new file mode 100644
index 000000000000..1cbf01b5fab0
--- /dev/null
+++ b/sysutils/uniutils/files/patch-unifuzz.c
@@ -0,0 +1,11 @@
+--- unifuzz.c.orig 2008-04-04 06:30:58.000000000 +0200
++++ unifuzz.c 2013-09-05 09:50:49.000000000 +0200
+@@ -97,7 +97,7 @@
+ }
+
+ /* Emit the middle character from each range */
+-EmitAllRanges(short AboveBMPP) {
++void EmitAllRanges(short AboveBMPP) {
+ int i;
+ UTF32 scp;
+ extern int Ranges_Defined;