aboutsummaryrefslogtreecommitdiff
path: root/sysutils/uptimed/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2002-10-10 20:00:43 +0000
committerWill Andrews <will@FreeBSD.org>2002-10-10 20:00:43 +0000
commit918c510872f2ff8556c8afe39e37d56770542866 (patch)
tree632ef7bd0a0d61069e59e46bfa0f1bcabef06a97 /sysutils/uptimed/Makefile
parente9082c927c5a6f3dfc906cfd301d5e1ec42405ec (diff)
downloadports-918c510872f2ff8556c8afe39e37d56770542866.tar.gz
ports-918c510872f2ff8556c8afe39e37d56770542866.zip
Notes
Diffstat (limited to 'sysutils/uptimed/Makefile')
-rw-r--r--sysutils/uptimed/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/sysutils/uptimed/Makefile b/sysutils/uptimed/Makefile
new file mode 100644
index 000000000000..3cfb3cfbd65d
--- /dev/null
+++ b/sysutils/uptimed/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: uptimed
+# Date created: 23 July 2002
+# Whom: Andy Fawcett <andy@athame.co.uk>
+#
+# $FreeBSD$
+
+PORTNAME= uptimed
+PORTVERSION= 0.2.0
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= uptimed
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= andy@athame.co.uk
+
+PREFIX= ${LOCALBASE}
+
+INSTALLS_SHLIB= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${LOCALBASE}
+
+USE_GMAKE= yes
+
+MAN1= uprecords.1
+MAN8= uptimed.8
+
+post-install:
+ ${INSTALL_SCRIPT} ${FILESDIR}/uptimed.sh.sample ${PREFIX}/etc/rc.d/
+ ${INSTALL_PROGRAM} ${PREFIX}/bin/uprecords ${PREFIX}/www/cgi-bin/uprecords.cgi
+ ${INSTALL_DATA} ${WRKSRC}/sample-cgi/* ${PREFIX}/www/cgi-bin/
+
+.include <bsd.port.mk>