aboutsummaryrefslogtreecommitdiff
path: root/sysutils/uptimed
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2002-10-10 20:00:43 +0000
committerWill Andrews <will@FreeBSD.org>2002-10-10 20:00:43 +0000
commit918c510872f2ff8556c8afe39e37d56770542866 (patch)
tree632ef7bd0a0d61069e59e46bfa0f1bcabef06a97 /sysutils/uptimed
parente9082c927c5a6f3dfc906cfd301d5e1ec42405ec (diff)
downloadports-918c510872f2ff8556c8afe39e37d56770542866.tar.gz
ports-918c510872f2ff8556c8afe39e37d56770542866.zip
Notes
Diffstat (limited to 'sysutils/uptimed')
-rw-r--r--sysutils/uptimed/Makefile33
-rw-r--r--sysutils/uptimed/distinfo1
-rw-r--r--sysutils/uptimed/files/uptimed.sh.sample16
-rw-r--r--sysutils/uptimed/pkg-comment1
-rw-r--r--sysutils/uptimed/pkg-descr9
-rw-r--r--sysutils/uptimed/pkg-plist12
6 files changed, 72 insertions, 0 deletions
diff --git a/sysutils/uptimed/Makefile b/sysutils/uptimed/Makefile
new file mode 100644
index 000000000000..3cfb3cfbd65d
--- /dev/null
+++ b/sysutils/uptimed/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: uptimed
+# Date created: 23 July 2002
+# Whom: Andy Fawcett <andy@athame.co.uk>
+#
+# $FreeBSD$
+
+PORTNAME= uptimed
+PORTVERSION= 0.2.0
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= uptimed
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= andy@athame.co.uk
+
+PREFIX= ${LOCALBASE}
+
+INSTALLS_SHLIB= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${LOCALBASE}
+
+USE_GMAKE= yes
+
+MAN1= uprecords.1
+MAN8= uptimed.8
+
+post-install:
+ ${INSTALL_SCRIPT} ${FILESDIR}/uptimed.sh.sample ${PREFIX}/etc/rc.d/
+ ${INSTALL_PROGRAM} ${PREFIX}/bin/uprecords ${PREFIX}/www/cgi-bin/uprecords.cgi
+ ${INSTALL_DATA} ${WRKSRC}/sample-cgi/* ${PREFIX}/www/cgi-bin/
+
+.include <bsd.port.mk>
diff --git a/sysutils/uptimed/distinfo b/sysutils/uptimed/distinfo
new file mode 100644
index 000000000000..934f0a7a8136
--- /dev/null
+++ b/sysutils/uptimed/distinfo
@@ -0,0 +1 @@
+MD5 (uptimed-0.2.0.tar.gz) = 6f9c87634a27eb4e1e8b38c7d771d4f4
diff --git a/sysutils/uptimed/files/uptimed.sh.sample b/sysutils/uptimed/files/uptimed.sh.sample
new file mode 100644
index 000000000000..004119ef423b
--- /dev/null
+++ b/sysutils/uptimed/files/uptimed.sh.sample
@@ -0,0 +1,16 @@
+#!/bin/sh
+case "$1" in
+start)
+ /usr/local/sbin/uptimed -b
+ echo -n ' uptimed'
+ /usr/local/sbin/uptimed
+ ;;
+stop)
+ ;;
+restart)
+ ;;
+*)
+ echo "Usage: ${0##*/}: { start | stop | restart }" 2>&1
+ exit 65
+ ;;
+esac
diff --git a/sysutils/uptimed/pkg-comment b/sysutils/uptimed/pkg-comment
new file mode 100644
index 000000000000..079204572fa0
--- /dev/null
+++ b/sysutils/uptimed/pkg-comment
@@ -0,0 +1 @@
+Rob Kaper's uptime daemon
diff --git a/sysutils/uptimed/pkg-descr b/sysutils/uptimed/pkg-descr
new file mode 100644
index 000000000000..4dca1115f1ab
--- /dev/null
+++ b/sysutils/uptimed/pkg-descr
@@ -0,0 +1,9 @@
+Uptimed is an uptime record daemon keeping track of the highest uptimes
+a computer system ever had. It uses the system boot time to keep sessions
+apart from each other. Uptimed comes with a console front-end to parse
+the records, which can also easily be used to show your records on a web page.
+
+WWW: http://www.unixcode.org/uptimed/
+
+- Andy Fawcett
+andy@athame.co.uk
diff --git a/sysutils/uptimed/pkg-plist b/sysutils/uptimed/pkg-plist
new file mode 100644
index 000000000000..9030455516cf
--- /dev/null
+++ b/sysutils/uptimed/pkg-plist
@@ -0,0 +1,12 @@
+bin/uprecords
+etc/uptimed.conf-dist
+lib/libuptimed.a
+lib/libuptimed.la
+lib/libuptimed.so
+lib/libuptimed.so.0
+sbin/uptimed
+etc/rc.d/uptimed.sh.sample
+www/cgi-bin/uprecords.cgi
+www/cgi-bin/uprecords.conf
+www/cgi-bin/uprecords.footer
+www/cgi-bin/uprecords.header