aboutsummaryrefslogtreecommitdiff
path: root/sysutils/usbhotkey
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 20:01:07 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 20:01:07 +0000
commit27d44119e7e106f32a4b4b25539a57a35cc68823 (patch)
tree8462df47de7a523e2debd710ebc0516911e33a43 /sysutils/usbhotkey
parentf3184698839707db08f51b1529956b01b49932cf (diff)
downloadports-27d44119e7e106f32a4b4b25539a57a35cc68823.tar.gz
ports-27d44119e7e106f32a4b4b25539a57a35cc68823.zip
Notes
Diffstat (limited to 'sysutils/usbhotkey')
-rw-r--r--sysutils/usbhotkey/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/sysutils/usbhotkey/Makefile b/sysutils/usbhotkey/Makefile
index c32a6e923136..08e2afa56ec0 100644
--- a/sysutils/usbhotkey/Makefile
+++ b/sysutils/usbhotkey/Makefile
@@ -12,25 +12,29 @@ COMMENT= A utility to remap USB keyboards under X11
LIB_DEPENDS= hid.0:${PORTSDIR}/devel/libhid \
Xtst.6:${PORTSDIR}/x11/libXtst
-OPTIONS= GUI "Enable GUI bits (Imlib dependency)" on
+OPTIONS_DEFINE= GUI
+OPTIONS_DEFAULT= GUI
+GUI_DESC= Enable GUI bits (Imlib dependency)
USE_RUBY= yes
USE_GMAKE= yes
HAS_CONFIGURE= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
CPPFLAGS+= -I${LOCALBASE}/include \
-I${LOCALBASE}/include/ruby-${RUBY_VER} \
-I${LOCALBASE}/include/ruby-${RUBY_VER}/${RUBY_ARCH}
LDFLAGS+= -L${LOCALBASE}/lib
-.if !defined(WITHOUT_GUI)
+.if ${PORT_OPTIONS:MGUI}
LIB_DEPENDS+= Imlib.5:${PORTSDIR}/graphics/imlib
.else
CONFIGURE_ARGS+= --without-Imlib
.endif
+.include <bsd.port.pre.mk>
+
.if ${RUBY_VER} == 1.9
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-main.c
.endif