aboutsummaryrefslogtreecommitdiff
path: root/sysutils/usermin/Makefile
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2004-06-20 10:53:14 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2004-06-20 10:53:14 +0000
commited3c9cc7f884cc9b10b66e1f4885c42a1d9c5bea (patch)
tree46a625699ed6036e73b58e970b765fb8a7017670 /sysutils/usermin/Makefile
parent3f3e6d58c7c731abdbf2d81ef33e5615d4bfec7e (diff)
downloadports-ed3c9cc7f884cc9b10b66e1f4885c42a1d9c5bea.tar.gz
ports-ed3c9cc7f884cc9b10b66e1f4885c42a1d9c5bea.zip
Notes
Diffstat (limited to 'sysutils/usermin/Makefile')
-rw-r--r--sysutils/usermin/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/sysutils/usermin/Makefile b/sysutils/usermin/Makefile
index a02493a5ae8f..2b7bb2304f43 100644
--- a/sysutils/usermin/Makefile
+++ b/sysutils/usermin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= usermin
PORTVERSION= 1.080
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= http://www.webmin.com/uupdates/ \
${MASTER_SITE_SOURCEFORGE}
@@ -41,7 +41,9 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e "s=%%PREFIX%%=${PREFIX}=" ${WRKSRC}/setup.sh
@${FIND} ${WRKSRC} -name "*.cgi" -print \
- | ${XARGS} ${REINPLACE_CMD} -e "s@/usr/local/bin/perl@${PERL}@"
+ | ${XARGS} ${REINPLACE_CMD} -e "s@#!/usr/local/bin/perl@#!${PERL}@"
+ @${FIND} ${WRKSRC} -name "*.pl" -print \
+ | ${XARGS} ${REINPLACE_CMD} -e "s@#!/usr/local/bin/perl@#!${PERL}@"
@${FIND} ${WRKSRC} -name "*.orig" -print | ${XARGS} ${RM}
@${FIND} ${WRKSRC} -name "*.bak" -print | ${XARGS} ${RM}
# we may have 2 levels of empty directories which cause the plist generation