aboutsummaryrefslogtreecommitdiff
path: root/sysutils/vobcopy
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2006-02-02 00:30:38 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2006-02-02 00:30:38 +0000
commit3008e126bdb3dd1fd7d5f01f6b8b7a70a7751fae (patch)
tree659d7dd1867f24ed5ee2bbea90e5231795221f5b /sysutils/vobcopy
parentb819c37bc4781573e3d84530cacf4dfa07c652cc (diff)
downloadports-3008e126bdb3dd1fd7d5f01f6b8b7a70a7751fae.tar.gz
ports-3008e126bdb3dd1fd7d5f01f6b8b7a70a7751fae.zip
Notes
Diffstat (limited to 'sysutils/vobcopy')
-rw-r--r--sysutils/vobcopy/Makefile1
-rw-r--r--sysutils/vobcopy/files/patch-dvd.c31
2 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/vobcopy/Makefile b/sysutils/vobcopy/Makefile
index 922b86a5efd5..77364b6e7fc1 100644
--- a/sysutils/vobcopy/Makefile
+++ b/sysutils/vobcopy/Makefile
@@ -7,6 +7,7 @@
PORTNAME= vobcopy
PORTVERSION= 0.5.16
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://lpn.rnbhq.org/download/
diff --git a/sysutils/vobcopy/files/patch-dvd.c b/sysutils/vobcopy/files/patch-dvd.c
new file mode 100644
index 000000000000..94bbfc9f0081
--- /dev/null
+++ b/sysutils/vobcopy/files/patch-dvd.c
@@ -0,0 +1,31 @@
+--- dvd.c.orig Wed Dec 7 21:31:56 2005
++++ dvd.c Wed Feb 1 22:23:15 2006
+@@ -692,28 +692,6 @@
+ /* fprintf(stderr,"debug: vob_size: %lli\n",buf.st_size); */
+ }
+ }
+- strcpy( stat_path, path_to_vobs3 );
+- strcat( stat_path, "_1.vob" );
+- if( ( tmp_streamin1 = fopen( stat_path, "r" ) ) != NULL ) /*check if this path is correct */
+- {
+- fclose ( tmp_streamin1 );
+- subvob = 1;
+- while( !stat( stat_path, &buf ) )
+- {
+- /* adjust path for next subvob */
+- subvob++;
+- strcpy( stat_path, path_to_vobs3 );
+- strcat( stat_path, "_" );
+- sprintf( temp1, "%d", subvob );
+- strcat( stat_path, temp1 );
+- strcat( stat_path, ".vob" );
+-
+- vob_size += buf.st_size;
+-/* fprintf(stderr,"debug: vob_size: %lli\n",vob_size); */
+-/* fprintf(stderr,"debug: vob_size: %lli\n",buf.st_size); */
+- }
+- }
+-
+ return ( off_t ) vob_size; /* think that (off_t) is not really needed here?
+ as it is defined as off_t and the function is
+ also defined as off_t */