aboutsummaryrefslogtreecommitdiff
path: root/sysutils/watchmen/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-07-17 18:57:31 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-07-17 18:57:31 +0000
commitf9877f51a24c6c26cdd41c9a4861a333453a83bd (patch)
tree3525a08a356f065fb9948fec9fc1831cfee68ba3 /sysutils/watchmen/Makefile
parentb0c0c9ed656189fd7b0e3a3d46857e8f791a80f2 (diff)
downloadports-f9877f51a24c6c26cdd41c9a4861a333453a83bd.tar.gz
ports-f9877f51a24c6c26cdd41c9a4861a333453a83bd.zip
Notes
Diffstat (limited to 'sysutils/watchmen/Makefile')
-rw-r--r--sysutils/watchmen/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/sysutils/watchmen/Makefile b/sysutils/watchmen/Makefile
new file mode 100644
index 000000000000..8ea6bfb0f95e
--- /dev/null
+++ b/sysutils/watchmen/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: watchmen
+# Date created: 2009-07-16
+# Whom: Oleg Alexeenkov <proler@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= watchmen
+PORTVERSION= 0.02
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= proler@gmail.com
+COMMENT= Watch and restart daemons
+
+RUN_DEPENDS+= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+USE_PERL5_RUN= yes
+POD2MAN?= pod2man
+
+MAN1= ${PORTNAME}.1
+PLIST_FILES= \
+ bin/${PORTNAME} \
+ etc/${PORTNAME}.conf.dist \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/watchmen/.packlist
+PLIST_DIRS=%%SITE_PERL%%/%%PERL_ARCH%%/auto/watchmen
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500805
+RUN_DEPENDS+= p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes
+.endif
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf.dist ${PREFIX}/etc
+
+.include <bsd.port.post.mk>