aboutsummaryrefslogtreecommitdiff
path: root/sysutils/webjob
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-04-05 00:39:58 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-04-05 00:39:58 +0000
commitb5ea715f9f3363d274af5b12850a5736adeb764f (patch)
treebd744694cb67fb92ef4e408cfd6648035819b16e /sysutils/webjob
parent91c1053d41890bb343d4869d8013844ef97f28fa (diff)
downloadports-b5ea715f9f3363d274af5b12850a5736adeb764f.tar.gz
ports-b5ea715f9f3363d274af5b12850a5736adeb764f.zip
Notes
Diffstat (limited to 'sysutils/webjob')
-rw-r--r--sysutils/webjob/Makefile8
-rw-r--r--sysutils/webjob/files/patch-configure17
-rw-r--r--sysutils/webjob/files/patch-configure.in13
-rw-r--r--sysutils/webjob/files/patch-src::config.h.in13
-rw-r--r--sysutils/webjob/files/patch-src::http.c57
-rw-r--r--sysutils/webjob/files/patch-src::ktypes.h12
-rw-r--r--sysutils/webjob/files/patch-src::webjob.c12
7 files changed, 125 insertions, 7 deletions
diff --git a/sysutils/webjob/Makefile b/sysutils/webjob/Makefile
index 6d018f6340fc..88d0aba57b03 100644
--- a/sysutils/webjob/Makefile
+++ b/sysutils/webjob/Makefile
@@ -32,13 +32,7 @@ CFLAGS+= -static
MAN1= webjob.1
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-BROKEN= "Configure fails on amd64"
-.endif
-
post-install:
@${STRIP_CMD} ${PREFIX}/bin/webjob
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/webjob/files/patch-configure b/sysutils/webjob/files/patch-configure
new file mode 100644
index 000000000000..8e216ecdfdc9
--- /dev/null
+++ b/sysutils/webjob/files/patch-configure
@@ -0,0 +1,17 @@
+diff -urP webjob-1.3.0/configure webjob-1.3.0.amd64/configure
+--- configure.orig Fri Jul 25 18:19:17 2003
++++ configure Sun Apr 4 23:52:02 2004
+@@ -1413,6 +1413,13 @@
+ _ACEOF
+
+ ;;
++amd64*)
++
++cat >>confdefs.h <<\_ACEOF
++#define K_CPU_AMD64 1
++_ACEOF
++
++ ;;
+ ia64*)
+
+ cat >>confdefs.h <<\_ACEOF
diff --git a/sysutils/webjob/files/patch-configure.in b/sysutils/webjob/files/patch-configure.in
new file mode 100644
index 000000000000..ec5a851bb87e
--- /dev/null
+++ b/sysutils/webjob/files/patch-configure.in
@@ -0,0 +1,13 @@
+diff -urP webjob-1.3.0/configure.in webjob-1.3.0.amd64/configure.in
+--- configure.in.orig Thu Jun 26 14:01:14 2003
++++ configure.in Sun Apr 4 23:47:36 2004
+@@ -87,6 +87,9 @@
+ alpha*)
+ AC_DEFINE(K_CPU_ALPHA, 1, Define to 1 if the host cpu is alpha.)
+ ;;
++amd64*)
++ AC_DEFINE(K_CPU_AMD64, 1, Define to 1 if the host cpu is amd64.)
++ ;;
+ ia64*)
+ AC_DEFINE(K_CPU_IA64, 1, Define to 1 if the host cpu is ia64.)
+ ;;
diff --git a/sysutils/webjob/files/patch-src::config.h.in b/sysutils/webjob/files/patch-src::config.h.in
new file mode 100644
index 000000000000..6b406243ab8c
--- /dev/null
+++ b/sysutils/webjob/files/patch-src::config.h.in
@@ -0,0 +1,13 @@
+diff -urP webjob-1.3.0/src/config.h.in webjob-1.3.0.amd64/src/config.h.in
+--- src/config.h.in.orig Fri Jul 25 18:19:19 2003
++++ src/config.h.in Sun Apr 4 23:52:03 2004
+@@ -161,6 +161,9 @@
+ /* Define to 1 if the host cpu is alpha. */
+ #undef K_CPU_ALPHA
+
++/* Define to 1 if the host cpu is amd64. */
++#undef K_CPU_AMD64
++
+ /* Define to 1 if the host cpu is iX86. */
+ #undef K_CPU_I386
+
diff --git a/sysutils/webjob/files/patch-src::http.c b/sysutils/webjob/files/patch-src::http.c
new file mode 100644
index 000000000000..c8e9c91497b3
--- /dev/null
+++ b/sysutils/webjob/files/patch-src::http.c
@@ -0,0 +1,57 @@
+diff -urP webjob-1.3.0/src/http.c webjob-1.3.0.amd64/src/http.c
+--- src/http.c.orig Wed Jul 23 15:16:07 2003
++++ src/http.c Sun Apr 4 23:49:52 2004
+@@ -144,7 +144,7 @@
+ sprintf(pcRequest, "%s %s%s%s HTTP/1.1\r\n"
+ "Host: %s:%d\r\n"
+ "Content-Type: application/octet-stream\r\n"
+-#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64)
++#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64) || defined(K_CPU_AMD64)
+ "Content-Length: %u\r\n"
+ #else
+ "Content-Length: %lu\r\n"
+@@ -166,7 +166,7 @@
+ sprintf(pcRequest, "%s %s%s%s HTTP/1.1\r\n"
+ "Host: %s:%d\r\n"
+ "Content-Type: application/octet-stream\r\n"
+-#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64)
++#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64) || defined(K_CPU_AMD64)
+ "Content-Length: %u\r\n"
+ #else
+ "Content-Length: %lu\r\n"
+@@ -1283,7 +1283,7 @@
+ */
+ if (ui32ContentLength > (K_UINT32) HTTP_MAX_MEMORY_SIZE)
+ {
+-#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64)
++#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64) || defined(K_CPU_AMD64)
+ snprintf(pcError, MESSAGE_SIZE, "%s: Content-Length = [%u] > [%u]: Length exceeds internally defined limit.",
+ #else
+ snprintf(pcError, MESSAGE_SIZE, "%s: Content-Length = [%lu] > [%lu]: Length exceeds internally defined limit.",
+@@ -1339,7 +1339,7 @@
+ }
+ if (ui32Offset != ui32ContentLength)
+ {
+-#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64)
++#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64) || defined(K_CPU_AMD64)
+ snprintf(pcError, MESSAGE_SIZE, "%s: Actual-Length = [%u] != [%u]: Actual-Length vs Content-Length Mismatch.",
+ #else
+ snprintf(pcError, MESSAGE_SIZE, "%s: Actual-Length = [%lu] != [%lu]: Actual-Length vs Content-Length Mismatch.",
+@@ -1409,7 +1409,7 @@
+ }
+ if (ui32Offset != ui32ContentLength)
+ {
+-#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64)
++#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64) || defined(K_CPU_AMD64)
+ snprintf(pcError, MESSAGE_SIZE, "%s: Actual-Length = [%u] != [%u]: Actual-Length vs Content-Length Mismatch.",
+ #else
+ snprintf(pcError, MESSAGE_SIZE, "%s: Actual-Length = [%lu] != [%lu]: Actual-Length vs Content-Length Mismatch.",
+@@ -2164,7 +2164,7 @@
+ */
+ if (psURL->ui32DownloadLimit != 0 && psResponseHeader->ui32ContentLength > psURL->ui32DownloadLimit)
+ {
+-#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64)
++#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64) || defined(K_CPU_AMD64)
+ snprintf(pcError, MESSAGE_SIZE, "%s: Content-Length = [%u] > [%u]: Length exceeds user defined limit.",
+ #else
+ snprintf(pcError, MESSAGE_SIZE, "%s: Content-Length = [%lu] > [%lu]: Length exceeds user defined limit.",
diff --git a/sysutils/webjob/files/patch-src::ktypes.h b/sysutils/webjob/files/patch-src::ktypes.h
new file mode 100644
index 000000000000..ec6a8617a819
--- /dev/null
+++ b/sysutils/webjob/files/patch-src::ktypes.h
@@ -0,0 +1,12 @@
+diff -urP webjob-1.3.0/src/ktypes.h webjob-1.3.0.amd64/src/ktypes.h
+--- src/ktypes.h.orig Sun Jun 15 22:49:21 2003
++++ src/ktypes.h Sun Apr 4 23:50:01 2004
+@@ -11,7 +11,7 @@
+ */
+
+ #if defined(UNIX)
+- #if defined(K_CPU_ALPHA) || defined(K_CPU_IA64)
++ #if defined(K_CPU_ALPHA) || defined(K_CPU_IA64) || defined(K_CPU_AMD64)
+ typedef char K_INT08;
+ typedef unsigned char K_UINT08;
+ typedef short K_INT16;
diff --git a/sysutils/webjob/files/patch-src::webjob.c b/sysutils/webjob/files/patch-src::webjob.c
new file mode 100644
index 000000000000..bf99196a6ff4
--- /dev/null
+++ b/sysutils/webjob/files/patch-src::webjob.c
@@ -0,0 +1,12 @@
+diff -urP webjob-1.3.0/src/webjob.c webjob-1.3.0.amd64/src/webjob.c
+--- src/webjob.c.orig Thu Jul 24 23:05:17 2003
++++ src/webjob.c Sun Apr 4 23:50:08 2004
+@@ -1478,7 +1478,7 @@
+ return ER;
+ }
+
+-#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64)
++#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64) || defined(K_CPU_AMD64)
+ sprintf(acQuery, "VERSION=%s&SYSTEM=%s&CLIENTID=%s&FILENAME=%s&RUNTYPE=%s&STDOUT_LENGTH=%u&STDERR_LENGTH=%u&STDENV_LENGTH=%u",
+ #else
+ sprintf(acQuery, "VERSION=%s&SYSTEM=%s&CLIENTID=%s&FILENAME=%s&RUNTYPE=%s&STDOUT_LENGTH=%lu&STDERR_LENGTH=%lu&STDENV_LENGTH=%lu",