aboutsummaryrefslogtreecommitdiff
path: root/sysutils/webmin/Makefile
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2001-03-28 09:29:20 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2001-03-28 09:29:20 +0000
commit96906f5359174bf48ea14944276afbbb5145c043 (patch)
tree7f0db51cb667245e3b2cc8376e8b33436a242107 /sysutils/webmin/Makefile
parent31bd66f65d264d3d5a840eb38cb1ab82bd6a51a1 (diff)
Notes
Diffstat (limited to 'sysutils/webmin/Makefile')
-rw-r--r--sysutils/webmin/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/sysutils/webmin/Makefile b/sysutils/webmin/Makefile
index b83d69421b14..61725e52f66d 100644
--- a/sysutils/webmin/Makefile
+++ b/sysutils/webmin/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= webmin
-PORTVERSION= 0.84
-PORTREVISION= 4
+PORTVERSION= 0.85
CATEGORIES= sysutils
MASTER_SITES= http://webadmin.sourceforge.net/webmin/updates/ \
http://webadmin.sourceforge.net/webmin/download/
@@ -23,15 +22,16 @@ USE_PERL5= yes
SCRIPTS_ENV+= WRKDIR="${WRKDIR}"
.if defined(WITH_UPDATES)
-WEBMIN_MODULES= apache.wbm.gz mysql.wbm.gz status.wbm.gz \
- file.wbm.gz dfsadmin-file.wbm.gz
+WEBMIN_MODULES=
.endif
post-extract:
.if defined(WITH_UPDATES)
- @for webmin_module in ${WEBMIN_MODULES}; do \
- ${TAR} xfz ${DISTDIR}/$${webmin_module} -C ${WRKSRC}; \
- done
+ if [ "${WEBMIN_MODULES}" != "" ]; then \
+ for webmin_module in "${WEBMIN_MODULES}"; do \
+ ${TAR} xfz ${DISTDIR}/$${webmin_module} -C ${WRKSRC}; \
+ done; \
+ fi
.endif
@find ${WRKSRC} -name "*.bak" | xargs ${RM}
@@ -78,6 +78,7 @@ do-install:
post-install:
@${CP} ${PLIST} ${TMPPLIST}
@find ${PREFIX}/lib/webmin -type f | ${SED} -e "s@${PREFIX}/@@" | sort >> ${TMPPLIST}
+ @find ${PREFIX}/lib/webmin -type l | ${SED} -e "s@${PREFIX}/@@" | sort >> ${TMPPLIST}
@find ${PREFIX}/lib/webmin -type d | ${SED} -e "s@${PREFIX}/@@" | ${PERL} -e 'print (join ("\n", reverse map ("\@dirrm " . substr ($$_, 0, -1), <STDIN>)) . "\n");' >> ${TMPPLIST}
@${CAT} ${PKGMESSAGE}