aboutsummaryrefslogtreecommitdiff
path: root/sysutils/webmin
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2012-03-12 21:28:17 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2012-03-12 21:28:17 +0000
commitb77961575a5303f7d2ffc27ad7525bb1c617309b (patch)
tree9875d4a05a54d2f4da6a1ba12bd3f3988352638e /sysutils/webmin
parent472db75cdccdf248d0260b4a20107c54a978e034 (diff)
downloadports-b77961575a5303f7d2ffc27ad7525bb1c617309b.tar.gz
ports-b77961575a5303f7d2ffc27ad7525bb1c617309b.zip
Notes
Diffstat (limited to 'sysutils/webmin')
-rw-r--r--sysutils/webmin/Makefile2
-rw-r--r--sysutils/webmin/files/patch-quota_freebsd-lib.pl23
2 files changed, 23 insertions, 2 deletions
diff --git a/sysutils/webmin/Makefile b/sysutils/webmin/Makefile
index 19398a17c1c9..d09f07b3d636 100644
--- a/sysutils/webmin/Makefile
+++ b/sysutils/webmin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= webmin
PORTVERSION= 1.580
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= http://download.webmin.com/updates/:up \
SF/webadmin/${PORTNAME}/${PORTVERSION}:sf \
diff --git a/sysutils/webmin/files/patch-quota_freebsd-lib.pl b/sysutils/webmin/files/patch-quota_freebsd-lib.pl
index b34984c8742e..559923c19bcd 100644
--- a/sysutils/webmin/files/patch-quota_freebsd-lib.pl
+++ b/sysutils/webmin/files/patch-quota_freebsd-lib.pl
@@ -3,7 +3,28 @@ $FreeBSD$
--- quota/freebsd-lib.pl.orig
+++ quota/freebsd-lib.pl
-@@ -240,11 +240,17 @@
+@@ -152,7 +152,9 @@
+ if (/^(\S+)$/) {
+ # Bogus wrapped line
+ $filesys{$n,'filesys'} = $1;
+- <QUOTA>=~/^.{15}(.{8}).(.{7})(.{8}).{8}(.{8}).(.{7})(.{8})/;
++ local $nl = <QUOTA>;
++ $nl =~ /^\s+(\S+)\s+(\S+)\s+(\S+)(.{8}\s+)(\S+)\s+(\S+)\s+(\S+)(.*)/ ||
++ $nl =~ /^.{15}(.{8}).(.{7})(.{8}).{8}(.{8}).(.{7})(.{8})/;
+ $filesys{$n,'ublocks'} = int($1);
+ $filesys{$n,'sblocks'} = int($2);
+ $filesys{$n,'hblocks'} = int($3);
+@@ -161,7 +163,8 @@
+ $filesys{$n,'hfiles'} = int($6);
+ $n++;
+ }
+- elsif (/^(.{15})(.{8}).(.{7})(.{8}).{8}(.{8}).(.{7})(.{8})/) {
++ elsif (/^\s*(\S+)\s+(\S+)\s+(\S+)\s+(\S+)(.{8}\s+)(\S+)\s+(\S+)\s+(\S+)(.*)/ ||
++ /^(.{15})(.{8}).(.{7})(.{8}).{8}(.{8}).(.{7})(.{8})/) {
+ $filesys{$n,'ublocks'} = int($2);
+ $filesys{$n,'sblocks'} = int($3);
+ $filesys{$n,'hblocks'} = int($4);
+@@ -240,11 +243,17 @@
@line = split(/\n/, $_[0]);
for($i=0; $i<@line; $i++) {
if ($line[$i] =~ /^(\S+): (blocks|kbytes) in use: (\d+), limits \(soft = (\d+), hard = (\d+)\)$/ && $1 eq $_[1]) {