aboutsummaryrefslogtreecommitdiff
path: root/sysutils/weedit
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2007-10-09 14:32:46 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2007-10-09 14:32:46 +0000
commit152b714ff78377eed14fc4c388683ee506740081 (patch)
tree984e2fac27ca24b98625814f6273d605053e5b67 /sysutils/weedit
parent14ed22050d7110553dbb7d7f2fbff0c19a347783 (diff)
downloadports-152b714ff78377eed14fc4c388683ee506740081.tar.gz
ports-152b714ff78377eed14fc4c388683ee506740081.zip
Add weedit, a file duplicate scanner with database support.
Notes
Notes: svn path=/head/; revision=201176
Diffstat (limited to 'sysutils/weedit')
-rw-r--r--sysutils/weedit/Makefile36
-rw-r--r--sysutils/weedit/distinfo3
-rw-r--r--sysutils/weedit/pkg-descr4
3 files changed, 43 insertions, 0 deletions
diff --git a/sysutils/weedit/Makefile b/sysutils/weedit/Makefile
new file mode 100644
index 000000000000..999a70c1e022
--- /dev/null
+++ b/sysutils/weedit/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: weedit
+# Date created: 9 Oct 2007
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= weedit
+PORTVERSION= 2.0.1
+CATEGORIES= sysutils
+MASTER_SITES= http://adm1n.cjb.net/cw/ \
+ http://critical.ch/distfiles/ \
+ http://energy.critical.ch/distfiles/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= File duplicate scanner with database support
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+SRCF= crc32 dlink weedit md5
+
+PLIST_FILES= bin/weedit bin/weeditreaddb
+
+do-build:
+.for f in ${SRCF}
+ ${CC} ${CFLAGS} -c ${WRKSRC}/${f}.c -o ${WRKSRC}/${f}.o
+.endfor
+ ${CC} ${CFLAGS} ${WRKSRC}/utils/readdb.c -o ${WRKSRC}/weeditreaddb
+ ${CC} ${LDFLAGS} -o ${WRKSRC}/${PORTNAME} \
+ ${SRCF:C/(.*)/${WRKSRC}\/\1.o/}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/weeditreaddb ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/sysutils/weedit/distinfo b/sysutils/weedit/distinfo
new file mode 100644
index 000000000000..520616a0953e
--- /dev/null
+++ b/sysutils/weedit/distinfo
@@ -0,0 +1,3 @@
+MD5 (weedit-2.0.1.tgz) = 0be21183ee88a6bbbd49d317650b69b6
+SHA256 (weedit-2.0.1.tgz) = 213781f8ecd929ad8902486b6da7b47d3a3bb908641cc8cde3d044fea4a3768f
+SIZE (weedit-2.0.1.tgz) = 20378
diff --git a/sysutils/weedit/pkg-descr b/sysutils/weedit/pkg-descr
new file mode 100644
index 000000000000..a50b64948ef6
--- /dev/null
+++ b/sysutils/weedit/pkg-descr
@@ -0,0 +1,4 @@
+weedit is a file duplicate scanner with database support. It uses CRC32, MD5,
+and file size to scan for duplicates.
+
+WWW: http://adm1n.cjb.net/cw/