aboutsummaryrefslogtreecommitdiff
path: root/sysutils/wmcube
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2010-01-20 15:22:02 +0000
committerRenato Botelho <garga@FreeBSD.org>2010-01-20 15:22:02 +0000
commit4f284116a49d800fc11c76851c58d9d6d5eccdd7 (patch)
tree70ec62a9aca99f18cc62b21b2c37a4da9d10f290 /sysutils/wmcube
parentd9ca159f55e8014373815aea5fd7f0fb985e035e (diff)
downloadports-4f284116a49d800fc11c76851c58d9d6d5eccdd7.tar.gz
ports-4f284116a49d800fc11c76851c58d9d6d5eccdd7.zip
Notes
Diffstat (limited to 'sysutils/wmcube')
-rw-r--r--sysutils/wmcube/Makefile3
-rw-r--r--sysutils/wmcube/files/patch-wmcube.c22
2 files changed, 15 insertions, 10 deletions
diff --git a/sysutils/wmcube/Makefile b/sysutils/wmcube/Makefile
index b03d148055ac..8ce6da9d353b 100644
--- a/sysutils/wmcube/Makefile
+++ b/sysutils/wmcube/Makefile
@@ -24,9 +24,6 @@ PORTDOCS= CHANGES README TODO
SUB_FILES= pkg-message
MAKE_JOBS_UNSAFE= yes
-post-patch:
- @${REINPLACE_CMD} -e '/include <utmp.h>/d' ${WRKSRC}/wmcube.c
-
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/wmcube ${PREFIX}/bin
@${CHMOD} g+s ${PREFIX}/bin/wmcube
diff --git a/sysutils/wmcube/files/patch-wmcube.c b/sysutils/wmcube/files/patch-wmcube.c
index b12d941b2450..b9aa5147d95c 100644
--- a/sysutils/wmcube/files/patch-wmcube.c
+++ b/sysutils/wmcube/files/patch-wmcube.c
@@ -1,6 +1,14 @@
--- wmcube.c.orig 2000-10-23 18:11:47.000000000 -0200
-+++ wmcube.c 2008-04-11 08:23:35.000000000 -0300
-@@ -125,6 +125,7 @@
++++ wmcube.c 2010-01-20 13:20:56.000000000 -0200
+@@ -42,7 +42,6 @@
+ #include <sys/ioctl.h>
+ #include <sys/socket.h>
+
+-#include <utmp.h>
+ #include <dirent.h>
+
+ #include <X11/Xlib.h>
+@@ -125,6 +124,7 @@
#ifdef FREEBSD
static kvm_t *kd;
static struct nlist nlst[] = { {"_cp_time"}, {0} };
@@ -8,7 +16,7 @@
#endif
int main(int argc, char **argv)
-@@ -913,7 +914,7 @@
+@@ -913,7 +913,7 @@
exit(0);
}
@@ -17,7 +25,7 @@
if (strcmp(tmp,"WMCUBE_COORDINATES") != 0) {
printf("\nError in objectfile: it must start with WMCUBE_COORDINATES\n\n");
-@@ -921,7 +922,7 @@
+@@ -921,7 +921,7 @@
exit(0);
}
@@ -26,7 +34,7 @@
counter = atoi(tmp);
while ((strcmp(tmp,"WMCUBE_LINES") != 0) && (strcmp(tmp,"WMCUBE_PLANES") != 0)) {
-@@ -938,7 +939,7 @@
+@@ -938,7 +938,7 @@
fclose(fp);
exit(0);
}
@@ -35,7 +43,7 @@
if (feof(fp)) {
printf("\nError in objectfile: you must have a section WMCUBE_LINES or WMCUBE_PLANES\n\n");
-@@ -1224,9 +1225,14 @@
+@@ -1224,9 +1224,14 @@
#include <nlist.h>
#include <fcntl.h>
#include <sys/dkstat.h>
@@ -50,7 +58,7 @@
if ((kd = kvm_open(NULL, NULL, NULL, O_RDONLY, "kvm_open")) == NULL)
{
-@@ -1249,6 +1255,13 @@
+@@ -1249,6 +1254,13 @@
int cpu,nice,system,idle;
unsigned long int cpu_time[CPUSTATES];