aboutsummaryrefslogtreecommitdiff
path: root/sysutils/wmfsm
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-02-04 22:44:33 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-02-04 22:44:33 +0000
commita01c32ad5f84d104244e2e6cfa75f4f2726ddd13 (patch)
treee8425718d93c74acdce8371c97c4df2223a34bc0 /sysutils/wmfsm
parent431f51597c510ea57f3314e1028efbf39e4e2499 (diff)
downloadports-a01c32ad5f84d104244e2e6cfa75f4f2726ddd13.tar.gz
ports-a01c32ad5f84d104244e2e6cfa75f4f2726ddd13.zip
Notes
Diffstat (limited to 'sysutils/wmfsm')
-rw-r--r--sysutils/wmfsm/Makefile23
-rw-r--r--sysutils/wmfsm/distinfo1
-rw-r--r--sysutils/wmfsm/files/patch-aa41
-rw-r--r--sysutils/wmfsm/files/patch-ab26
-rw-r--r--sysutils/wmfsm/pkg-comment1
-rw-r--r--sysutils/wmfsm/pkg-descr7
-rw-r--r--sysutils/wmfsm/pkg-plist1
7 files changed, 100 insertions, 0 deletions
diff --git a/sysutils/wmfsm/Makefile b/sysutils/wmfsm/Makefile
new file mode 100644
index 000000000000..b4204d2ba73e
--- /dev/null
+++ b/sysutils/wmfsm/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: wmfsm
+# Date created: 2 January 2001
+# Whom: Steven Enderle <panic@subphase.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmfsm
+PORTVERSION= 0.31
+CATEGORIES= sysutils windowmaker
+MASTER_SITES= http://netpedia.net/hosting/wmfsm/source/ \
+ http://e.dyn.mdn.de/mirror/wmfsm/
+
+MAINTAINER= panic@subphase.de
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/wmfsm
+
+MAKEFILE= Makefile.bsd
+
+USE_X_PREFIX= yes
+USE_XPM= yes
+
+.include <bsd.port.mk>
diff --git a/sysutils/wmfsm/distinfo b/sysutils/wmfsm/distinfo
new file mode 100644
index 000000000000..a28114071dd6
--- /dev/null
+++ b/sysutils/wmfsm/distinfo
@@ -0,0 +1 @@
+MD5 (wmfsm-0.31.tar.gz) = 9b47b44ed9102b8b659168383a0c379e
diff --git a/sysutils/wmfsm/files/patch-aa b/sysutils/wmfsm/files/patch-aa
new file mode 100644
index 000000000000..1e768f203b14
--- /dev/null
+++ b/sysutils/wmfsm/files/patch-aa
@@ -0,0 +1,41 @@
+
+$FreeBSD$
+
+--- wmfsm.c.orig Thu Aug 26 09:42:39 1999
++++ wmfsm.c Mon Feb 5 00:38:13 2001
+@@ -59,7 +59,7 @@
+ #elif defined(SunOS)
+ # define STATFS(a,b) statfs(a,b,sizeof(struct statfs),0)
+ # include <sys/statfs.h>
+-#elif defined(__OpenBSD__)
++#elif defined(__OpenBSD__) || defined(__FreeBSD__)
+ # define STATFS(a,b) statfs(a,b)
+ # include <sys/param.h>
+ # include <sys/mount.h>
+@@ -362,7 +362,7 @@
+
+ void readFileSystems(){
+ /* Look for the goods between #if defined(__OpenBSD__) -- tschroed */
+-#if defined(__OpenBSD__)
++#if defined(__OpenBSD__) || defined(__FreeBSD__)
+ #define MAXMOUNT 32
+ struct statfs sfs[MAXMOUNT];
+ int fscount;
+@@ -379,7 +379,7 @@
+ { numberfs--; fscount--; }
+ else
+ mp[numberfs]=strdup(sfs[numberfs].f_mntonname);
+-#else /* __OpenBSD__ */
++#else /* __OpenBSD__ || __FreeBSD__ */
+
+ FILE *fp;
+ char mountPoint[255],dummy[255],fstype[255],options[255];
+@@ -424,7 +424,7 @@
+ mp[numberfs++]=strdup(mountPoint);
+ }
+ }
+-#endif /* __OpenBSD__ */
++#endif /* __OpenBSD__ || __FreeBSD__ */
+ excludeFileSystems();
+ }
+ void excludeFileSystems(){
diff --git a/sysutils/wmfsm/files/patch-ab b/sysutils/wmfsm/files/patch-ab
new file mode 100644
index 000000000000..78dacc52bc55
--- /dev/null
+++ b/sysutils/wmfsm/files/patch-ab
@@ -0,0 +1,26 @@
+
+$FreeBSD$
+
+--- Makefile.bsd.orig Wed Jun 16 09:54:34 1999
++++ Makefile.bsd Mon Feb 5 00:38:13 2001
+@@ -1,9 +1,9 @@
+-CC = gcc
++CC ?= gcc
+ #CC = /usr/pure/purify-4.1-irix6/purify cc
+-CFLAGS =
+-INCDIR = -I/usr/X11R6/include/X11 -I/home/p-sgi2/eilemann/IRIX64/include -I/usr/X11R6/include
+-DESTDIR= /usr/X11R6
+-LIBDIR = -L/usr/X11R6/lib
++CFLAGS +=
++INCDIR = -I${X11BASE}/include/X11 -I${X11BASE}/include
++DESTDIR= ${PREFIX}
++LIBDIR = -L${X11BASE}/lib
+ # for linux & irix
+ LIBS = -lXpm -lX11 -lXext
+
+@@ -33,4 +33,4 @@
+ rm -f wmfsm
+
+ install:: wmfsm
+- install -s -m 0755 wmfsm $(DESTDIR)/bin
++ ${BSD_INSTALL_PROGRAM} wmfsm $(DESTDIR)/bin
diff --git a/sysutils/wmfsm/pkg-comment b/sysutils/wmfsm/pkg-comment
new file mode 100644
index 000000000000..0fae2d17939e
--- /dev/null
+++ b/sysutils/wmfsm/pkg-comment
@@ -0,0 +1 @@
+Displays filesystem usage of mountpoints in a nice WindowMaker dockapp
diff --git a/sysutils/wmfsm/pkg-descr b/sysutils/wmfsm/pkg-descr
new file mode 100644
index 000000000000..a5284604ce61
--- /dev/null
+++ b/sysutils/wmfsm/pkg-descr
@@ -0,0 +1,7 @@
+Wmfsm monitors your filesystem usage. It features three display modes,
+different colorschemes and exclusion of filesystems (eg /cdrom).
+
+WWW: http://freshmeat.net/projects/wmfsm/homepage/
+
+- Steven
+panic@subphase.de
diff --git a/sysutils/wmfsm/pkg-plist b/sysutils/wmfsm/pkg-plist
new file mode 100644
index 000000000000..9fe9ee480f38
--- /dev/null
+++ b/sysutils/wmfsm/pkg-plist
@@ -0,0 +1 @@
+bin/wmfsm