aboutsummaryrefslogtreecommitdiff
path: root/sysutils/wmmount
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:37:35 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:37:35 +0000
commitcfbbad11c967c68017361159bd04d46e52fd4d95 (patch)
treef179ea891d920e4c53ffe5557036aa2ebbed379f /sysutils/wmmount
parente496d3c2790afd2dd1acf6d85fc50885becd065b (diff)
downloadports-cfbbad11c967c68017361159bd04d46e52fd4d95.tar.gz
ports-cfbbad11c967c68017361159bd04d46e52fd4d95.zip
Notes
Diffstat (limited to 'sysutils/wmmount')
-rw-r--r--sysutils/wmmount/Makefile6
-rw-r--r--sysutils/wmmount/files/patch-dockapp.c11
-rw-r--r--sysutils/wmmount/files/patch-wmmount.c11
3 files changed, 24 insertions, 4 deletions
diff --git a/sysutils/wmmount/Makefile b/sysutils/wmmount/Makefile
index ec7a506dfea6..e450938eda95 100644
--- a/sysutils/wmmount/Makefile
+++ b/sysutils/wmmount/Makefile
@@ -7,6 +7,7 @@
PORTNAME= wmmount
PORTVERSION= 1.0b2
+PORTREVISION= 1
CATEGORIES= sysutils windowmaker afterstep
MASTER_SITES= http://www.geocities.com/SiliconValley/Vista/2471/files/
DISTNAME= ${PORTNAME}-1.0-beta2
@@ -15,15 +16,12 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= The freespace for Window Maker
+USE_GETOPT_LONG=yes
USE_IMAKE= yes
USE_XPM= yes
USE_REINPLACE= yes
MAKE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lgnugetopt
-
post-patch:
.for file in system.wmmount.eg system.wmmount.sh
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/config/${file}
diff --git a/sysutils/wmmount/files/patch-dockapp.c b/sysutils/wmmount/files/patch-dockapp.c
new file mode 100644
index 000000000000..de01dbd9c0ce
--- /dev/null
+++ b/sysutils/wmmount/files/patch-dockapp.c
@@ -0,0 +1,11 @@
+--- dockapp.c.orig Fri Jun 18 04:41:41 1999
++++ dockapp.c Mon Jul 7 04:34:44 2003
+@@ -89,7 +89,7 @@
+ dockapp_argv=argv;
+ while(true) {
+ option_index=0;
+- option_c=getopt_long_only(argc, argv, "-hwsaf:b:", long_options, &option_index);
++ option_c=getopt_long(argc, argv, "-hwsaf:b:", long_options, &option_index);
+ if(option_c==-1)
+ break;
+ if(option_c==0) {
diff --git a/sysutils/wmmount/files/patch-wmmount.c b/sysutils/wmmount/files/patch-wmmount.c
new file mode 100644
index 000000000000..384f2520dd57
--- /dev/null
+++ b/sysutils/wmmount/files/patch-wmmount.c
@@ -0,0 +1,11 @@
+--- wmmount.c.orig Fri Jun 18 04:41:41 1999
++++ wmmount.c Mon Jul 7 04:35:33 2003
+@@ -231,7 +231,7 @@
+ };
+ while(true) {
+ option_index=0;
+- option_c=getopt_long_only(argc, (char * const *)argv, "-h", long_options, &option_index);
++ option_c=getopt_long(argc, (char * const *)argv, "-h", long_options, &option_index);
+ if(option_c==-1)
+ break;
+ if(option_c==1) {