aboutsummaryrefslogtreecommitdiff
path: root/sysutils/wmtop
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2001-02-26 03:37:42 +0000
committerSteve Price <steve@FreeBSD.org>2001-02-26 03:37:42 +0000
commit19bec0e53c95e0ef7e8bb0c5f526c11b6b4e06e1 (patch)
tree44c86adf23981907011551c2e78c3f0a806d4d38 /sysutils/wmtop
parentd8f88d6f7b0fe347a1bb48745c2adbe00a774774 (diff)
downloadports-19bec0e53c95e0ef7e8bb0c5f526c11b6b4e06e1.tar.gz
ports-19bec0e53c95e0ef7e8bb0c5f526c11b6b4e06e1.zip
Notes
Diffstat (limited to 'sysutils/wmtop')
-rw-r--r--sysutils/wmtop/Makefile5
-rw-r--r--sysutils/wmtop/distinfo2
-rw-r--r--sysutils/wmtop/files/patch-ab55
3 files changed, 59 insertions, 3 deletions
diff --git a/sysutils/wmtop/Makefile b/sysutils/wmtop/Makefile
index aff6d0efcc06..2762280265bc 100644
--- a/sysutils/wmtop/Makefile
+++ b/sysutils/wmtop/Makefile
@@ -5,9 +5,10 @@
# $FreeBSD$
PORTNAME= wmtop
-PORTVERSION= 0.81
+PORTVERSION= 0.83
CATEGORIES= sysutils
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= http://wmtop.sourceforge.net/ \
+ ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= wmtop@tanelorn.demon.co.uk
diff --git a/sysutils/wmtop/distinfo b/sysutils/wmtop/distinfo
index e29a03659d7b..4313f64cb748 100644
--- a/sysutils/wmtop/distinfo
+++ b/sysutils/wmtop/distinfo
@@ -1 +1 @@
-MD5 (wmtop-0.81.tar.gz) = 76c520de993daf649a34a0a6981b8628
+MD5 (wmtop-0.83.tar.gz) = 948bdcbd0b18c119532153d1ec20ee64
diff --git a/sysutils/wmtop/files/patch-ab b/sysutils/wmtop/files/patch-ab
new file mode 100644
index 000000000000..58178b734998
--- /dev/null
+++ b/sysutils/wmtop/files/patch-ab
@@ -0,0 +1,55 @@
+--- wmtop.c.orig Wed May 17 05:08:20 2000
++++ wmtop.c Wed Sep 20 03:48:43 2000
+@@ -78,6 +78,10 @@
+ */
+ int mode = 0;
+
++#if defined(FREEBSD)
++int show_system = 0;
++#endif
++
+ #if defined(DEBUG)
+ /*
+ * Memory handler
+@@ -234,7 +238,7 @@
+ char deparenthesised_name[WMTOP_BUFLENGTH];
+ #endif /* defined(LINUX) */
+ #if defined(FREEBSD)
+- int us,um,ks,km;
++ int us,um,ks,km,ppid;
+ #endif /* defined(FREEBSD) */
+
+ #if defined(PARANOID)
+@@ -298,11 +302,18 @@
+ * Extract cpu times from data in /proc/<pid>/stat
+ * XXX: Process name extractor for FreeBSD is untested right now.
+ */
+- rc = sscanf(line,"%s %*s %*s %*s %*s %*s %*s %*s %d,%d %d,%d",
+- procname,
++ rc = sscanf(line,"%s %*s %d %*s %*s %*s %*s %*s %d,%d %d,%d",
++ procname, &ppid,
+ &us,&um,&ks,&km);
+ if (rc<5)
+ return 1;
++
++ if (ppid == 0 && !show_system)
++ {
++ process->time_stamp=0;
++ return 1;
++ }
++
+ if (process->name)
+ wmtop_free(process->name);
+ process->name = wmtop_strdup(procname);
+@@ -725,6 +736,11 @@
+ i++;
+ }
+ break;
++#if defined (FREEBSD)
++ case 'S':
++ show_system = 1;
++ break;
++#endif
+ case 'r':
+ if (argc > (i+1)) {
+ refresh_rate = (atoi(argv[i+1]) * 1000);